aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-08-18 16:38:12 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-18 16:55:34 +0000
commit25ca96997fd0e23eebca7c143510000ad2743f76 (patch)
tree9d5635970a4a390ad67abe8f9d72a5c99da1e718
parent5d7aff9db9e0af5ee428da293202fe0fb1f51987 (diff)
downloadports-25ca96997fd0e23eebca7c143510000ad2743f76.tar.gz
ports-25ca96997fd0e23eebca7c143510000ad2743f76.zip
devel/intel-graphics-compiler: note llvm10 (production) flavor cannot be exposed
llvm11 is considered experimental but llvm10 doesn't work for us: FAILED: bin/built_ins/x64/gen12lp/bindful_aux_translation_Gen12LPlp.spv /wrkdirs/usr/ports/lang/intel-compute-runtime/work-llvm10/.build/bin/built_ins/x64/gen12lp/bindful_aux_translation_Gen12LPlp.spv cd /wrkdirs/usr/ports/lang/intel-compute-runtime/work-llvm10/compute-runtime-21.32.20609/shared/source/built_ins/kernels && LD_LIBRARY_PATH=/wrkdirs/usr/ports/lang/intel-compute-runtime/work-llvm10/.build/bin /wrkdirs/usr/ports/lang/intel-compute-runtime/work-llvm10/.build/bin/ocloc -q -file aux_translation.builtin_kernel -spv_only -device tgllp -64 -output bindful_aux_translation -out_dir /wrkdirs/usr/ports/lang/intel-compute-runtime/work-llvm10/.build/bin/built_ins/x64/gen12lp -options -cl-kernel-arg-info : CommandLine Error: Option 'mc-relax-all' registered more than once! LLVM ERROR: inconsistency in registered CommandLine options https://github.com/intel/intel-graphics-compiler/blob/igc-1.0.8365/documentation/build_ubuntu.md#version-overview
-rw-r--r--devel/intel-graphics-compiler/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/intel-graphics-compiler/Makefile b/devel/intel-graphics-compiler/Makefile
index c52bff10a570..f1dfd1805a1d 100644
--- a/devel/intel-graphics-compiler/Makefile
+++ b/devel/intel-graphics-compiler/Makefile
@@ -17,6 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= Only Intel GPUs on x86 are supported
+# llvm10 is unstable, see https://github.com/intel/compute-runtime/issues/431
BUILD_DEPENDS= vc-intrinsics-llvm11>=s20210730:devel/vc-intrinsics@llvm11
LIB_DEPENDS= libopencl-clang.so.11:devel/opencl-clang@llvm11