aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBradley T. Hughes <bhughes@FreeBSD.org>2021-10-14 13:53:30 +0000
committerBradley T. Hughes <bhughes@FreeBSD.org>2021-10-14 18:31:11 +0000
commit25cf6ee9a998c92ffc86f8fa8e6bbd96d9d32e76 (patch)
tree105790140d03dcbb8d8f082438f83a3bf7220a1a
parent63d429cab2cd5a4710d4ca3deb3c351edc4ad7b8 (diff)
downloadports-25cf6ee9a998c92ffc86f8fa8e6bbd96d9d32e76.tar.gz
ports-25cf6ee9a998c92ffc86f8fa8e6bbd96d9d32e76.zip
www/node: Update 16.10.0 -> 16.11.0
MFH: 2021Q4 Sponsored by: Miles AS
-rw-r--r--www/node/Makefile4
-rw-r--r--www/node/distinfo6
-rw-r--r--www/node/files/patch-deps_v8_src_libsampler_sampler.cc4
3 files changed, 7 insertions, 7 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index 31f125a3e19d..1085a5647eea 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -1,6 +1,6 @@
PORTNAME= node
DISTVERSIONPREFIX= v
-DISTVERSION= 16.10.0
+DISTVERSION= 16.11.0
CATEGORIES= www
MASTER_SITES= https://nodejs.org/dist/v${DISTVERSION}/
@@ -70,7 +70,7 @@ MAKE_ENV+= CC.host=${CC} CFLAGS.host="${CFLAGS}" \
BUILD_DEPENDS+= brotli>=1.0.9,1:archivers/brotli \
c-ares>=1.17.2:dns/c-ares \
libuv>=1.42.0:devel/libuv \
- libnghttp2>=1.42.0:www/libnghttp2 \
+ libnghttp2>=1.45.1:www/libnghttp2 \
objdump:devel/binutils
LIB_DEPENDS+= libbrotlidec.so:archivers/brotli \
libcares.so:dns/c-ares \
diff --git a/www/node/distinfo b/www/node/distinfo
index cf3dfe8f75ac..f310dae5365d 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1632405515
-SHA256 (node-v16.10.0.tar.gz) = 69b09bb0c4cd9add7eb501b1625a405b15d6ce53596e98b863c8d066e0b6b202
-SIZE (node-v16.10.0.tar.gz) = 64661120
+TIMESTAMP = 1633729788
+SHA256 (node-v16.11.0.tar.gz) = a070b0f57cf0851d959d6d8caa4e3fc24a34998ccf1f4ad68abfaa6103fbb6fd
+SIZE (node-v16.11.0.tar.gz) = 63667994
diff --git a/www/node/files/patch-deps_v8_src_libsampler_sampler.cc b/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
index 8a0fbeeda3d6..13dee5483046 100644
--- a/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
+++ b/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
@@ -1,6 +1,6 @@
---- deps/v8/src/libsampler/sampler.cc.orig 2021-04-20 11:30:13 UTC
+--- deps/v8/src/libsampler/sampler.cc.orig 2021-10-08 13:38:46 UTC
+++ deps/v8/src/libsampler/sampler.cc
-@@ -488,6 +488,10 @@ void SignalHandler::FillRegisterState(void* context, R
+@@ -490,6 +490,10 @@ void SignalHandler::FillRegisterState(void* context, R
state->pc = reinterpret_cast<void*>(mcontext.__gregs[_REG_PC]);
state->sp = reinterpret_cast<void*>(mcontext.__gregs[_REG_SP]);
state->fp = reinterpret_cast<void*>(mcontext.__gregs[_REG_FP]);