aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2024-06-17 08:32:22 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2024-06-17 08:35:03 +0000
commit2612aa236edb789960eaa10420b008de8da148b7 (patch)
tree0b7e37867ec5e80b84255ba7b89a12609010ed73
parent126aa7a0f6a8e574dc203c440977ddc2e16b74c8 (diff)
downloadports-2612aa236edb789960eaa10420b008de8da148b7.tar.gz
ports-2612aa236edb789960eaa10420b008de8da148b7.zip
mail/mlmmj: reduce the number of dependencies necessary to build
Use the "testing" Feature" to activate testing PR: 278665
-rw-r--r--Mk/bsd.options.mk1
-rw-r--r--mail/mlmmj/Makefile11
2 files changed, 11 insertions, 1 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 964b817ff706..3b4b2dd4d300 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -472,6 +472,7 @@ SUBPACKAGES+= ${${opt}_SUBPACKAGES_OFF}
. endif
. endif
. endfor
+
. for opt in ${_REALLY_ALL_POSSIBLE_OPTIONS}
# PLIST_SUB
PLIST_SUB?=
diff --git a/mail/mlmmj/Makefile b/mail/mlmmj/Makefile
index 07083d48165e..15ed1f053f6d 100644
--- a/mail/mlmmj/Makefile
+++ b/mail/mlmmj/Makefile
@@ -27,8 +27,9 @@ PERL_RUN_DEPENDS= p5-URI>0:net/p5-URI \
p5-HTML-Parser>0:www/p5-HTML-Parser
PHP_USES= php:web
-BUILD_DEPENDS= kyua:devel/kyua \
+TEST_DEPENDS= kyua:devel/kyua \
atf-sh:devel/atf
+TEST_TARGET= check
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@@ -45,4 +46,12 @@ post-install-PHP-on:
@(cd ${WRKSRC}/contrib/web && ${COPYTREE_SHARE} "php-*" \
${STAGEDIR}${WWWDIR})
+.include <bsd.port.options.mk>
+
+.if defined(WITH_TESTING)
+CONFIGURE_ARGS+= --enable-tests
+.else
+CONFIGURE_ARGS+= --disable-tests
+.endif
+
.include <bsd.port.mk>