aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-01-06 01:35:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-01-06 01:55:22 +0000
commit26553ca00e2a8b6beedae1552fb5c3a940255a58 (patch)
tree3e8923f75c3be4e60915ef07b3d8a1710cfd172d
parent5010ffc75ceb8d55a0d4a4770790a27a8a28df33 (diff)
downloadports-26553ca00e2a8b6beedae1552fb5c3a940255a58.tar.gz
ports-26553ca00e2a8b6beedae1552fb5c3a940255a58.zip
www/py-flask-jwt: New port: JWT token authentication for Flask apps
-rw-r--r--www/Makefile1
-rw-r--r--www/py-flask-jwt/Makefile20
-rw-r--r--www/py-flask-jwt/distinfo3
-rw-r--r--www/py-flask-jwt/pkg-descr1
4 files changed, 25 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3b97a3c2736b..07df1104afb0 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1642,6 +1642,7 @@
SUBDIR += py-flask-cors
SUBDIR += py-flask-flatpages
SUBDIR += py-flask-json
+ SUBDIR += py-flask-jwt
SUBDIR += py-flask-jwt-extended
SUBDIR += py-flask-limiter
SUBDIR += py-flask-login
diff --git a/www/py-flask-jwt/Makefile b/www/py-flask-jwt/Makefile
new file mode 100644
index 000000000000..5dc4d19f7987
--- /dev/null
+++ b/www/py-flask-jwt/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= Flask-JWT
+DISTVERSION= 0.3.2
+CATEGORIES= www python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= JWT token authentication for Flask apps
+WWW= https://github.com/mattupstate/flask-jwt
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flask>=0.9:www/py-flask@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyjwt>=1.4.0:www/py-pyjwt@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist pytest # tests fail to run, see https://github.com/mattupstate/flask-jwt/issues/155
+
+.include <bsd.port.mk>
diff --git a/www/py-flask-jwt/distinfo b/www/py-flask-jwt/distinfo
new file mode 100644
index 000000000000..b2cec4c38a3e
--- /dev/null
+++ b/www/py-flask-jwt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1704499464
+SHA256 (Flask-JWT-0.3.2.tar.gz) = 49c0672fbde0f1cd3374bd834918d28956e3c521c7e00089cdc5380d323bd0ad
+SIZE (Flask-JWT-0.3.2.tar.gz) = 9892
diff --git a/www/py-flask-jwt/pkg-descr b/www/py-flask-jwt/pkg-descr
new file mode 100644
index 000000000000..e894149d0173
--- /dev/null
+++ b/www/py-flask-jwt/pkg-descr
@@ -0,0 +1 @@
+Flask-JWT allows to add basic JWT features to Flask applications.