aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-09 20:39:08 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-09 20:39:08 +0000
commit265945fa58c166aabc06e9cedeefe48cd5614ddf (patch)
treec1b2d44c5fc3cf5448987bf45b6958302da41f74
parentf337a3fdd82fc70d0a0a8dabe6600ff44bf31d3d (diff)
downloadports-265945fa58c166aabc06e9cedeefe48cd5614ddf.tar.gz
ports-265945fa58c166aabc06e9cedeefe48cd5614ddf.zip
devel/py-livemark: Add py-livemark 0.110.5
Data presentation framework for Python that generates static sites from extended Markdown with interactive charts, tables, scripts, and other features. Purpose: - Data Journalism: Livemark provides a complete toolset for working with data, starting from data extraction and ending with a published website containing interactive charts, tables, and other features. - Software Education: Livemark is perfectly suited for writing education materials as it uses code execution model in markdown documents. It solves a range of problems with testing and having your code example up-to-date. - Python Development: Livemark can be used in software development as a helper tool for working on Python projects. It provides an ability to create documentation sites and works as a task runner.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-livemark/Makefile34
-rw-r--r--devel/py-livemark/distinfo3
-rw-r--r--devel/py-livemark/files/patch-setup.py11
-rw-r--r--devel/py-livemark/pkg-descr13
5 files changed, 62 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a71171aa9af3..063b91227cb5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4858,6 +4858,7 @@
SUBDIR += py-linecache2
SUBDIR += py-lineedit
SUBDIR += py-littleutils
+ SUBDIR += py-livemark
SUBDIR += py-llfuse
SUBDIR += py-llvmcpy
SUBDIR += py-llvmlite
diff --git a/devel/py-livemark/Makefile b/devel/py-livemark/Makefile
new file mode 100644
index 000000000000..063b0d084946
--- /dev/null
+++ b/devel/py-livemark/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= livemark
+PORTVERSION= 0.110.5
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Data presentation framework for Python
+WWW= https://github.com/frictionlessdata/livemark
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}attrs>=22.0:devel/py-attrs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cached-property>=1.5:devel/py-cached-property@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}deepmerge>=0.3:devel/py-deepmerge@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}docstring-parser>=0.10:textproc/py-docstring-parser@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}frictionless>=4.0:devel/py-frictionless@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gitpython>=3.1:devel/py-gitpython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}giturlparse>=0.10:devel/py-giturlparse@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>=3.0:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>=2.5:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}livereload>=2.6:www/py-livereload@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}marko>=1.0:textproc/py-marko@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyquery>=1.0:devel/py-pyquery@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=5.3:devel/py-yaml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typer>=0.3:devel/py-typer@${PY_FLAVOR}
+
+USES= python:3.8+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-livemark/distinfo b/devel/py-livemark/distinfo
new file mode 100644
index 000000000000..3fbeaaab254a
--- /dev/null
+++ b/devel/py-livemark/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1681052882
+SHA256 (livemark-0.110.5.tar.gz) = f257737761d75e977c2066ae2279f6e29c6ecfdb467847ed8b69160f01e84782
+SIZE (livemark-0.110.5.tar.gz) = 57173
diff --git a/devel/py-livemark/files/patch-setup.py b/devel/py-livemark/files/patch-setup.py
new file mode 100644
index 000000000000..fd146b385603
--- /dev/null
+++ b/devel/py-livemark/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2023-03-16 09:34:49 UTC
++++ setup.py
+@@ -40,7 +40,7 @@ INSTALL_REQUIRES = [
+ "marko>=1.0",
+ "pyyaml>=5.3",
+ "jinja2>=3.0",
+- "pyquery==1.*",
++ "pyquery>=1.0",
+ "deepmerge>=0.3",
+ "gitpython>=3.1",
+ "jsonschema>=2.5",
diff --git a/devel/py-livemark/pkg-descr b/devel/py-livemark/pkg-descr
new file mode 100644
index 000000000000..7c1ea5819ec9
--- /dev/null
+++ b/devel/py-livemark/pkg-descr
@@ -0,0 +1,13 @@
+Data presentation framework for Python that generates static sites from extended
+Markdown with interactive charts, tables, scripts, and other features.
+
+Purpose:
+- Data Journalism: Livemark provides a complete toolset for working with data,
+ starting from data extraction and ending with a published website containing
+ interactive charts, tables, and other features.
+- Software Education: Livemark is perfectly suited for writing education
+ materials as it uses code execution model in markdown documents. It solves a
+ range of problems with testing and having your code example up-to-date.
+- Python Development: Livemark can be used in software development as a helper
+ tool for working on Python projects. It provides an ability to create
+ documentation sites and works as a task runner.