aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2021-08-03 06:46:19 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2021-08-03 06:46:19 +0000
commit26613bdbc44d37ecc0cfdbe726b50e5a01f1ff78 (patch)
tree937a621a24beccbe728c09bba5e65fff8e97e47d
parent4a836720c73ef48f1afd3ba7d1abe960ea2c61ef (diff)
downloadports-26613bdbc44d37ecc0cfdbe726b50e5a01f1ff78.tar.gz
ports-26613bdbc44d37ecc0cfdbe726b50e5a01f1ff78.zip
security/vouch-proxy: Add new port
An SSO solution for Nginx using the auth_request module. Vouch Proxy can protect all of your websites at once. Vouch Proxy supports many OAuth and OIDC login providers and can enforce authentication to Google, GitHub, Okta and many more. WWW: https://github.com/vouch/vouch-proxy
-rw-r--r--security/Makefile1
-rw-r--r--security/vouch-proxy/Makefile23
-rw-r--r--security/vouch-proxy/distinfo5
-rw-r--r--security/vouch-proxy/files/vouch-proxy.in19
-rw-r--r--security/vouch-proxy/pkg-descr7
-rw-r--r--security/vouch-proxy/pkg-plist13
6 files changed, 68 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 2cb4494a6301..be4e71c56c82 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1305,6 +1305,7 @@
SUBDIR += vlock
SUBDIR += vm-to-tor
SUBDIR += vnccrack
+ SUBDIR += vouch-proxy
SUBDIR += vpnc
SUBDIR += vuls
SUBDIR += vuxml
diff --git a/security/vouch-proxy/Makefile b/security/vouch-proxy/Makefile
new file mode 100644
index 000000000000..ff6468c47629
--- /dev/null
+++ b/security/vouch-proxy/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= vouch-proxy
+DISTVERSIONPREFIX=v
+DISTVERSION= 0.29.1
+CATEGORIES= security
+
+MAINTAINER= decke@FreeBSD.org
+COMMENT= SSO solution for Nginx using the auth_request module
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+USE_RC_SUBR= ${PORTNAME}
+
+GO_MODULE= github.com/vouch/vouch-proxy
+GO_BUILDFLAGS= -ldflags "-X main.version=${PORTVERSION} -X main.uname=FreeBSD"
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ (cd ${WRKSRC}/config && ${COPYTREE_SHARE} "config.yml*" ${STAGEDIR}${ETCDIR})
+
+.include <bsd.port.mk>
diff --git a/security/vouch-proxy/distinfo b/security/vouch-proxy/distinfo
new file mode 100644
index 000000000000..5f52d5faa02c
--- /dev/null
+++ b/security/vouch-proxy/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1627972867
+SHA256 (go/security_vouch-proxy/vouch-proxy-v0.29.1/v0.29.1.mod) = 441c7b64635398cb3a37e2851029f0adf2b99bfe39a889cdb7676e9f45dd48e0
+SIZE (go/security_vouch-proxy/vouch-proxy-v0.29.1/v0.29.1.mod) = 1287
+SHA256 (go/security_vouch-proxy/vouch-proxy-v0.29.1/v0.29.1.zip) = 819d5be679c3d9e1f8ae0731f169a4ce1865795fc0ca923a90226a4a73e16ab7
+SIZE (go/security_vouch-proxy/vouch-proxy-v0.29.1/v0.29.1.zip) = 253158
diff --git a/security/vouch-proxy/files/vouch-proxy.in b/security/vouch-proxy/files/vouch-proxy.in
new file mode 100644
index 000000000000..a735628924e3
--- /dev/null
+++ b/security/vouch-proxy/files/vouch-proxy.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+# PROVIDE: vouchproxy
+# REQUIRE: NETWORKING
+
+. /etc/rc.subr
+
+name="vouchproxy"
+rcvar="vouchproxy_enable"
+
+pidfile="/var/run/${name}.pid"
+command="/usr/sbin/daemon"
+command_args="-P ${pidfile} -r -f -o /var/log/${name}.log %%PREFIX%%/bin/vouch-proxy"
+
+load_rc_config $name
+: ${vouchproxy_enable:=NO}
+: ${vouchproxy_env:="VOUCH_CONFIG=%%PREFIX%%/etc/vouch-proxy/config.yml"}
+
+run_rc_command "$1"
diff --git a/security/vouch-proxy/pkg-descr b/security/vouch-proxy/pkg-descr
new file mode 100644
index 000000000000..39747950175b
--- /dev/null
+++ b/security/vouch-proxy/pkg-descr
@@ -0,0 +1,7 @@
+An SSO solution for Nginx using the auth_request module. Vouch Proxy
+can protect all of your websites at once.
+
+Vouch Proxy supports many OAuth and OIDC login providers and can
+enforce authentication to Google, GitHub, Okta and many more.
+
+WWW: https://github.com/vouch/vouch-proxy
diff --git a/security/vouch-proxy/pkg-plist b/security/vouch-proxy/pkg-plist
new file mode 100644
index 000000000000..9cb28262d066
--- /dev/null
+++ b/security/vouch-proxy/pkg-plist
@@ -0,0 +1,13 @@
+bin/vouch-proxy
+%%ETCDIR%%/config.yml_example
+%%ETCDIR%%/config.yml_example_adfs
+%%ETCDIR%%/config.yml_example_azure
+%%ETCDIR%%/config.yml_example_gitea
+%%ETCDIR%%/config.yml_example_github
+%%ETCDIR%%/config.yml_example_github_enterprise
+%%ETCDIR%%/config.yml_example_google
+%%ETCDIR%%/config.yml_example_homeassistant
+%%ETCDIR%%/config.yml_example_indieauth
+%%ETCDIR%%/config.yml_example_nextcloud
+%%ETCDIR%%/config.yml_example_oidc
+%%ETCDIR%%/config.yml_example_scopes_and_claims