aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2023-03-24 20:47:24 +0000
committerRomain Tartière <romain@FreeBSD.org>2023-03-24 22:24:07 +0000
commit266e23fd78acb1d2a4285a4419982c89ad025748 (patch)
treee5a8b8357e38086045b84014761f79a12805f3ec
parent35810f4fd5ba10bdb2d2bfd5bbf7d3e8e96063b1 (diff)
downloadports-266e23fd78acb1d2a4285a4419982c89ad025748.tar.gz
ports-266e23fd78acb1d2a4285a4419982c89ad025748.zip
sysutils/puppet6: Switch back to older concurrent-ruby
This revert 347b5b85e274420b07a8ed58ef8dc1640d9fa69e and update the dependency on concurrent-ruby to use version 1.1. With hat: puppet
-rw-r--r--sysutils/puppet6/Makefile4
-rw-r--r--sysutils/puppet6/files/patch-lib_puppet_thread__local.rb13
2 files changed, 2 insertions, 15 deletions
diff --git a/sysutils/puppet6/Makefile b/sysutils/puppet6/Makefile
index 8b118ef4fe47..e2a28a6c9fea 100644
--- a/sysutils/puppet6/Makefile
+++ b/sysutils/puppet6/Makefile
@@ -1,6 +1,6 @@
PORTNAME= puppet
PORTVERSION= 6.28.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= https://forge.puppet.com/v3/files/:forge
PKGNAMESUFFIX= 6
@@ -17,7 +17,7 @@ EXPIRATION_DATE=2023-06-01
BROKEN_RUBY30= yes
BROKEN_RUBY31= yes
-RUN_DEPENDS= rubygem-concurrent-ruby>=1.0:devel/rubygem-concurrent-ruby \
+RUN_DEPENDS= rubygem-concurrent-ruby11>=1.0:devel/rubygem-concurrent-ruby11 \
rubygem-deep_merge>=1.0:devel/rubygem-deep_merge \
rubygem-fast_gettext1>=1.1:devel/rubygem-fast_gettext1 \
rubygem-ffi>=1.9.24:devel/rubygem-ffi \
diff --git a/sysutils/puppet6/files/patch-lib_puppet_thread__local.rb b/sysutils/puppet6/files/patch-lib_puppet_thread__local.rb
deleted file mode 100644
index 0966f4b86576..000000000000
--- a/sysutils/puppet6/files/patch-lib_puppet_thread__local.rb
+++ /dev/null
@@ -1,13 +0,0 @@
-Reference: https://github.com/ruby-concurrency/concurrent-ruby/pull/988
- https://github.com/ruby-concurrency/concurrent-ruby/issues/986
- https://github.com/puppetlabs/puppet/commit/9182bc3dd2576f409a6d01fb5c08d392670e90a2
-
---- lib/puppet/thread_local.rb.orig 2022-07-11 22:46:41 UTC
-+++ lib/puppet/thread_local.rb
-@@ -3,5 +3,5 @@ require 'concurrent'
- # We want to use the pure Ruby implementation even on JRuby. If we use the Java
- # implementation of ThreadLocal, we end up leaking references to JRuby instances
- # and preventing them from being garbage collected.
--class Puppet::ThreadLocal < Concurrent::RubyThreadLocalVar
-+class Puppet::ThreadLocal < Concurrent::ThreadLocalVar
- end