aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2022-02-06 05:27:59 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2022-02-06 05:29:36 +0000
commit26a0655f78fbc7608fec20726c299d04908c0253 (patch)
treedfc2cc5021ec3f8cfa65cb2332ca87d4e3d291b1
parent0e170396da4d35288e9e05f68c56c295934c82fc (diff)
downloadports-26a0655f78fbc7608fec20726c299d04908c0253.tar.gz
ports-26a0655f78fbc7608fec20726c299d04908c0253.zip
editors/vscode: update to 1.64.0
-rw-r--r--editors/vscode/Makefile13
-rw-r--r--editors/vscode/distinfo18
-rw-r--r--editors/vscode/files/patch-build_gulpfile.extensions.js4
-rw-r--r--editors/vscode/files/patch-build_gulpfile.vscode.js4
-rw-r--r--editors/vscode/files/patch-build_lib_layersChecker.ts4
-rw-r--r--editors/vscode/files/patch-build_lib_preLaunch.ts11
-rw-r--r--editors/vscode/files/patch-extensions_emmet_src_test_testUtils.ts4
-rw-r--r--editors/vscode/files/patch-extensions_vscode-api-tests_src_utils.ts4
-rw-r--r--editors/vscode/files/patch-product.json4
-rw-r--r--editors/vscode/files/patch-scripts_test.sh11
-rw-r--r--editors/vscode/files/patch-src_vs_base_common_platform.ts6
-rw-r--r--editors/vscode/files/patch-src_vs_code_electron-main_app.ts4
-rw-r--r--editors/vscode/files/patch-src_vs_workbench_contrib_extensions_browser_extensionEditor.ts4
-rw-r--r--editors/vscode/files/patch-test_automation_src_electronDriver.ts8
-rw-r--r--editors/vscode/files/patch-test_smoke_src_main.ts6
-rw-r--r--editors/vscode/pkg-plist98
16 files changed, 123 insertions, 80 deletions
diff --git a/editors/vscode/Makefile b/editors/vscode/Makefile
index fcd9f947e535..c64779eb2e8e 100644
--- a/editors/vscode/Makefile
+++ b/editors/vscode/Makefile
@@ -1,6 +1,5 @@
PORTNAME= vscode
-DISTVERSION= 1.63.2
-PORTREVISION= 4
+DISTVERSION= 1.64.0
CATEGORIES= editors
MASTER_SITES= https://registry.npmjs.org/esbuild-freebsd-64/-/:esbuild_binary \
https://nodejs.org/dist/v${NODE_VER}/:node_headers \
@@ -70,7 +69,7 @@ USES= desktop-file-utils gl gmake gnome jpeg pkgconfig \
USE_GITHUB= yes
GH_ACCOUNT= microsoft
-SOURCE_COMMIT_HASH= 899d46d82c4c95423fb7e10e68eba52050e30ba3
+SOURCE_COMMIT_HASH= 5554b12acf27056905806867f251c859323ff7e9
BINARY_ALIAS= python=${PYTHON_CMD}
@@ -85,7 +84,7 @@ USE_LDCONFIG= ${DATADIR}
NODE_VER= 14.16.0
NODE_VER_MAJOR= ${NODE_VER:C/\..*$//}
# See ${WRKSRC}/build/package.json for ESBUILD_VER_BUILD
-ESBUILD_VER_BUILD= 0.12.6
+ESBUILD_VER_BUILD= 0.14.2
# See ${WRKSRC}/extensions/package.json for ESBUILD_VER_EXTENSIONS
ESBUILD_VER_EXTENSIONS= 0.11.23
@@ -186,10 +185,12 @@ pre-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
yarn --frozen-lockfile --offline
# copy rg binary files to vscode-ripgrep module directory
+ ${MKDIR} ${WRKSRC}/node_modules/@vscode/ripgrep/bin
+ ${CP} ${LOCALBASE}/bin/rg ${WRKSRC}/node_modules/@vscode/ripgrep/bin
${MKDIR} ${WRKSRC}/node_modules/vscode-ripgrep/bin
${CP} ${LOCALBASE}/bin/rg ${WRKSRC}/node_modules/vscode-ripgrep/bin
- ${MKDIR} ${WRKSRC}/remote/node_modules/vscode-ripgrep/bin
- ${CP} ${LOCALBASE}/bin/rg ${WRKSRC}/remote/node_modules/vscode-ripgrep/bin
+ ${MKDIR} ${WRKSRC}/remote/node_modules/@vscode/ripgrep/bin
+ ${CP} ${LOCALBASE}/bin/rg ${WRKSRC}/remote/node_modules/@vscode/ripgrep/bin
do-build:
# setup download cache for gulp-atom-electron
diff --git a/editors/vscode/distinfo b/editors/vscode/distinfo
index 75a23d353d8b..5f63db15f481 100644
--- a/editors/vscode/distinfo
+++ b/editors/vscode/distinfo
@@ -1,13 +1,13 @@
-TIMESTAMP = 1639982477
-SHA256 (vscode/esbuild-freebsd-64-0.12.6.tgz) = 356c12b53e77f210f6155cf978d2e51054e983eaf0d63d218c153b559e3e1160
-SIZE (vscode/esbuild-freebsd-64-0.12.6.tgz) = 3132209
+TIMESTAMP = 1644039631
+SHA256 (vscode/esbuild-freebsd-64-0.14.2.tgz) = 9e5669e0afa0bdccdce9ab5c07eeec45cc3116ebdeb2739ff7f11e27c6ab6c34
+SIZE (vscode/esbuild-freebsd-64-0.14.2.tgz) = 3228893
SHA256 (vscode/esbuild-freebsd-64-0.11.23.tgz) = 976dc94c9aa92d7ef029c1f5e246883986fa92626aba8c8a37876a6929c64c30
SIZE (vscode/esbuild-freebsd-64-0.11.23.tgz) = 3108323
SHA256 (vscode/node-v14.16.0-headers.tar.gz) = 4b44b92903a61c29af20550f9d25bfc3029657df6b5f0a12072a70360f7eedee
SIZE (vscode/node-v14.16.0-headers.tar.gz) = 597013
-SHA256 (vscode/yarn-offline-cache-1.63.2.tar.gz) = 3261b29a91d9690986ea2bbe1748e351b490cd0f5a03ded65fe48b6fa7c409d2
-SIZE (vscode/yarn-offline-cache-1.63.2.tar.gz) = 119158162
-SHA256 (vscode/vscode-marketplace-exts-1.63.2.tar.gz) = 33cfe0b6c32e7545af04baddd9f18afba6d3b08df0497376fc4208d1a71de5e7
-SIZE (vscode/vscode-marketplace-exts-1.63.2.tar.gz) = 1516950
-SHA256 (vscode/microsoft-vscode-1.63.2_GH0.tar.gz) = 21fc9bc17ba4cf480b1e006f298363d86215c339c480f8d781cabcfedad2d624
-SIZE (vscode/microsoft-vscode-1.63.2_GH0.tar.gz) = 15411738
+SHA256 (vscode/yarn-offline-cache-1.64.0.tar.gz) = 6bb85fd136b4ab12746455bf7950318016eccbe3f7ca82cf18120276accb3141
+SIZE (vscode/yarn-offline-cache-1.64.0.tar.gz) = 156426784
+SHA256 (vscode/vscode-marketplace-exts-1.64.0.tar.gz) = 76e5c2fd53f27c2bc19b7e587a5d6ba55dc5b1510684a7dc24e6c0bacb41ccb0
+SIZE (vscode/vscode-marketplace-exts-1.64.0.tar.gz) = 1513737
+SHA256 (vscode/microsoft-vscode-1.64.0_GH0.tar.gz) = b068d1d5353f36dd367b01dd69a6fbbe55f425608b06309549c2b4be35dd97b4
+SIZE (vscode/microsoft-vscode-1.64.0_GH0.tar.gz) = 14293509
diff --git a/editors/vscode/files/patch-build_gulpfile.extensions.js b/editors/vscode/files/patch-build_gulpfile.extensions.js
index 6c394089ed93..fb348fe16a9b 100644
--- a/editors/vscode/files/patch-build_gulpfile.extensions.js
+++ b/editors/vscode/files/patch-build_gulpfile.extensions.js
@@ -1,6 +1,6 @@
---- build/gulpfile.extensions.js.orig 2021-12-06 21:35:50 UTC
+--- build/gulpfile.extensions.js.orig 2022-02-02 16:57:24 UTC
+++ build/gulpfile.extensions.js
-@@ -220,7 +220,7 @@ const cleanExtensionsBuildTask = task.define('clean-ex
+@@ -221,7 +221,7 @@ const cleanExtensionsBuildTask = task.define('clean-ex
const compileExtensionsBuildTask = task.define('compile-extensions-build', task.series(
cleanExtensionsBuildTask,
task.define('bundle-extensions-build', () => ext.packageLocalExtensionsStream(false).pipe(gulp.dest('.build'))),
diff --git a/editors/vscode/files/patch-build_gulpfile.vscode.js b/editors/vscode/files/patch-build_gulpfile.vscode.js
index 2ea90b5911d4..d7fe1fb6561f 100644
--- a/editors/vscode/files/patch-build_gulpfile.vscode.js
+++ b/editors/vscode/files/patch-build_gulpfile.vscode.js
@@ -1,6 +1,6 @@
---- build/gulpfile.vscode.js.orig 2021-12-06 21:35:50 UTC
+--- build/gulpfile.vscode.js.orig 2022-02-02 16:57:24 UTC
+++ build/gulpfile.vscode.js
-@@ -295,7 +295,7 @@ function packageTask(platform, arch, sourceFolderName,
+@@ -297,7 +297,7 @@ function packageTask(platform, arch, sourceFolderName,
.pipe(util.skipDirectories())
.pipe(util.fixWin32DirectoryPermissions())
.pipe(filter(['**', '!**/.github/**'], { dot: true })) // https://github.com/microsoft/vscode/issues/116523
diff --git a/editors/vscode/files/patch-build_lib_layersChecker.ts b/editors/vscode/files/patch-build_lib_layersChecker.ts
index e9f7a36a7178..f7e31dbb15df 100644
--- a/editors/vscode/files/patch-build_lib_layersChecker.ts
+++ b/editors/vscode/files/patch-build_lib_layersChecker.ts
@@ -1,6 +1,6 @@
---- build/lib/layersChecker.ts.orig 2021-10-19 14:41:40 UTC
+--- build/lib/layersChecker.ts.orig 2022-02-02 16:57:24 UTC
+++ build/lib/layersChecker.ts
-@@ -290,7 +290,7 @@ function checkFile(program: ts.Program, sourceFile: ts
+@@ -294,7 +294,7 @@ function checkFile(program: ts.Program, sourceFile: ts
function createProgram(tsconfigPath: string): ts.Program {
const tsConfig = ts.readConfigFile(tsconfigPath, ts.sys.readFile);
diff --git a/editors/vscode/files/patch-build_lib_preLaunch.ts b/editors/vscode/files/patch-build_lib_preLaunch.ts
new file mode 100644
index 000000000000..5150c306cc61
--- /dev/null
+++ b/editors/vscode/files/patch-build_lib_preLaunch.ts
@@ -0,0 +1,11 @@
+--- build/lib/preLaunch.ts.orig 2022-02-05 06:44:51 UTC
++++ build/lib/preLaunch.ts
+@@ -49,7 +49,7 @@ async function ensureCompiled() {
+
+ async function main() {
+ await ensureNodeModules();
+- await getElectron();
++ // await getElectron();
+ await ensureCompiled();
+
+ // Can't require this until after dependencies are installed
diff --git a/editors/vscode/files/patch-extensions_emmet_src_test_testUtils.ts b/editors/vscode/files/patch-extensions_emmet_src_test_testUtils.ts
index b77cd51c3b8c..97a125a263e5 100644
--- a/editors/vscode/files/patch-extensions_emmet_src_test_testUtils.ts
+++ b/editors/vscode/files/patch-extensions_emmet_src_test_testUtils.ts
@@ -1,6 +1,6 @@
---- extensions/emmet/src/test/testUtils.ts.orig 2019-12-18 06:34:11 UTC
+--- extensions/emmet/src/test/testUtils.ts.orig 2022-02-02 16:57:24 UTC
+++ extensions/emmet/src/test/testUtils.ts
-@@ -26,7 +26,7 @@ export function createRandomFile(contents = '', fileEx
+@@ -31,7 +31,7 @@ export function createRandomFile(contents = '', fileEx
}
export function pathEquals(path1: string, path2: string): boolean {
diff --git a/editors/vscode/files/patch-extensions_vscode-api-tests_src_utils.ts b/editors/vscode/files/patch-extensions_vscode-api-tests_src_utils.ts
index 820f269986a6..1dc015ee6c2d 100644
--- a/editors/vscode/files/patch-extensions_vscode-api-tests_src_utils.ts
+++ b/editors/vscode/files/patch-extensions_vscode-api-tests_src_utils.ts
@@ -1,6 +1,6 @@
---- extensions/vscode-api-tests/src/utils.ts.orig 2019-12-18 06:34:54 UTC
+--- extensions/vscode-api-tests/src/utils.ts.orig 2022-02-02 16:57:24 UTC
+++ extensions/vscode-api-tests/src/utils.ts
-@@ -36,7 +36,7 @@ export async function deleteFile(file: vscode.Uri): Pr
+@@ -38,7 +38,7 @@ export async function deleteFile(file: vscode.Uri): Pr
}
export function pathEquals(path1: string, path2: string): boolean {
diff --git a/editors/vscode/files/patch-product.json b/editors/vscode/files/patch-product.json
index 42a096edcbc5..3ad34eea370d 100644
--- a/editors/vscode/files/patch-product.json
+++ b/editors/vscode/files/patch-product.json
@@ -1,6 +1,6 @@
---- product.json.orig 2021-11-16 15:42:03 UTC
+--- product.json.orig 2022-02-02 16:57:24 UTC
+++ product.json
-@@ -32,6 +32,17 @@
+@@ -34,6 +34,17 @@
"GitHub.remotehub",
"GitHub.remotehub-insiders"
],
diff --git a/editors/vscode/files/patch-scripts_test.sh b/editors/vscode/files/patch-scripts_test.sh
new file mode 100644
index 000000000000..6f21d01b2277
--- /dev/null
+++ b/editors/vscode/files/patch-scripts_test.sh
@@ -0,0 +1,11 @@
+--- scripts/test.sh.orig 2022-02-05 06:42:53 UTC
++++ scripts/test.sh
+@@ -27,7 +27,7 @@ VSCODECRASHDIR=$ROOT/.build/crashes
+ test -d node_modules || yarn
+
+ # Get electron
+-yarn electron
++# yarn electron
+
+ # Unit Tests
+ if [[ "$OSTYPE" == "darwin"* ]]; then
diff --git a/editors/vscode/files/patch-src_vs_base_common_platform.ts b/editors/vscode/files/patch-src_vs_base_common_platform.ts
index c209b5da692b..a2027bcf1b8a 100644
--- a/editors/vscode/files/patch-src_vs_base_common_platform.ts
+++ b/editors/vscode/files/patch-src_vs_base_common_platform.ts
@@ -1,6 +1,6 @@
---- src/vs/base/common/platform.ts.orig 2021-12-15 09:23:15 UTC
+--- src/vs/base/common/platform.ts.orig 2022-02-02 16:57:24 UTC
+++ src/vs/base/common/platform.ts
-@@ -80,7 +80,7 @@ if (typeof navigator === 'object' && !isElectronRender
+@@ -79,7 +79,7 @@ if (typeof navigator === 'object' && !isElectronRender
_isWindows = _userAgent.indexOf('Windows') >= 0;
_isMacintosh = _userAgent.indexOf('Macintosh') >= 0;
_isIOS = (_userAgent.indexOf('Macintosh') >= 0 || _userAgent.indexOf('iPad') >= 0 || _userAgent.indexOf('iPhone') >= 0) && !!navigator.maxTouchPoints && navigator.maxTouchPoints > 0;
@@ -9,7 +9,7 @@
_isWeb = true;
_locale = navigator.language;
_language = _locale;
-@@ -90,7 +90,7 @@ if (typeof navigator === 'object' && !isElectronRender
+@@ -89,7 +89,7 @@ if (typeof navigator === 'object' && !isElectronRender
else if (typeof nodeProcess === 'object') {
_isWindows = (nodeProcess.platform === 'win32');
_isMacintosh = (nodeProcess.platform === 'darwin');
diff --git a/editors/vscode/files/patch-src_vs_code_electron-main_app.ts b/editors/vscode/files/patch-src_vs_code_electron-main_app.ts
index 05301d93dcf9..c7071308be28 100644
--- a/editors/vscode/files/patch-src_vs_code_electron-main_app.ts
+++ b/editors/vscode/files/patch-src_vs_code_electron-main_app.ts
@@ -1,6 +1,6 @@
---- src/vs/code/electron-main/app.ts.orig 2021-12-06 21:35:50 UTC
+--- src/vs/code/electron-main/app.ts.orig 2022-02-02 16:57:24 UTC
+++ src/vs/code/electron-main/app.ts
-@@ -465,7 +465,7 @@ export class CodeApplication extends Disposable {
+@@ -552,7 +552,7 @@ export class CodeApplication extends Disposable {
services.set(IUpdateService, new SyncDescriptor(Win32UpdateService));
break;
diff --git a/editors/vscode/files/patch-src_vs_workbench_contrib_extensions_browser_extensionEditor.ts b/editors/vscode/files/patch-src_vs_workbench_contrib_extensions_browser_extensionEditor.ts
index 146544c14b93..ab809307305f 100644
--- a/editors/vscode/files/patch-src_vs_workbench_contrib_extensions_browser_extensionEditor.ts
+++ b/editors/vscode/files/patch-src_vs_workbench_contrib_extensions_browser_extensionEditor.ts
@@ -1,6 +1,6 @@
---- src/vs/workbench/contrib/extensions/browser/extensionEditor.ts.orig 2021-12-06 21:35:50 UTC
+--- src/vs/workbench/contrib/extensions/browser/extensionEditor.ts.orig 2022-02-02 16:57:24 UTC
+++ src/vs/workbench/contrib/extensions/browser/extensionEditor.ts
-@@ -1743,7 +1743,8 @@ export class ExtensionEditor extends EditorPane {
+@@ -1759,7 +1759,8 @@ export class ExtensionEditor extends EditorPane {
switch (platform) {
case 'win32': key = rawKeyBinding.win; break;
diff --git a/editors/vscode/files/patch-test_automation_src_electronDriver.ts b/editors/vscode/files/patch-test_automation_src_electronDriver.ts
index df804e61123d..f280e310cfed 100644
--- a/editors/vscode/files/patch-test_automation_src_electronDriver.ts
+++ b/editors/vscode/files/patch-test_automation_src_electronDriver.ts
@@ -1,6 +1,6 @@
---- test/automation/src/electronDriver.ts.orig 2021-12-09 06:41:16 UTC
+--- test/automation/src/electronDriver.ts.orig 2022-02-02 16:57:24 UTC
+++ test/automation/src/electronDriver.ts
-@@ -39,7 +39,7 @@ export async function launch(codePath: string | undefi
+@@ -42,7 +42,7 @@ export async function launch(options: LaunchOptions):
'--driver', driverIPCHandle
];
@@ -9,7 +9,7 @@
args.push('--disable-gpu'); // Linux has trouble in VMs to render properly with GPU enabled
}
-@@ -148,7 +148,7 @@ function getDevElectronPath(): string {
+@@ -157,7 +157,7 @@ function getDevElectronPath(): string {
switch (process.platform) {
case 'darwin':
return path.join(buildPath, 'electron', `${product.nameLong}.app`, 'Contents', 'MacOS', 'Electron');
@@ -18,7 +18,7 @@
return path.join(buildPath, 'electron', `${product.applicationName}`);
case 'win32':
return path.join(buildPath, 'electron', `${product.nameShort}.exe`);
-@@ -161,7 +161,7 @@ function getBuildElectronPath(root: string): string {
+@@ -170,7 +170,7 @@ function getBuildElectronPath(root: string): string {
switch (process.platform) {
case 'darwin':
return path.join(root, 'Contents', 'MacOS', 'Electron');
diff --git a/editors/vscode/files/patch-test_smoke_src_main.ts b/editors/vscode/files/patch-test_smoke_src_main.ts
index 5a502f330173..f610c44436d3 100644
--- a/editors/vscode/files/patch-test_smoke_src_main.ts
+++ b/editors/vscode/files/patch-test_smoke_src_main.ts
@@ -1,6 +1,6 @@
---- test/smoke/src/main.ts.orig 2021-12-06 21:35:50 UTC
+--- test/smoke/src/main.ts.orig 2022-02-02 16:57:24 UTC
+++ test/smoke/src/main.ts
-@@ -109,7 +109,7 @@ if (!opts.web) {
+@@ -130,7 +130,7 @@ if (!opts.web) {
switch (process.platform) {
case 'darwin':
return path.join(buildPath, 'electron', `${product.nameLong}.app`, 'Contents', 'MacOS', 'Electron');
@@ -9,7 +9,7 @@
return path.join(buildPath, 'electron', `${product.applicationName}`);
case 'win32':
return path.join(buildPath, 'electron', `${product.nameShort}.exe`);
-@@ -122,7 +122,7 @@ if (!opts.web) {
+@@ -143,7 +143,7 @@ if (!opts.web) {
switch (process.platform) {
case 'darwin':
return path.join(root, 'Contents', 'MacOS', 'Electron');
diff --git a/editors/vscode/pkg-plist b/editors/vscode/pkg-plist
index 68dd843374cd..f97d6194a835 100644
--- a/editors/vscode/pkg-plist
+++ b/editors/vscode/pkg-plist
@@ -228,6 +228,7 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/extensions/github/dist/nls.metadata.header.json
%%DATADIR%%/resources/app/extensions/github/dist/nls.metadata.json
%%DATADIR%%/resources/app/extensions/github/images/icon.png
+%%DATADIR%%/resources/app/extensions/github/markdown.css
%%DATADIR%%/resources/app/extensions/github/package.json
%%DATADIR%%/resources/app/extensions/github/package.nls.json
%%DATADIR%%/resources/app/extensions/go/language-configuration.json
@@ -343,6 +344,20 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/extensions/julia/package.json
%%DATADIR%%/resources/app/extensions/julia/package.nls.json
%%DATADIR%%/resources/app/extensions/julia/syntaxes/julia.tmLanguage.json
+%%DATADIR%%/resources/app/extensions/latex/build/update-grammars.js
+%%DATADIR%%/resources/app/extensions/latex/cgmanifest.json
+%%DATADIR%%/resources/app/extensions/latex/cpp-bailout-license.txt
+%%DATADIR%%/resources/app/extensions/latex/latex-cpp-embedded-language-configuration.json
+%%DATADIR%%/resources/app/extensions/latex/latex-language-configuration.json
+%%DATADIR%%/resources/app/extensions/latex/markdown-latex-combined-language-configuration.json
+%%DATADIR%%/resources/app/extensions/latex/markdown-latex-combined-license.txt
+%%DATADIR%%/resources/app/extensions/latex/package.json
+%%DATADIR%%/resources/app/extensions/latex/package.nls.json
+%%DATADIR%%/resources/app/extensions/latex/syntaxes/Bibtex.tmLanguage.json
+%%DATADIR%%/resources/app/extensions/latex/syntaxes/LaTeX.tmLanguage.json
+%%DATADIR%%/resources/app/extensions/latex/syntaxes/TeX.tmLanguage.json
+%%DATADIR%%/resources/app/extensions/latex/syntaxes/cpp-grammar-bailout.tmLanguage.json
+%%DATADIR%%/resources/app/extensions/latex/syntaxes/markdown-latex-combined.tmLanguage.json
%%DATADIR%%/resources/app/extensions/less/language-configuration.json
%%DATADIR%%/resources/app/extensions/less/package.json
%%DATADIR%%/resources/app/extensions/less/package.nls.json
@@ -865,6 +880,7 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/extensions/yaml/syntaxes/yaml.tmLanguage.json
%%DATADIR%%/resources/app/node_modules.asar
%%DATADIR%%/resources/app/node_modules.asar.unpacked/@parcel/watcher/build/Release/watcher.node
+%%DATADIR%%/resources/app/node_modules.asar.unpacked/@vscode/ripgrep/bin/rg
%%DATADIR%%/resources/app/node_modules.asar.unpacked/@vscode/sqlite3/build/Release/sqlite.node
%%DATADIR%%/resources/app/node_modules.asar.unpacked/keytar/build/Release/keytar.node
%%DATADIR%%/resources/app/node_modules.asar.unpacked/keytar/build/Release/obj.target/keytar.node
@@ -875,9 +891,7 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/node_modules.asar.unpacked/node-pty/lib/shared/conout.js
%%DATADIR%%/resources/app/node_modules.asar.unpacked/node-pty/lib/worker/conoutSocketWorker.js
%%DATADIR%%/resources/app/node_modules.asar.unpacked/spdlog/build/Release/spdlog.node
-%%DATADIR%%/resources/app/node_modules.asar.unpacked/vscode-nsfw/build/Release/nsfw.node
%%DATADIR%%/resources/app/node_modules.asar.unpacked/vscode-oniguruma/release/onig.wasm
-%%DATADIR%%/resources/app/node_modules.asar.unpacked/vscode-ripgrep/bin/rg
%%DATADIR%%/resources/app/node_modules.asar.unpacked/windows-foreground-love/build/Release/foreground_love.node
%%DATADIR%%/resources/app/node_modules.asar.unpacked/windows-foreground-love/build/Release/obj.target/foreground_love.node
%%DATADIR%%/resources/app/out/bootstrap-amd.js
@@ -928,10 +942,8 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/out/vs/platform/extensionManagement/common/media/defaultIcon.png
%%DATADIR%%/resources/app/out/vs/platform/extensions/node/extensionHostStarterWorker.js
%%DATADIR%%/resources/app/out/vs/platform/extensions/node/extensionHostStarterWorkerMain.js
-%%DATADIR%%/resources/app/out/vs/platform/files/node/watcher/nsfw/watcherApp.js
-%%DATADIR%%/resources/app/out/vs/platform/files/node/watcher/nsfw/watcherApp.nls.js
-%%DATADIR%%/resources/app/out/vs/platform/files/node/watcher/parcel/watcherApp.js
-%%DATADIR%%/resources/app/out/vs/platform/files/node/watcher/parcel/watcherApp.nls.js
+%%DATADIR%%/resources/app/out/vs/platform/files/node/watcher/watcherMain.js
+%%DATADIR%%/resources/app/out/vs/platform/files/node/watcher/watcherMain.nls.js
%%DATADIR%%/resources/app/out/vs/platform/sharedProcess/electron-browser/sharedProcessWorkerMain.js
%%DATADIR%%/resources/app/out/vs/platform/sharedProcess/electron-browser/sharedProcessWorkerMain.nls.js
%%DATADIR%%/resources/app/out/vs/platform/terminal/node/ptyHostMain.js
@@ -941,6 +953,9 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/out/vs/workbench/browser/parts/editor/media/letterpress-dark.svg
%%DATADIR%%/resources/app/out/vs/workbench/browser/parts/editor/media/letterpress-hc.svg
%%DATADIR%%/resources/app/out/vs/workbench/browser/parts/editor/media/letterpress.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/audioCues/browser/media/break.opus
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/audioCues/browser/media/error.opus
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/audioCues/browser/media/foldedAreas.opus
%%DATADIR%%/resources/app/out/vs/workbench/contrib/debug/browser/media/continue-tb.png
%%DATADIR%%/resources/app/out/vs/workbench/contrib/debug/browser/media/pause-tb.png
%%DATADIR%%/resources/app/out/vs/workbench/contrib/debug/browser/media/restart-tb.png
@@ -955,52 +970,57 @@ share/applications/code-oss.desktop
%%DATADIR%%/resources/app/out/vs/workbench/contrib/extensions/browser/media/theme-icon.png
%%DATADIR%%/resources/app/out/vs/workbench/contrib/externalTerminal/node/TerminalHelper.scpt
%%DATADIR%%/resources/app/out/vs/workbench/contrib/externalTerminal/node/iTermHelper.scpt
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/interactive/browser/docs/interactive.drawio.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/notebook/browser/docs/cell-resize-above-viewport.drawio.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/notebook/browser/docs/hybrid-find.drawio.svg
%%DATADIR%%/resources/app/out/vs/workbench/contrib/notebook/browser/docs/viewport-rendering.drawio.svg
%%DATADIR%%/resources/app/out/vs/workbench/contrib/notebook/common/services/notebookSimpleWorker.js
%%DATADIR%%/resources/app/out/vs/workbench/contrib/output/common/outputLinkComputer.js
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/terminal/browser/media/shellIntegration-bash.sh
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/terminal/browser/media/shellIntegration-zsh.sh
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/terminal/browser/media/shellIntegration.ps1
%%DATADIR%%/resources/app/out/vs/workbench/contrib/webview/browser/pre/fake.html
%%DATADIR%%/resources/app/out/vs/workbench/contrib/webview/browser/pre/index.html
%%DATADIR%%/resources/app/out/vs/workbench/contrib/webview/browser/pre/main.js
%%DATADIR%%/resources/app/out/vs/workbench/contrib/webview/browser/pre/service-worker.js
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/colorTheme.png
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/commandPalette.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/dark.png
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/debug.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/extensions-web.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/extensions.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/git.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/github.png
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/interactivePlayground.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/languages.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/learn.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/light.png
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/menuBar.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/monokai.png
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/more.png
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/notebookThemes/colab.png
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/notebookThemes/default.png
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/notebookThemes/jupyter.png
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/openFolder.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/quiet-light.png
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/runTask.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/search.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/settings.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/settingsSync.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/shortcuts.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/sideBySide.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/terminal.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/tutorialVideo.png
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/gettingStarted/common/media/workspaceTrust.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/overlay/browser/media/commandpalette-dark.svg
-%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcome/overlay/browser/media/commandpalette.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/colorTheme.png
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/commandPalette.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/dark.png
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/debug.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/extensions-web.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/extensions.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/git.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/github.png
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/interactivePlayground.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/languages.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/learn.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/light.png
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/menuBar.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/monokai.png
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/more.png
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/notebookThemes/colab.png
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/notebookThemes/default.png
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/notebookThemes/jupyter.png
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/openFolder.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/quiet-light.png
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/runTask.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/search.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/settings.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/settingsSync.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/shortcuts.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/sideBySide.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/terminal.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/tutorialVideo.png
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeGettingStarted/common/media/workspaceTrust.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeOverlay/browser/media/commandpalette-dark.svg
+%%DATADIR%%/resources/app/out/vs/workbench/contrib/welcomeOverlay/browser/media/commandpalette.svg
%%DATADIR%%/resources/app/out/vs/workbench/contrib/workspace/browser/media/trusted-badge.png
%%DATADIR%%/resources/app/out/vs/workbench/contrib/workspace/browser/media/untrusted-status.png
%%DATADIR%%/resources/app/out/vs/workbench/services/extensions/node/extensionHostProcess.js
%%DATADIR%%/resources/app/out/vs/workbench/services/extensions/node/extensionHostProcess.nls.js
%%DATADIR%%/resources/app/out/vs/workbench/services/extensions/worker/extensionHostWorker.js
%%DATADIR%%/resources/app/out/vs/workbench/services/extensions/worker/extensionHostWorker.nls.js
-%%DATADIR%%/resources/app/out/vs/workbench/services/extensions/worker/httpWebWorkerExtensionHostIframe.html
-%%DATADIR%%/resources/app/out/vs/workbench/services/extensions/worker/httpsWebWorkerExtensionHostIframe.html
+%%DATADIR%%/resources/app/out/vs/workbench/services/extensions/worker/webWorkerExtensionHostIframe.html
%%DATADIR%%/resources/app/out/vs/workbench/services/languageDetection/browser/languageDetectionSimpleWorker.js
%%DATADIR%%/resources/app/out/vs/workbench/services/search/worker/localFileSearch.js
%%DATADIR%%/resources/app/out/vs/workbench/workbench.desktop.main.css