aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 17:10:33 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 17:20:05 +0000
commit26f27d05605286c0c2beb0e6fe310481ac96c70c (patch)
treee195075ca8520486295233fec571bb450c1b0aac
parentdf17c9422768830b281929a996f2676182d34eb7 (diff)
downloadports-26f27d05605286c0c2beb0e6fe310481ac96c70c.tar.gz
ports-26f27d05605286c0c2beb0e6fe310481ac96c70c.zip
net/ss5: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--net/ss5/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/net/ss5/Makefile b/net/ss5/Makefile
index 42083975e752..e3ae3dcf4587 100644
--- a/net/ss5/Makefile
+++ b/net/ss5/Makefile
@@ -11,8 +11,6 @@ WWW= http://ss5.sourceforge.net/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/License
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/-[0-9]+//}
-
USES= ldap ssl
USE_RC_SUBR= ${PORTNAME}
@@ -22,12 +20,21 @@ CONFIGURE_ARGS= --with-binpathbase=${PREFIX}/sbin \
--with-confpathbase=${PREFIX}/etc \
--with-libpath=${PREFIX}/lib
-MAKE_ENV= DATADIR=${DATADIR} EXAMPLESDIR=${EXAMPLESDIR}
MAKE_ARGS+= CC="${CC}"
+MAKE_ENV= DATADIR=${DATADIR} EXAMPLESDIR=${EXAMPLESDIR}
+
CFLAGS+= -fcommon
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/-[0-9]+//}
+
OPTIONS_DEFINE= DOCS EXAMPLES
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,/usr/local/etc/opt/ss5,${PREFIX}/etc/ss5,' \
${WRKSRC}/include/config.h.in