aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-05-17 05:20:09 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-05-17 05:20:55 +0000
commit27089289ec6b94710cc90dffc076cca5bd99c134 (patch)
tree669dd8c0df34a367dbdae3fb539d8173af230bc7
parentb021ddea8b4f22a399660d2848e7e1a8ef8e8774 (diff)
downloadports-27089289ec6b94710cc90dffc076cca5bd99c134.tar.gz
ports-27089289ec6b94710cc90dffc076cca5bd99c134.zip
graphics/gmic: Update 3.0.1 -> 3.1.2
-rw-r--r--graphics/darktable/Makefile2
-rw-r--r--graphics/gmic/Makefile21
-rw-r--r--graphics/gmic/distinfo6
-rw-r--r--graphics/gmic/files/patch-CMakeLists.txt11
-rw-r--r--graphics/gmic/files/patch-src_gmic.cpp6
-rw-r--r--graphics/gmic/pkg-plist12
-rw-r--r--multimedia/zart/Makefile2
7 files changed, 22 insertions, 38 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 3e6d39faab1d..c24d4dfc34dd 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -2,7 +2,7 @@
PORTNAME= darktable
PORTVERSION= 3.8.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= https://github.com/darktable-org/${PORTNAME}/releases/download/release-${PORTVERSION:C/\.rc/rc/}/
diff --git a/graphics/gmic/Makefile b/graphics/gmic/Makefile
index d28e7ab6023b..420dace564de 100644
--- a/graphics/gmic/Makefile
+++ b/graphics/gmic/Makefile
@@ -1,5 +1,5 @@
PORTNAME= gmic
-DISTVERSION= 3.0.1
+DISTVERSION= 3.1.2
CATEGORIES= graphics
MASTER_SITES= https://gmic.eu/files/source/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -14,6 +14,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BROKEN_i386= error: "c++ crashes, clang-5 and 6 fail: undefined reference to `__atomic_load'"
+BUILD_DEPENDS= gimptool-2.0:graphics/gimp-app
LIB_DEPENDS= libcurl.so:ftp/curl \
libfftw3.so:math/fftw3 \
libGraphicsMagick++.so:graphics/GraphicsMagick \
@@ -23,24 +24,18 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libpng.so:graphics/png \
libtiff.so:graphics/tiff
-USES= cmake compiler:c++11-lang jpeg localbase:ldflags pkgconfig
+USES= compiler:c++11-lang gmake jpeg localbase:ldflags pkgconfig
USE_LDCONFIG= yes
-CMAKE_OFF= BUILD_LIB_STATIC
-CMAKE_ON= ENABLE_DYNAMIC_LINKING
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-OPTIONS_DEFINE= OPENMP X11
-OPTIONS_DEFAULT= OPENMP X11
-OPTIONS_SUB= yes
-
-OPENMP_CMAKE_BOOL= ENABLE_OPENMP
+MAKE_JOBS_UNSAFE= yes
-X11_CMAKE_BOOL= ENABLE_X
-X11_USES= xorg
-X11_USE= XORG=ice,sm,x11,xext
+ALL_TARGET= lib
PORTSCOUT= limit:[0-9]\..* # not v.220 and similar
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgmic.so.312
+
.include <bsd.port.mk>
diff --git a/graphics/gmic/distinfo b/graphics/gmic/distinfo
index 5abf6acd7632..f8c7634b1e2b 100644
--- a/graphics/gmic/distinfo
+++ b/graphics/gmic/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1642176210
-SHA256 (gmic_3.0.1.tar.gz) = 6cc20a20e3ab53ce485ccf6e044a30141b3d62cf7743b83bb04906ff29453035
-SIZE (gmic_3.0.1.tar.gz) = 10457923
+TIMESTAMP = 1652739109
+SHA256 (gmic_3.1.2.tar.gz) = d5070c559c75161a225d74a99c19faf2485a3983139290f998cc6359bb318ba4
+SIZE (gmic_3.1.2.tar.gz) = 10694085
diff --git a/graphics/gmic/files/patch-CMakeLists.txt b/graphics/gmic/files/patch-CMakeLists.txt
deleted file mode 100644
index e432c8d055fe..000000000000
--- a/graphics/gmic/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orig 2021-12-09 09:25:45 UTC
-+++ CMakeLists.txt
-@@ -100,7 +100,7 @@ list(APPEND GMIC_CXX_COMPILE_FLAGS -Dgmic_build -Dcimg
- if(APPLE)
- list(APPEND GMIC_CXX_COMPILE_FLAGS -mmacosx-version-min=10.8 -stdlib=libc++ -Wno-error=c++11-narrowing -Wc++11-extensions -fpermissive)
- else()
-- list(APPEND GMIC_CXX_COMPILE_FLAGS -Wno-error=narrowing -fno-ipa-sra -fpermissive)
-+ list(APPEND GMIC_CXX_COMPILE_FLAGS -Wno-error=narrowing -fpermissive)
- endif()
-
- if(NOT "${PRERELEASE_TAG}" STREQUAL "")
diff --git a/graphics/gmic/files/patch-src_gmic.cpp b/graphics/gmic/files/patch-src_gmic.cpp
index fe2ae81af054..80860cb5274a 100644
--- a/graphics/gmic/files/patch-src_gmic.cpp
+++ b/graphics/gmic/files/patch-src_gmic.cpp
@@ -1,6 +1,6 @@
---- src/gmic.cpp.orig 2020-06-10 13:43:16 UTC
+--- src/gmic.cpp.orig 2022-05-11 08:15:20 UTC
+++ src/gmic.cpp
-@@ -2320,7 +2320,7 @@ double gmic::mp_setname(const unsigned int ind, const
+@@ -2516,7 +2516,7 @@ double gmic::mp_store(const Ts *const ptr, const unsig
// Manage correspondence between abort pointers and thread ids.
CImgList<void*> gmic::list_p_is_abort = CImgList<void*>();
bool *gmic::abort_ptr(bool *const p_is_abort) {
@@ -9,7 +9,7 @@
void* tid = (void*)(cimg_ulong)getpid();
#elif cimg_OS==1
void* tid = (void*)(cimg_ulong)syscall(SYS_gettid);
-@@ -2660,7 +2660,7 @@ gmic::~gmic() {
+@@ -2858,7 +2858,7 @@ gmic::~gmic() {
cimg::exception_mode(cimg_exception_mode);
cimg_forX(display_windows,l) delete &display_window(l);
cimg::mutex(21);
diff --git a/graphics/gmic/pkg-plist b/graphics/gmic/pkg-plist
index 68c6e628f706..777162c6c4c1 100644
--- a/graphics/gmic/pkg-plist
+++ b/graphics/gmic/pkg-plist
@@ -1,9 +1,9 @@
-bin/gmic
include/gmic.h
-lib/cmake/gmic/GmicConfig.cmake
-lib/cmake/gmic/GmicTargets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/gmic/GmicTargets.cmake
+include/gmic_libc.h
lib/libgmic.so
-lib/libgmic.so.1
+lib/libgmic.so.3
+lib/libgmic.so.312
+libexec/gimp/2.2/plug-ins/gmic_cluts.gmz
+libexec/gimp/2.2/plug-ins/gmic_denoise_cnn.gmz
+share/man/fr/man1/gmic.1.gz
share/man/man1/gmic.1.gz
-share/bash-completion/completions/gmic
diff --git a/multimedia/zart/Makefile b/multimedia/zart/Makefile
index e2ecfddb1e85..2b25a99f610f 100644
--- a/multimedia/zart/Makefile
+++ b/multimedia/zart/Makefile
@@ -1,6 +1,6 @@
PORTNAME= zart
PORTVERSION= g20191124
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= https://gmic.eu/files/source/:gmic
DISTFILES= gmic_${GMIC_VERSION}.tar.gz:gmic