aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:42:50 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:20:36 +0000
commit273a697cbf9ef412b61d4c9c44b66ee2d3294b70 (patch)
tree9f4baa8d8d18925b2cadfbe2f909e304ad281879
parent4be8586c98bc2b2a8e83723bc9bf992e7d6b2583 (diff)
downloadports-273a697cbf9ef412b61d4c9c44b66ee2d3294b70.tar.gz
ports-273a697cbf9ef412b61d4c9c44b66ee2d3294b70.zip
devel/py-exceptiongroup: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-exceptiongroup/Makefile8
-rw-r--r--devel/py-exceptiongroup/files/setup.py29
2 files changed, 4 insertions, 33 deletions
diff --git a/devel/py-exceptiongroup/Makefile b/devel/py-exceptiongroup/Makefile
index b8f5251c7a45..3444dd193ca8 100644
--- a/devel/py-exceptiongroup/Makefile
+++ b/devel/py-exceptiongroup/Makefile
@@ -1,5 +1,6 @@
PORTNAME= exceptiongroup
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,12 +12,11 @@ WWW= https://github.com/agronholm/exceptiongroup
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flit-scm>=0:devel/py-flit-scm@${PY_FLAVOR}
+
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-post-patch:
- @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-
.include <bsd.port.mk>
diff --git a/devel/py-exceptiongroup/files/setup.py b/devel/py-exceptiongroup/files/setup.py
deleted file mode 100644
index 00fe7e9866ad..000000000000
--- a/devel/py-exceptiongroup/files/setup.py
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/usr/bin/env python
-# setup.py generated by flit for tools that don't yet use PEP 517
-
-from distutils.core import setup
-
-packages = \
-['exceptiongroup']
-
-package_data = \
-{'': ['*']}
-
-package_dir = \
-{'': 'src'}
-
-extras_require = \
-{'test': ['pytest >= 6']}
-
-setup(name='exceptiongroup',
- version='%%PORTVERSION%%',
- description='Backport of PEP 654 (exception groups)',
- author=None,
- author_email='Alex Grönholm <alex.gronholm@nextday.fi>',
- url=None,
- packages=packages,
- package_data=package_data,
- package_dir=package_dir,
- extras_require=extras_require,
- python_requires='>=3.7',
- )