aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-08-25 10:45:53 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-08-25 10:49:37 +0000
commit2757c63bd0e6d01f9f0657fe03bb3a7b49adcae2 (patch)
tree691714d5122525456a0ff61745d238dde56d3975
parent04d257baa182926cff158f32cf459e560426add0 (diff)
downloadports-2757c63bd0e6d01f9f0657fe03bb3a7b49adcae2.tar.gz
ports-2757c63bd0e6d01f9f0657fe03bb3a7b49adcae2.zip
Revert "games/veloren: Fix build with rust 1.63.0"
This reverts commit 5e9ef674125a03baa9bae3f138134219d2212428. PR: 265915
-rw-r--r--games/veloren/Makefile2
-rw-r--r--games/veloren/distinfo6
-rw-r--r--games/veloren/files/patch-rust-1.6336
3 files changed, 4 insertions, 40 deletions
diff --git a/games/veloren/Makefile b/games/veloren/Makefile
index 5c1d5d15dcd1..3596a65a71fa 100644
--- a/games/veloren/Makefile
+++ b/games/veloren/Makefile
@@ -410,7 +410,7 @@ CARGO_CRATES= ab_glyph-0.2.15 \
os_str_bytes-6.0.0 \
owned_ttf_parser-0.6.0 \
owned_ttf_parser-0.15.0 \
- packed_simd_2-0.3.8 \
+ packed_simd_2-0.3.7 \
parking_lot-0.10.2 \
parking_lot-0.11.2 \
parking_lot-0.12.0 \
diff --git a/games/veloren/distinfo b/games/veloren/distinfo
index 52400ab98f49..566198c1e6d4 100644
--- a/games/veloren/distinfo
+++ b/games/veloren/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1660732539
+TIMESTAMP = 1658582101
SHA256 (rust/crates/ab_glyph-0.2.15.crate) = 24606928a235e73cdef55a0c909719cadd72fce573e5713d58cb2952d8f5794c
SIZE (rust/crates/ab_glyph-0.2.15.crate) = 15906
SHA256 (rust/crates/ab_glyph_rasterizer-0.1.5.crate) = a13739d7177fbd22bb0ed28badfff9f372f8bef46c863db4e1c6248f6b223b6e
@@ -751,8 +751,8 @@ SHA256 (rust/crates/owned_ttf_parser-0.6.0.crate) = 9f923fb806c46266c02ab4a5b239
SIZE (rust/crates/owned_ttf_parser-0.6.0.crate) = 20574
SHA256 (rust/crates/owned_ttf_parser-0.15.0.crate) = 4fb1e509cfe7a12db2a90bfa057dfcdbc55a347f5da677c506b53dd099cfec9d
SIZE (rust/crates/owned_ttf_parser-0.15.0.crate) = 23088
-SHA256 (rust/crates/packed_simd_2-0.3.8.crate) = a1914cd452d8fccd6f9db48147b29fd4ae05bea9dc5d9ad578509f72415de282
-SIZE (rust/crates/packed_simd_2-0.3.8.crate) = 97388
+SHA256 (rust/crates/packed_simd_2-0.3.7.crate) = defdcfef86dcc44ad208f71d9ff4ce28df6537a4e0d6b0e8e845cb8ca10059a6
+SIZE (rust/crates/packed_simd_2-0.3.7.crate) = 97413
SHA256 (rust/crates/parking_lot-0.10.2.crate) = d3a704eb390aafdc107b0e392f56a82b668e3a71366993b5340f5833fd62505e
SIZE (rust/crates/parking_lot-0.10.2.crate) = 39536
SHA256 (rust/crates/parking_lot-0.11.2.crate) = 7d17b78036a60663b797adeaee46f5c9dfebb86948d1255007a1d6be0271ff99
diff --git a/games/veloren/files/patch-rust-1.63 b/games/veloren/files/patch-rust-1.63
deleted file mode 100644
index 5050354349f1..000000000000
--- a/games/veloren/files/patch-rust-1.63
+++ /dev/null
@@ -1,36 +0,0 @@
---- Cargo.lock.orig 2022-08-17 12:36:05 UTC
-+++ Cargo.lock
-@@ -4025,9 +4025,9 @@ name = "packed_simd_2"
-
- [[package]]
- name = "packed_simd_2"
--version = "0.3.7"
-+version = "0.3.8"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "defdcfef86dcc44ad208f71d9ff4ce28df6537a4e0d6b0e8e845cb8ca10059a6"
-+checksum = "a1914cd452d8fccd6f9db48147b29fd4ae05bea9dc5d9ad578509f72415de282"
- dependencies = [
- "cfg-if 1.0.0",
- "libm 0.1.4",
-@@ -6241,7 +6241,7 @@ dependencies = [
- source = "registry+https://github.com/rust-lang/crates.io-index"
- checksum = "4ee73e6e4924fe940354b8d4d98cad5231175d615cd855b758adc658c0aac6a0"
- dependencies = [
-- "cfg-if 1.0.0",
-+ "cfg-if 0.1.10",
- "rand 0.8.5",
- "static_assertions",
- ]
-
-
---- voxygen/src/scene/terrain.rs.orig 2022-08-17 11:42:07.587067000 +0000
-+++ voxygen/src/scene/terrain.rs 2022-08-17 11:43:10.451160000 +0000
-@@ -555,7 +557,7 @@ impl SpriteRenderContext {
- }
- });
-
-- let init = core::lazy::OnceCell::new();
-+ let init = core::cell::OnceCell::new();
- let mut join_handle = Some(join_handle);
- let mut closure = move |renderer: &mut Renderer| {
- // The second unwrap can only fail if the sprite meshing thread panics, which