aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-04-24 10:40:06 +0000
committerDimitry Andric <dim@FreeBSD.org>2023-04-29 08:43:16 +0000
commit276de0b840925e727810341ed61a0849c9607e52 (patch)
tree5e907743724b03d39b1c898f938ba28b14a152a0
parenta17847a2345a127b86c44c1dfacf9eccb2951177 (diff)
downloadports-276de0b840925e727810341ed61a0849c9607e52.tar.gz
ports-276de0b840925e727810341ed61a0849c9607e52.zip
textproc/source-highlight: fix build with clang 16
Since clang 16 (and gcc 11) the default C++ standard is now gnu++17. Because textproc/source-highlight's Makefile does not explicitly set its C++ standard, this leads to several errors: In file included from fileutil.cc:28: ./fileutil.h:30:41: error: ISO C++17 does not allow dynamic exception specifications [-Wdynamic-exception-spec] string readFile(const string &fileName) throw (IOException); ^~~~~~~~~~~~~~~~~~~ ./fileutil.h:30:41: note: use 'noexcept(false)' instead string readFile(const string &fileName) throw (IOException); ^~~~~~~~~~~~~~~~~~~ noexcept(false) fileutil.cc:51:41: error: ISO C++17 does not allow dynamic exception specifications [-Wdynamic-exception-spec] string readFile(const string &fileName) throw (IOException) { ^~~~~~~~~~~~~~~~~~~ fileutil.cc:51:41: note: use 'noexcept(false)' instead string readFile(const string &fileName) throw (IOException) { ^~~~~~~~~~~~~~~~~~~ noexcept(false) In http://git.savannah.gnu.org/cgit/src-highlite.git/commit/?id=416b397 indicates that after 3.1.9 C++11 will be required and supported, so add USE_CXXSTD=gnu++11 to avoid the errors for now. PR: 271044 Approved by: tcberner (maintainer) MFH 2023Q2
-rw-r--r--textproc/source-highlight/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/textproc/source-highlight/Makefile b/textproc/source-highlight/Makefile
index 3536cfe2c544..a71c50635adf 100644
--- a/textproc/source-highlight/Makefile
+++ b/textproc/source-highlight/Makefile
@@ -1,6 +1,6 @@
PORTNAME= source-highlight
DISTVERSION= 3.1.9
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= textproc
MASTER_SITES= GNU/src-highlite
@@ -17,6 +17,7 @@ BUILD_DEPENDS= exctags:devel/ctags
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
USES= compiler:c++11-lang gmake pathfix libtool localbase
+USE_CXXSTD= gnu++11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-bash-completion
INSTALL_TARGET= install-strip