aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-05-06 20:11:07 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-05-06 20:11:25 +0000
commit27e3a3eab4f7f7eece010344ccfaf3f4057cdc6e (patch)
tree7ba6776f76e977f89eb6c878beb1eb3bd21bf12b
parent8ec237cd568f2c51f700014cba613e943e3b0006 (diff)
downloadports-27e3a3eab4f7f7eece010344ccfaf3f4057cdc6e.tar.gz
ports-27e3a3eab4f7f7eece010344ccfaf3f4057cdc6e.zip
security/nmap-devel: Use EXTRACT_AFTER_ARGS
To decrease I/O load skip extracting files instead of removing after extraction PR: 278743 Reviewed by: cy (maintainer)
-rw-r--r--security/nmap-devel/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/security/nmap-devel/Makefile b/security/nmap-devel/Makefile
index 8711eb18b94a..2201dbde0c4d 100644
--- a/security/nmap-devel/Makefile
+++ b/security/nmap-devel/Makefile
@@ -21,6 +21,11 @@ LICENSE_PERMS= auto-accept dist-mirror pkg-mirror pkg-sell
LIB_DEPENDS= libpcre2-16.so:devel/pcre2
USES= gmake cpe libtool
+
+# XXX limit results if we do a grep in the sources!
+EXTRACT_AFTER_ARGS= --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/mswin32 \
+ --no-same-owner --no-same-permissions
+
USE_GITHUB= yes
GH_TAGNAME= 036714cde
NMAP_COMMIT_DATE= 20240327
@@ -58,10 +63,6 @@ STRIP_FILES+= nmap nping
.include <bsd.port.options.mk>
-# XXX limit results if we do a grep in the sources!
-post-extract:
- @${RM} -r ${WRKSRC}/mswin32
-
.if exists(/usr/lib/libibverbs.a)
# Link with libibverbs is needed by static libpcap
post-patch-PCAP-on: