aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-10-15 19:25:39 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-10-15 19:25:39 +0000
commit280bc204b10f58715b63453b5ecb51ab7391e707 (patch)
tree4d36f9e040037ec737f4b11a8c91490fd4eacd6b
parent80847668cfbae6008bdef17bae8684fcc3b5d717 (diff)
downloadports-280bc204b10f58715b63453b5ecb51ab7391e707.tar.gz
ports-280bc204b10f58715b63453b5ecb51ab7391e707.zip
games/LibreMines: Free/Libre and Open Source software Qt based Minesweeper
LibreMines is a Free/Libre and Open Source software Qt based Minesweeper clone available for GNU/Linux, FreeBSD and Windows systems.
-rw-r--r--games/LibreMines/Makefile22
-rw-r--r--games/LibreMines/distinfo3
-rw-r--r--games/LibreMines/pkg-descr4
-rw-r--r--games/Makefile1
4 files changed, 30 insertions, 0 deletions
diff --git a/games/LibreMines/Makefile b/games/LibreMines/Makefile
new file mode 100644
index 000000000000..171e32af6190
--- /dev/null
+++ b/games/LibreMines/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= LibreMines
+PORTVERSION= 1.6.3
+DISTVERSIONPREFIX= v
+CATEGORIES= games
+
+MAINTAINER= pkubaj@FreeBSD.org
+COMMENT= Free/Libre and Open Source Software Qt based Minesweeper
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake qt:5
+USE_QT= buildtools_build core gui qmake_build svg widgets
+
+USE_GITHUB= yes
+GH_ACCOUNT= Bollos00
+
+PLIST_FILES= bin/libremines \
+ share/applications/libremines.desktop \
+ share/icons/hicolor/scalable/apps/libremines.svg
+
+.include <bsd.port.mk>
diff --git a/games/LibreMines/distinfo b/games/LibreMines/distinfo
new file mode 100644
index 000000000000..44a7bc2a0b3f
--- /dev/null
+++ b/games/LibreMines/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1634313302
+SHA256 (Bollos00-LibreMines-v1.6.3_GH0.tar.gz) = 782dea572996966b00b644592a90e8b5ac2781c7891df24c8748ba722c4caadf
+SIZE (Bollos00-LibreMines-v1.6.3_GH0.tar.gz) = 1491248
diff --git a/games/LibreMines/pkg-descr b/games/LibreMines/pkg-descr
new file mode 100644
index 000000000000..48af064a4444
--- /dev/null
+++ b/games/LibreMines/pkg-descr
@@ -0,0 +1,4 @@
+LibreMines is a Free/Libre and Open Source software Qt based Minesweeper clone
+available for GNU/Linux, FreeBSD and Windows systems.
+
+WWW: https://github.com/Bollos00/LibreMines
diff --git a/games/Makefile b/games/Makefile
index 6f2db140e767..9f4a971a99ed 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -14,6 +14,7 @@
SUBDIR += DDNet
SUBDIR += HeroesOfMightAndMagic
SUBDIR += KnightCap
+ SUBDIR += LibreMines
SUBDIR += NBlood
SUBDIR += OpenDiablo2
SUBDIR += OpenLara