aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-07-02 10:44:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-07-02 10:44:25 +0000
commit28cecaab53d1fd164f00f519d7939cdc9e3129c3 (patch)
treed88219807fe19fc87e41f5cefc7d69e2f7fae8f6
parentbba68325c9490058c3917ed0deebb236599dfecd (diff)
downloadports-28cecaab53d1fd164f00f519d7939cdc9e3129c3.tar.gz
ports-28cecaab53d1fd164f00f519d7939cdc9e3129c3.zip
net-mgmt/victoria-metrics: adjust BUILDINFO_TAG and set DATEINFO_TAG
Suggested by: Lapo Luchini
-rw-r--r--net-mgmt/victoria-metrics/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-mgmt/victoria-metrics/Makefile b/net-mgmt/victoria-metrics/Makefile
index 75a18dc77339..98e7126da2a6 100644
--- a/net-mgmt/victoria-metrics/Makefile
+++ b/net-mgmt/victoria-metrics/Makefile
@@ -1,7 +1,7 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
PORTNAME?= victoria-metrics
-PORTVERSION= 1.62.0
+PORTVERSION= 1.62.0 # don't forget to update BUILDINFO_TAG
DISTVERSIONPREFIX= v
CATEGORIES= net-mgmt
@@ -16,7 +16,8 @@ RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
USES= gmake go:modules,no_targets
USE_RC_SUBR?= ${PORTNAME}
MAKE_ENV= PKG_TAG=${DISTVERSIONPREFIX}${DISTVERSION} \
- BUILDINFO_TAG=2ef2e3d GOOS=${OPSYS:tl}
+ GOOS=${OPSYS:tl} BUILDINFO_TAG=008033a \
+ DATEINFO_TAG=${_GET_DATE:sh}
ALL_TARGET= ${PORTNAME}-pure
USE_GITHUB= yes
@@ -51,3 +52,5 @@ do-install-DOCS-on:
.endif
.include <bsd.port.mk>
+
+_GET_DATE= TZ= ${STAT} -f %Sm -t %Y%m%d-%H%M%S ${WRKSRC}/.gitignore