aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTrond Endrestol <Trond.Endrestol@ximalas.info>2023-07-22 13:06:47 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2023-07-22 13:08:43 +0000
commit290685cd059422d4afa8712c7beb0b4b3d7fcb73 (patch)
tree67800e79d9e110d9838a0c146e1a78a2e7b0a63f
parent582b973cb0d9a924fac545def8e0e4e1cb2d5934 (diff)
downloadports-290685cd059422d4afa8712c7beb0b4b3d7fcb73.tar.gz
ports-290685cd059422d4afa8712c7beb0b4b3d7fcb73.zip
multimedia/onevpl: Fix build with llvm16
- Pet portclippy and portfmt PR: 272662
-rw-r--r--multimedia/onevpl/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/multimedia/onevpl/Makefile b/multimedia/onevpl/Makefile
index 6e5021f75911..0d15f3394248 100644
--- a/multimedia/onevpl/Makefile
+++ b/multimedia/onevpl/Makefile
@@ -15,23 +15,26 @@ ONLY_FOR_ARCHS_REASON= only Intel GPUs on x86 are supported
BUILD_DEPENDS= wayland-protocols>0:graphics/wayland-protocols
LIB_DEPENDS= libdrm.so:graphics/libdrm \
- libwayland-client.so:graphics/wayland \
- libva.so:multimedia/libva
+ libva.so:multimedia/libva \
+ libwayland-client.so:graphics/wayland
-USES= cmake:testing compiler:c++17-lang localbase:ldflags pkgconfig xorg
+USES= cmake:testing compiler:c++14-lang localbase:ldflags pkgconfig \
+ xorg
+USE_CXXSTD= c++14
USE_GITHUB= yes
+GH_ACCOUNT= oneapi-src
USE_LDCONFIG= yes
USE_XORG= x11 xcb
-GH_ACCOUNT= oneapi-src
+
CMAKE_TESTING_ON= BUILD_TESTS
DATADIR= ${PREFIX}/share/vpl
-OPTIONS_DEFINE= PYTHON
-OPTIONS_DEFAULT=PYTHON
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= PYTHON
+OPTIONS_DEFAULT= PYTHON
+OPTIONS_SUB= yes
-PYTHON_USES= python
PYTHON_BUILD_DEPENDS= pybind11>0:devel/pybind11
+PYTHON_USES= python
PYTHON_CMAKE_BOOL= BUILD_PYTHON_BINDING
PYTHON_CMAKE_ON= -DPython3_EXECUTABLE:FILEPATH="${PYTHON_CMD}"