aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-11-19 20:02:35 +0000
committerDimitry Andric <dim@FreeBSD.org>2023-11-19 20:10:09 +0000
commit2932218a3cd1f02024412b4d6912d17f131b3d80 (patch)
treead1bf68fa06b6808a3d5b942ae59eeaf70bcbbe0
parent57a397e0a279cdb6e73a29d23e233051441d179c (diff)
downloadports-2932218a3cd1f02024412b4d6912d17f131b3d80.tar.gz
ports-2932218a3cd1f02024412b4d6912d17f131b3d80.zip
databases/ldb22: fix build with lld 17
Building databases/ldb22 with lld 17 results in the following link errors: ld: error: version script assignment of 'LDB_0.9.10' to symbol 'ldb_connect_backend' failed: symbol not defined ld: error: version script assignment of 'LDB_0.9.10' to symbol 'ldb_init_module_chain' failed: symbol not defined ld: error: version script assignment of 'LDB_0.9.10' to symbol 'ldb_load_modules_list' failed: symbol not defined ld: error: version script assignment of 'LDB_0.9.18' to symbol 'ldb_asq_init' failed: symbol not defined ld: error: version script assignment of 'LDB_0.9.18' to symbol 'ldb_paged_results_init' failed: symbol not defined ld: error: version script assignment of 'LDB_0.9.18' to symbol 'ldb_paged_searches_init' failed: symbol not defined ld: error: version script assignment of 'LDB_0.9.18' to symbol 'ldb_rdn_name_init' failed: symbol not defined ld: error: version script assignment of 'LDB_0.9.18' to symbol 'ldb_sample_init' failed: symbol not defined ld: error: version script assignment of 'LDB_0.9.18' to symbol 'ldb_server_sort_init' failed: symbol not defined ld: error: version script assignment of 'LDB_0.9.18' to symbol 'ldb_skel_init' failed: symbol not defined ld: error: version script assignment of 'LDB_0.9.18' to symbol 'ldb_tdb_init' failed: symbol not defined ld: error: version script assignment of 'LDB_1.1.25' to symbol 'ldb_unpack_data_only_attr_list' failed: symbol not defined ld: error: version script assignment of 'LDB_1.1.27' to symbol 'ldb_unpack_data_only_attr_list_flags' failed: symbol not defined ld: error: version script assignment of 'local' to symbol '_end' failed: symbol not defined ld: error: version script assignment of 'local' to symbol '__bss_start' failed: symbol not defined ld: error: version script assignment of 'local' to symbol '_edata' failed: symbol not defined Since the linker version scripts are generated dynamically, suppress errors with lld >= 17 due to these undefined symbols. PR: 273753 MFH: 2023Q4
-rw-r--r--databases/ldb22/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/databases/ldb22/Makefile b/databases/ldb22/Makefile
index cd97a646c97a..7b49fdec3420 100644
--- a/databases/ldb22/Makefile
+++ b/databases/ldb22/Makefile
@@ -94,6 +94,11 @@ PLIST_FILES= include/ldb_version.h \
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+# Some symbols in ldb's linker version scripts are not defined, but since the
+# scripts are generated dynamically, suppress errors with lld >= 17 due to these
+# undefined symbols.
+LDFLAGS+= -Wl,--undefined-version
+
.if ! ${PORT_OPTIONS:MMANPAGES}
CONFIGURE_ENV+= XSLTPROC="true"
.else