aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-03-13 21:39:20 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-03-14 10:32:34 +0000
commit2969348f1e0824fee1f01a7259ecf9fcf2d5f6fb (patch)
tree66e6f93a8c1634b4f9a50f867369b6c9186993db
parent08d479599d0755b3f29a5c76f2a06eafd5b87b25 (diff)
downloadports-2969348f1e0824fee1f01a7259ecf9fcf2d5f6fb.tar.gz
ports-2969348f1e0824fee1f01a7259ecf9fcf2d5f6fb.zip
net-im/py-slack-sdk: New PORT
The Slack platform offers several APIs to build apps. Each Slack API delivers part of the capabilities from the platform, so that you can pick just those that fit for your needs. This SDK offers a corresponding package for each of Slack’s APIs. They are small and powerful when used independently, and work seamlessly when used together, too. WWW: https://slack.dev/python-slack-sdk/
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/py-slack-sdk/Makefile35
-rw-r--r--net-im/py-slack-sdk/distinfo3
-rw-r--r--net-im/py-slack-sdk/pkg-descr7
4 files changed, 46 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 54e72cb457a6..5dc8c3d1935a 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -126,6 +126,7 @@
SUBDIR += py-nbxmpp
SUBDIR += py-punjab
SUBDIR += py-python-telegram-bot
+ SUBDIR += py-slack-sdk
SUBDIR += py-slackclient
SUBDIR += py-slixmpp
SUBDIR += py-telepot
diff --git a/net-im/py-slack-sdk/Makefile b/net-im/py-slack-sdk/Makefile
new file mode 100644
index 000000000000..62e04bd22013
--- /dev/null
+++ b/net-im/py-slack-sdk/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= slack-sdk
+PORTVERSION= 3.15.2
+DISTVERSIONPREFIX= v
+CATEGORIES= net-im python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= bofh@FreeBSD.org
+COMMENT= Slack SDK for several API
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>3.5.2:www/py-aiohttp@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python:3.6+
+# PyPi sdist do not have tests
+USE_GITHUB= yes
+GH_ACCOUNT= slackapi
+GH_PROJECT= python-${PORTNAME}
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= ASYNCDNS
+OPTIONS_DEFAULT= ASYNCDNS
+
+ASYNCDNS_DESC= Asyncronous DNS support
+
+ASYNCDNS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiodns>1.0:dns/py-aiodns@${PY_FLAVOR}
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs
+
+.include <bsd.port.mk>
diff --git a/net-im/py-slack-sdk/distinfo b/net-im/py-slack-sdk/distinfo
new file mode 100644
index 000000000000..cdd2d0094753
--- /dev/null
+++ b/net-im/py-slack-sdk/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1647205731
+SHA256 (slackapi-python-slack-sdk-v3.15.2_GH0.tar.gz) = edde4bf7717650ef29b723acf409cf0c50e590472f97f1b0e4b7ad6b895396f9
+SIZE (slackapi-python-slack-sdk-v3.15.2_GH0.tar.gz) = 3726526
diff --git a/net-im/py-slack-sdk/pkg-descr b/net-im/py-slack-sdk/pkg-descr
new file mode 100644
index 000000000000..324dd943bf64
--- /dev/null
+++ b/net-im/py-slack-sdk/pkg-descr
@@ -0,0 +1,7 @@
+The Slack platform offers several APIs to build apps. Each Slack API
+delivers part of the capabilities from the platform, so that you can
+pick just those that fit for your needs. This SDK offers a corresponding
+package for each of Slack’s APIs. They are small and powerful when used
+independently, and work seamlessly when used together, too.
+
+WWW: https://slack.dev/python-slack-sdk/