aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-05-16 20:53:52 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-05-16 20:55:59 +0000
commit2990a0702eaba66016159fdae3b8699d9093a45f (patch)
tree4460b6d548661530bb19237ecde634cbad295779
parentaf4393166169138e6985360b7cb75d30f2cc3cb0 (diff)
downloadports-2990a0702eaba66016159fdae3b8699d9093a45f.tar.gz
ports-2990a0702eaba66016159fdae3b8699d9093a45f.zip
emulators/mame: use sqlite from ports
This fixes runtime on powerpc64le since sqlite vanilla assumes big-endian on all powerpc*. PR: 257253 Approved by: manu (maintainer timeout)
-rw-r--r--emulators/mame/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index 60bf7c773f79..75365e831242 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -2,7 +2,7 @@
PORTNAME?= mame
PORTVERSION= 0.226
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MAINTAINER= manu@FreeBSD.org
@@ -21,7 +21,7 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
RUN_DEPENDS= liberation-fonts-ttf>=0:x11-fonts/liberation-fonts-ttf
USES= compiler:c++14-lang gl gmake jpeg localbase pkgconfig \
- python:3.7,build qt:5 sdl shebangfix xorg
+ python:3.7,build qt:5 sdl shebangfix sqlite:3 xorg
USE_GITHUB= yes
GH_ACCOUNT= mamedev
@@ -38,7 +38,8 @@ SHEBANG_FILES= src/devices/cpu/m6502/m6502make.py \
src/devices/cpu/tms57002/tmsmake.py
MAKEFILE= makefile
-MAKE_ARGS= TARGETOS=freebsd VERBOSE=1 TOOLS=1 USE_SYSTEM_LIB_PUGIXML=1
+MAKE_ARGS= TARGETOS=freebsd VERBOSE=1 TOOLS=1 USE_SYSTEM_LIB_PUGIXML=1 \
+ USE_SYSTEM_LIB_SQLITE3=1
MAKE_ENV= NOWERROR=1 USE_NETWORK=1 \
LD="${CXX}" PYTHON="${PYTHON_CMD}" \
OPT_FLAGS="${CXXFLAGS}" GCC_LDFLAGS="${LDFLAGS}" \