aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Cieślak <saper@saper.info>2024-02-23 12:03:50 +0000
committerWen Heping <wen@FreeBSD.org>2024-02-23 12:05:11 +0000
commit299683ae32dd945383498c0e78c2a274a4c94258 (patch)
tree19b0988a1475fa0c366887242522d48fe9b40618
parentbd05b23fad81b9be9e8c0e0a95a35aeaedf3d6ea (diff)
downloadports-299683ae32dd945383498c0e78c2a274a4c94258.tar.gz
ports-299683ae32dd945383498c0e78c2a274a4c94258.zip
lang/gnu-cobol: Fix ld error
PR: 277229 Reported by: saper@saper.info
-rw-r--r--lang/gnu-cobol/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/gnu-cobol/Makefile b/lang/gnu-cobol/Makefile
index 8690cf388b63..3cd6db52ef7e 100644
--- a/lang/gnu-cobol/Makefile
+++ b/lang/gnu-cobol/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gnucobol
PORTVERSION= 3.2
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= GNU/gnucobol
@@ -17,6 +18,8 @@ LIB_DEPENDS= libgmp.so:math/gmp \
USES= bdb gmake libtool ncurses tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= MATH_LIBS=-lm
+
TEST_TARGET= check
TEST_ENV= TESTSUITEFLAGS=--jobs=${MAKE_JOBS_NUMBER}