aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-01-04 19:54:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-01-04 19:54:03 +0000
commit299c87d8826d47e4967f7041687a1a09a70b8e11 (patch)
treeb8762a7feeabdac626a2bb4f646c62ab032358ef
parentd40ba16676ecd40fd3b0e5f13a5fe2d7484b0b57 (diff)
downloadports-299c87d8826d47e4967f7041687a1a09a70b8e11.tar.gz
ports-299c87d8826d47e4967f7041687a1a09a70b8e11.zip
science/mstore: New port: Molecular structure store for testing
-rw-r--r--science/Makefile1
-rw-r--r--science/mstore/Makefile22
-rw-r--r--science/mstore/distinfo3
-rw-r--r--science/mstore/pkg-descr6
-rw-r--r--science/mstore/pkg-plist25
5 files changed, 57 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 9a935be3f24f..200dc92c592e 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -166,6 +166,7 @@
SUBDIR += mpb
SUBDIR += mpqc
SUBDIR += msms
+ SUBDIR += mstore
SUBDIR += multiwfn
SUBDIR += namd
SUBDIR += nest
diff --git a/science/mstore/Makefile b/science/mstore/Makefile
new file mode 100644
index 000000000000..6116cf08bb53
--- /dev/null
+++ b/science/mstore/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= mstore
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.0
+CATEGORIES= science # chemistry
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Molecular structure store for testing
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libmctc-lib.so:science/mctc-lib
+
+USES= cmake fortran
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= grimme-lab
+
+CMAKE_ON= BUILD_SHARED_LIBS
+
+.include <bsd.port.mk>
diff --git a/science/mstore/distinfo b/science/mstore/distinfo
new file mode 100644
index 000000000000..7b1be5a91acb
--- /dev/null
+++ b/science/mstore/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1641325651
+SHA256 (grimme-lab-mstore-v0.2.0_GH0.tar.gz) = 95edba88afbc8013f57f4c818a97c0500cc40b158bed11234c061b2b6d7e480d
+SIZE (grimme-lab-mstore-v0.2.0_GH0.tar.gz) = 240180
diff --git a/science/mstore/pkg-descr b/science/mstore/pkg-descr
new file mode 100644
index 000000000000..8edb7cc34661
--- /dev/null
+++ b/science/mstore/pkg-descr
@@ -0,0 +1,6 @@
+mstore is molecular structure store for testing.
+
+It allows to store molecular structures in computational chemistry
+software.
+
+WWW: https://github.com/grimme-lab/mstore
diff --git a/science/mstore/pkg-plist b/science/mstore/pkg-plist
new file mode 100644
index 000000000000..d44910f84672
--- /dev/null
+++ b/science/mstore/pkg-plist
@@ -0,0 +1,25 @@
+bin/mstore-fortranize
+bin/mstore-info
+include/mstore/GNU-10.3.0/mstore.mod
+include/mstore/GNU-10.3.0/mstore_amino20x4.mod
+include/mstore/GNU-10.3.0/mstore_but14diol.mod
+include/mstore/GNU-10.3.0/mstore_data_collection.mod
+include/mstore/GNU-10.3.0/mstore_data_record.mod
+include/mstore/GNU-10.3.0/mstore_data_store.mod
+include/mstore/GNU-10.3.0/mstore_heavy28.mod
+include/mstore/GNU-10.3.0/mstore_ice10.mod
+include/mstore/GNU-10.3.0/mstore_il16.mod
+include/mstore/GNU-10.3.0/mstore_mb16_43.mod
+include/mstore/GNU-10.3.0/mstore_upu23.mod
+include/mstore/GNU-10.3.0/mstore_version.mod
+include/mstore/GNU-10.3.0/mstore_x23.mod
+lib/cmake/mstore/Findmctc-lib.cmake
+lib/cmake/mstore/mstore-config-version.cmake
+lib/cmake/mstore/mstore-config.cmake
+lib/cmake/mstore/mstore-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/mstore/mstore-targets.cmake
+lib/cmake/mstore/mstore-utils.cmake
+lib/libmstore.so
+lib/libmstore.so.0
+lib/libmstore.so.0.2.0
+libdata/pkgconfig/mstore.pc