aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2022-11-27 07:50:04 +0000
committerWen Heping <wen@FreeBSD.org>2022-11-27 07:50:04 +0000
commit29a8ff46431668c958dd1c0353c442b517210aaa (patch)
treec91f626b026501c0ac17b69f3193a0af3a7849bb
parent8098fe3bb23c65bc2813820fb6fcdb0dbbe4c314 (diff)
downloadports-29a8ff46431668c958dd1c0353c442b517210aaa.tar.gz
ports-29a8ff46431668c958dd1c0353c442b517210aaa.zip
www/moodle41: New port, which repocopied from www/moodle40
Moodle is a course management system (CMS) - a free, Open Source software package designed using sound pedagogical principles, to help educators create effective online learning communities. You can use it on any computer you have handy (including webhosts), yet it can scale from a single-teacher site to a 40,000-student University.
-rw-r--r--www/Makefile1
-rw-r--r--www/moodle41/Makefile62
-rw-r--r--www/moodle41/distinfo3
-rw-r--r--www/moodle41/files/pkg-message.in59
-rw-r--r--www/moodle41/pkg-descr5
5 files changed, 130 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0cfde027315a..9725bfcd69da 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -411,6 +411,7 @@
SUBDIR += moodle311
SUBDIR += moodle39
SUBDIR += moodle40
+ SUBDIR += moodle41
SUBDIR += morty
SUBDIR += mozplugger
SUBDIR += multisort
diff --git a/www/moodle41/Makefile b/www/moodle41/Makefile
new file mode 100644
index 000000000000..6faa56fd83f5
--- /dev/null
+++ b/www/moodle41/Makefile
@@ -0,0 +1,62 @@
+PORTNAME= moodle
+PORTVERSION= 4.1
+CATEGORIES= www education
+MASTER_SITES= SF/moodle/Moodle/stable401/
+PKGNAMESUFFIX= ${PKGORIGIN:T:S/moodle//}${PHP_PKGNAMESUFFIX}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Course management system based on social constructionism
+WWW= https://www.moodle.org/
+
+LICENSE= GPLv3
+
+CONFLICTS= moodle39-3.9.[0-9]* moodle311-3.11.[0-9]* moodle40-4.0.[0-9]*
+
+USES= cpe php:flavors tar:tgz
+USE_PHP= ctype curl dom exif fileinfo filter gd hash \
+ iconv intl json mbstring opcache openssl \
+ pcre session simplexml soap sodium spl tokenizer \
+ xml xmlreader xmlrpc zip zlib
+IGNORE_WITH_PHP= 82
+
+WRKSRC= ${WRKDIR}/moodle
+
+OPTIONS_SINGLE= BACKEND
+OPTIONS_SINGLE_BACKEND= MYSQL PGSQL MSSQL
+OPTIONS_DEFINE= LDAP
+OPTIONS_DEFAULT= MYSQL
+
+MYSQL_USES= mysql
+MYSQL_USE= php=mysqli
+PGSQL_USE= php=pgsql
+MSSQL_USE= php=mssql
+LDAP_USE= php=ldap
+
+NO_BUILD= yes
+PLIST= ${WRKDIR}/plist
+SUB_FILES= pkg-message
+SUB_LIST= MOODLEDIR=${MOODLEDIR} \
+ MOODLEDATADIR=${MOODLEDATADIR}
+
+MOODLEDIR?= www/moodle
+MOODLEDATADIR?= moodledata
+
+pre-install:
+ @${ECHO_CMD} "@owner ${WWWOWN}" >> ${PLIST}
+ @${ECHO_CMD} "@group ${WWWGRP}" >> ${PLIST}
+ @${ECHO_CMD} "@mode 755" >> ${PLIST}
+ @${ECHO} @dir ${MOODLEDATADIR} >> ${PLIST}
+ @${ECHO_CMD} "@mode" >> ${PLIST}
+ @${ECHO_CMD} "@group" >> ${PLIST}
+ @${ECHO_CMD} "@owner" >> ${PLIST}
+
+# Here for safety I do not set moodle diretory 0755 permission
+# It require user write config.php manually then.
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MOODLEDIR}?g" >>${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dir ${MOODLEDIR}?g" >> ${PLIST}
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${MOODLEDIR}
+ @${INSTALL} -d ${STAGEDIR}${PREFIX}/${MOODLEDATADIR}
+
+.include <bsd.port.mk>
diff --git a/www/moodle41/distinfo b/www/moodle41/distinfo
new file mode 100644
index 000000000000..8b170e3fc7c7
--- /dev/null
+++ b/www/moodle41/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1669528366
+SHA256 (moodle-4.1.tgz) = 2df7da5a9efab55120aa0ebbfb80acdee62ebc08fcca6f4961e2430d3f2241a6
+SIZE (moodle-4.1.tgz) = 64706705
diff --git a/www/moodle41/files/pkg-message.in b/www/moodle41/files/pkg-message.in
new file mode 100644
index 000000000000..5282847317fb
--- /dev/null
+++ b/www/moodle41/files/pkg-message.in
@@ -0,0 +1,59 @@
+[
+{ type: install
+ message: <<EOM
+1) Create a user and a database for Moodle to store all
+ its tables in (or choose an existing database).
+ It doesn't matter what the database or user names are,
+ as this will be configured in a later step.
+ NOTE: this package assumes that either the phpX-pgsql,
+ phpX-mysql, or phpX-mssql packages are installed.
+
+2) Add the following to your Apache configuration file
+ httpd.conf, and restart the server:
+
+ Alias /moodle %%PREFIX%%/%%MOODLEDIR%%/
+ AcceptPathInfo On
+ <Directory %%PREFIX%%/%%MOODLEDIR%%/>
+ AllowOverride None
+ Require all granted
+ </Directory>
+
+3) Visit your Moodle site with a browser (i.e.,
+ http://your.server.com/moodle/), and you should
+ be taken to the install.php script, which will lead
+ you through creating a config.php file and then
+ setting up Moodle, creating an admin account, etc.
+
+ At one step, you will get a message saying that the
+ installer script was not able to automatically create
+ the config.php file. Just download it and copy it to
+ %%PREFIX%%/%%MOODLEDIR%%/config.php. Beware that it
+ will contain the database password in cleartext, so
+ set up whatever file permissions you deem more adequate.
+ For instance, user=root, group=www, mask=640.
+
+4) Set up a cron task to invoke the file admin/cron.php
+ every five minutes or so. For instance:
+ */5 * * * * fetch http://your.server.com/moodle/admin/cron.php
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ http://docs.moodle.org/en/Installing_Moodle
+
+It may be worth reading the installation docs even if Moodle seems
+to be working at first, to ensure your PHP settings and database
+configuration will allow Moodle to operate properly.
+EOM
+}
+{ type: upgrade
+ message: <<EOM
+If you are upgrading from an earlier version of Moodle, check out
+possible additional steps at:
+
+ https://docs.moodle.org/400/en/Upgrading
+
+If you have real trouble, please visit the Moodle course
+"Using Moodle" on moodle.org.
+EOM
+}
+]
diff --git a/www/moodle41/pkg-descr b/www/moodle41/pkg-descr
new file mode 100644
index 000000000000..8d24b9357db9
--- /dev/null
+++ b/www/moodle41/pkg-descr
@@ -0,0 +1,5 @@
+Moodle is a course management system (CMS) - a free, Open Source software
+package designed using sound pedagogical principles, to help educators
+create effective online learning communities. You can use it on any
+computer you have handy (including webhosts), yet it can scale from a
+single-teacher site to a 40,000-student University.