aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksii Samorukov <samm@FreeBSD.org>2021-11-24 20:22:39 +0000
committerOleksii Samorukov <samm@FreeBSD.org>2021-11-24 20:22:39 +0000
commit29c0aa77578b766ac518e948c76834869e9813e5 (patch)
tree97aa4ba861f91791f1f73839746b968df58d4df9
parent36eaab838a17c18690b59450a554425b2e6cf280 (diff)
downloadports-29c0aa77578b766ac518e948c76834869e9813e5.tar.gz
ports-29c0aa77578b766ac518e948c76834869e9813e5.zip
www/trac-devel: Upgrade to 1.5.3 and unbreak
PR: 258942 Reported by: lapo@lapo.it
-rw-r--r--www/trac-devel/Makefile4
-rw-r--r--www/trac-devel/distinfo6
-rw-r--r--www/trac-devel/files/patch-trac_ticket_templates_report__view.html10
-rw-r--r--www/trac-devel/files/patch-trac_util_html.py11
-rw-r--r--www/trac-devel/files/patch-trac_util_presentation.py19
-rw-r--r--www/trac-devel/files/patch-trac_util_text.py31
6 files changed, 75 insertions, 6 deletions
diff --git a/www/trac-devel/Makefile b/www/trac-devel/Makefile
index 5aa9fe0f7bea..2f61b7d8ddc2 100644
--- a/www/trac-devel/Makefile
+++ b/www/trac-devel/Makefile
@@ -1,5 +1,5 @@
PORTNAME= trac
-DISTVERSION= 1.5.2
+DISTVERSION= 1.5.3
PORTREVISION= 2
CATEGORIES= www devel python
MASTER_SITES= http://ftp.edgewall.com/pub/trac/ \
@@ -13,8 +13,6 @@ COMMENT= Enhanced wiki and issue tracking system for software projects
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= does not build (cannot import name 'soft_unicode' from 'jinja2.utils')
-
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=2.3.4:devel/py-babel@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Jinja2>=2.10:devel/py-Jinja2@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=2.3.4:devel/py-babel@${PY_FLAVOR} \
diff --git a/www/trac-devel/distinfo b/www/trac-devel/distinfo
index a5cb0f6307e4..bc1e278bd51b 100644
--- a/www/trac-devel/distinfo
+++ b/www/trac-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1609593024
-SHA256 (Trac-1.5.2.tar.gz) = dac241e8018e11374cfabe68f902d815948611481f4ecb565e4f076768547e39
-SIZE (Trac-1.5.2.tar.gz) = 5416364
+TIMESTAMP = 1637782544
+SHA256 (Trac-1.5.3.tar.gz) = 699f5dd3ce82fb7138c726ef55a653f09531823e26170a1fb4d71d31b4adeaa5
+SIZE (Trac-1.5.3.tar.gz) = 5423354
diff --git a/www/trac-devel/files/patch-trac_ticket_templates_report__view.html b/www/trac-devel/files/patch-trac_ticket_templates_report__view.html
new file mode 100644
index 000000000000..de20599c2244
--- /dev/null
+++ b/www/trac-devel/files/patch-trac_ticket_templates_report__view.html
@@ -0,0 +1,10 @@
+--- trac/ticket/templates/report_view.html.orig 2021-05-09 23:08:49 UTC
++++ trac/ticket/templates/report_view.html
+@@ -162,6 +162,7 @@ history and logs, available at https://trac.edgewall.o
+ # for value_for_group, row_group in row_groups:
+ # if loop.first:
+ <thead>
++ # set header_group, header = None, None
+ # set column_headers
+ # for header_group in header_groups:
+ <tr class="trac-columns">
diff --git a/www/trac-devel/files/patch-trac_util_html.py b/www/trac-devel/files/patch-trac_util_html.py
new file mode 100644
index 000000000000..e99992efd7d1
--- /dev/null
+++ b/www/trac-devel/files/patch-trac_util_html.py
@@ -0,0 +1,11 @@
+--- trac/util/html.py.orig 2021-05-09 23:08:49 UTC
++++ trac/util/html.py
+@@ -24,7 +24,7 @@ import sys
+ from html import entities
+ from html.parser import HTMLParser
+
+-from markupsafe import Markup, escape as escape_quotes
++from markupsafe import Markup, escape as escape_quotes, soft_unicode
+
+ try:
+ from babel.support import LazyProxy
diff --git a/www/trac-devel/files/patch-trac_util_presentation.py b/www/trac-devel/files/patch-trac_util_presentation.py
new file mode 100644
index 000000000000..f04f3a8bab1d
--- /dev/null
+++ b/www/trac-devel/files/patch-trac_util_presentation.py
@@ -0,0 +1,19 @@
+--- trac/util/presentation.py.orig 2021-05-09 23:08:49 UTC
++++ trac/util/presentation.py
+@@ -21,13 +21,13 @@ from datetime import datetime
+ from math import ceil
+ import re
+
+-from jinja2 import Markup, Undefined, contextfilter, evalcontextfilter
++from jinja2 import Undefined, contextfilter, evalcontextfilter
+ from jinja2.filters import make_attrgetter
+-from jinja2.utils import soft_unicode
+
+ from trac.core import TracError
+ from .datefmt import to_utimestamp, utc
+-from .html import Fragment, classes, html_attribute, styles, tag
++from .html import (Fragment, Markup, classes, html_attribute, soft_unicode,
++ styles, tag)
+ from .text import javascript_quote
+
+ __all__ = ['captioned_button', 'classes', 'first_last', 'group', 'istext',
diff --git a/www/trac-devel/files/patch-trac_util_text.py b/www/trac-devel/files/patch-trac_util_text.py
new file mode 100644
index 000000000000..64e40a62758c
--- /dev/null
+++ b/www/trac-devel/files/patch-trac_util_text.py
@@ -0,0 +1,31 @@
+--- trac/util/text.py.orig 2021-05-09 23:08:49 UTC
++++ trac/util/text.py
+@@ -22,6 +22,7 @@ import base64
+ import configparser
+ import locale
+ import os
++import pkg_resources
+ import re
+ import sys
+ import textwrap
+@@ -43,6 +44,11 @@ del Empty # shouldn't be used outside of Trac core
+
+ # -- Jinja2
+
++_jinja2_ver = pkg_resources.parse_version(jinja2.__version__)
++_jinja2_exts = ['jinja2.ext.do', 'jinja2.ext.i18n']
++if _jinja2_ver < pkg_resources.parse_version('3'):
++ _jinja2_exts.append('jinja2.ext.with_')
++
+ def jinja2env(**kwargs):
+ """Creates a Jinja2 ``Environment`` configured with Trac conventions.
+
+@@ -65,7 +71,7 @@ def jinja2env(**kwargs):
+ line_comment_prefix='##',
+ trim_blocks=True,
+ lstrip_blocks=True,
+- extensions=['jinja2.ext.do', 'jinja2.ext.i18n', 'jinja2.ext.with_'],
++ extensions=list(_jinja2_exts),
+ finalize=filterout_none,
+ autoescape=autoescape_extensions,
+ )