aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-01-04 22:29:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-01-04 22:30:11 +0000
commit29c3e2e6e1de61d7811499849a3755aa5e40bbdb (patch)
tree6849a76f625a575d51da74b70cf58ac5dcd4a63c
parent76941a47e63c8348bf81c3ad933dda4678486b06 (diff)
downloadports-29c3e2e6e1de61d7811499849a3755aa5e40bbdb.tar.gz
ports-29c3e2e6e1de61d7811499849a3755aa5e40bbdb.zip
science/plumed: Fix the test target
-rw-r--r--science/plumed/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/science/plumed/Makefile b/science/plumed/Makefile
index 7d6f4c961c4a..72f7d9e5ee54 100644
--- a/science/plumed/Makefile
+++ b/science/plumed/Makefile
@@ -18,7 +18,11 @@ USES= autoreconf compiler:c++11-lang gmake pkgconfig shebangfix
USE_LDCONFIG= yes
SHEBANG_GLOB= *.sh
-SHEBANG_FILES= src/maketools/makecmd src/maketools/xxd
+SHEBANG_FILES= src/maketools/makecmd \
+ src/maketools/xxd \
+ regtest/scripts/check \
+ regtest/scripts/run \
+ regtest/scripts/what
USE_GITHUB= yes
GH_PROJECT= plumed2
@@ -26,13 +30,14 @@ GH_PROJECT= plumed2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --disable-python
-TEST_TARGET= test # https://github.com/plumed/plumed2/issues/781
+TEST_TARGET= check # the 'installcheck' target checks installed version
+# 27 tests are known to fail: https://github.com/plumed/plumed2/issues/782
post-patch:
@${REINPLACE_CMD} -e 's|#! /bin/bash|#! ${LOCALBASE}/bin/bash|' ${WRKSRC}/src/lib/Makefile
post-install:
@${RMDIR} ${STAGEDIR}${PREFIX}/lib/plumed/obj
- @cd ${STAGEDIR}${PREFIX} && ${STRIP_CMD} bin/plumed lib/plumed/plumed-runtime lib/libplumed.so lib/libplumedKernel.so
+ @cd ${STAGEDIR}${PREFIX} && ${STRIP_CMD} bin/plumed lib/plumed/plumed-runtime lib/libplumed.so lib/libplumedKernel.so
.include <bsd.port.mk>