aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-25 21:25:33 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-25 21:46:47 +0000
commit2a6480a37c5e8888aaa98d487ab22f72339dee29 (patch)
tree8344014d0ad891b953d405410a491a51f78280fa
parent17bcbb1d3ac539254abe39edeab68819260f50f5 (diff)
downloadports-2a6480a37c5e8888aaa98d487ab22f72339dee29.tar.gz
ports-2a6480a37c5e8888aaa98d487ab22f72339dee29.zip
textproc/py-tomli-w: Update to 0.4.0
-rw-r--r--textproc/py-tomli-w/Makefile5
-rw-r--r--textproc/py-tomli-w/distinfo6
-rw-r--r--textproc/py-tomli-w/files/setup.py21
3 files changed, 28 insertions, 4 deletions
diff --git a/textproc/py-tomli-w/Makefile b/textproc/py-tomli-w/Makefile
index a3c6a238f8d2..d074d88b9e8f 100644
--- a/textproc/py-tomli-w/Makefile
+++ b/textproc/py-tomli-w/Makefile
@@ -1,7 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= tomli-w
-PORTVERSION= 0.3.0
+PORTVERSION= 0.4.0
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,4 +18,7 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+post-patch:
+ @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
+
.include <bsd.port.mk>
diff --git a/textproc/py-tomli-w/distinfo b/textproc/py-tomli-w/distinfo
index ad78f1d47504..060c33fc0e8d 100644
--- a/textproc/py-tomli-w/distinfo
+++ b/textproc/py-tomli-w/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1634111638
-SHA256 (tomli_w-0.3.0.tar.gz) = 207c5f05803aec5a9a578c6aca5c1bbbba9783ad88461f3e180eb8c3c3c48a4b
-SIZE (tomli_w-0.3.0.tar.gz) = 5466
+TIMESTAMP = 1635181101
+SHA256 (tomli_w-0.4.0.tar.gz) = 47643abe03b628b6e214c38cf0816dca7b63888e503ec8580d251e331c0526b6
+SIZE (tomli_w-0.4.0.tar.gz) = 6568
diff --git a/textproc/py-tomli-w/files/setup.py b/textproc/py-tomli-w/files/setup.py
new file mode 100644
index 000000000000..bedbff79c68c
--- /dev/null
+++ b/textproc/py-tomli-w/files/setup.py
@@ -0,0 +1,21 @@
+#!/usr/bin/env python
+# setup.py generated by flit for tools that don't yet use PEP 517
+
+from distutils.core import setup
+
+packages = \
+['tomli_w']
+
+package_data = \
+{'': ['*']}
+
+setup(name='tomli_w',
+ version='0.4.0',
+ description="A lil' TOML writer",
+ author=None,
+ author_email='Taneli Hukkinen <hukkin@users.noreply.github.com>',
+ url=None,
+ packages=packages,
+ package_data=package_data,
+ python_requires='>=3.6',
+ )