aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-02-19 01:48:08 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-02-19 01:48:08 +0000
commit2ad82a1068e1e06f47843bbbb7df1e281bd53d29 (patch)
tree6d82564066a11667115a35bb45ae2c94b7c22b15
parentc22e29d08774bc5ad5eee4406ae59898c5903619 (diff)
downloadports-2ad82a1068e1e06f47843bbbb7df1e281bd53d29.tar.gz
ports-2ad82a1068e1e06f47843bbbb7df1e281bd53d29.zip
*/*: Replace format=bsdtar with format=ustar in tar archive operations
... because the undocumented format bsdtar adds paxheaders on some systems, therefore breaking the fetch. The documentation for format=bsdtar should be added: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=277139 Approved by: portmgr (blanket unbreak)
-rw-r--r--audio/synthpod-lv2/Makefile2
-rw-r--r--biology/gatk/Makefile2
-rw-r--r--math/ttmath/Makefile2
-rw-r--r--science/salome-configuration/Makefile2
-rw-r--r--science/salome-kernel/Makefile2
-rw-r--r--textproc/write-good/Makefile4
-rw-r--r--textproc/xlnt/Makefile2
-rw-r--r--x11/qimageblitz/Makefile2
8 files changed, 9 insertions, 9 deletions
diff --git a/audio/synthpod-lv2/Makefile b/audio/synthpod-lv2/Makefile
index 17bb540b13b0..0da93b933c23 100644
--- a/audio/synthpod-lv2/Makefile
+++ b/audio/synthpod-lv2/Makefile
@@ -75,7 +75,7 @@ do-fetch:
(cd ${PORTNAME}-${DISTVERSIONFULL} && git reset -q --hard ${GIT_TAGNAME} && ${RM} -r .git) && \
${FIND} ${PORTNAME}-${DISTVERSIONFULL} -and -exec ${TOUCH} -h -d 1970-01-01T00:00:00Z {} \; && \
${FIND} ${PORTNAME}-${DISTVERSIONFULL} -print0 | LC_ALL=C ${SORT} -z | \
- ${TAR} czf ${PORTNAME}-${DISTVERSIONFULL}${EXTRACT_SUFX} --format=bsdtar --gid 0 --uid 0 --options gzip:!timestamp --no-recursion --null -T - && \
+ ${TAR} czf ${PORTNAME}-${DISTVERSIONFULL}${EXTRACT_SUFX} --format=ustar --gid 0 --uid 0 --options gzip:!timestamp --no-recursion --null -T - && \
${RM} -r ${PORTNAME}-${DISTVERSIONFULL}; \
fi
diff --git a/biology/gatk/Makefile b/biology/gatk/Makefile
index 672e53c1d812..d518057376ef 100644
--- a/biology/gatk/Makefile
+++ b/biology/gatk/Makefile
@@ -67,7 +67,7 @@ do-fetch:
) && \
${FIND} ${PORTNAME}-${DISTVERSION} -and -exec ${TOUCH} -h -d 1970-01-01T00:00:00Z {} \; && \
${FIND} ${PORTNAME}-${DISTVERSION} -print0 | LC_ALL=C ${SORT} -z | \
- ${TAR} czf ${DISTNAME}${EXTRACT_SUFX} --format=bsdtar --gid 0 --uid 0 --options gzip:!timestamp --no-recursion --null -T - && \
+ ${TAR} czf ${DISTNAME}${EXTRACT_SUFX} --format=ustar --gid 0 --uid 0 --options gzip:!timestamp --no-recursion --null -T - && \
${RM} -r ${PORTNAME}-${DISTVERSION}; \
fi
.endif
diff --git a/math/ttmath/Makefile b/math/ttmath/Makefile
index 89503a45c06a..144d75ed4bdb 100644
--- a/math/ttmath/Makefile
+++ b/math/ttmath/Makefile
@@ -27,7 +27,7 @@ do-fetch:
(cd ${PORTNAME}-${DISTVERSIONFULL} && git reset -q --hard ${GIT_TAG} && ${RM} -r .git) && \
${FIND} ${PORTNAME}-${DISTVERSIONFULL} -and -exec ${TOUCH} -h -d 1970-01-01T00:00:00Z {} \; && \
${FIND} ${PORTNAME}-${DISTVERSIONFULL} -print0 | LC_ALL=C ${SORT} -z | \
- ${TAR} czf ${PORTNAME}-${DISTVERSIONFULL}${EXTRACT_SUFX} --format=bsdtar --gid 0 --uid 0 --options gzip:!timestamp --no-recursion --null -T - && \
+ ${TAR} czf ${PORTNAME}-${DISTVERSIONFULL}${EXTRACT_SUFX} --format=ustar --gid 0 --uid 0 --options gzip:!timestamp --no-recursion --null -T - && \
${RM} -r ${PORTNAME}-${DISTVERSIONFULL}; \
fi
diff --git a/science/salome-configuration/Makefile b/science/salome-configuration/Makefile
index ea03f6e27265..6afeb92ff2cd 100644
--- a/science/salome-configuration/Makefile
+++ b/science/salome-configuration/Makefile
@@ -24,7 +24,7 @@ do-fetch:
(cd ${PORTNAME}-${DISTVERSIONFULL} && git reset -q --hard ${DISTVERSIONFULL} && ${RM} -r .git) && \
${FIND} ${PORTNAME}-${DISTVERSIONFULL} -and -exec ${TOUCH} -h -d 1970-01-01T00:00:00Z {} \; && \
${FIND} ${PORTNAME}-${DISTVERSIONFULL} -print0 | LC_ALL=C ${SORT} -z | \
- ${TAR} czf ${PORTNAME}-${DISTVERSIONFULL}${EXTRACT_SUFX} --format=bsdtar --gid 0 --uid 0 --options gzip:!timestamp --no-recursion --null -T - && \
+ ${TAR} czf ${PORTNAME}-${DISTVERSIONFULL}${EXTRACT_SUFX} --format=ustar --gid 0 --uid 0 --options gzip:!timestamp --no-recursion --null -T - && \
${RM} -r ${PORTNAME}-${DISTVERSIONFULL}; \
fi
diff --git a/science/salome-kernel/Makefile b/science/salome-kernel/Makefile
index 134403d43687..28f3f2eecabb 100644
--- a/science/salome-kernel/Makefile
+++ b/science/salome-kernel/Makefile
@@ -53,7 +53,7 @@ do-fetch:
(cd ${PORTNAME}-${DISTVERSIONFULL} && git reset -q --hard ${DISTVERSIONFULL} && ${RM} -r .git) && \
${FIND} ${PORTNAME}-${DISTVERSIONFULL} -and -exec ${TOUCH} -h -d 1970-01-01T00:00:00Z {} \; && \
${FIND} ${PORTNAME}-${DISTVERSIONFULL} -print0 | LC_ALL=C ${SORT} -z | \
- ${TAR} czf ${PORTNAME}-${DISTVERSIONFULL}${EXTRACT_SUFX} --format=bsdtar --gid 0 --uid 0 --options gzip:!timestamp --no-recursion --null -T - && \
+ ${TAR} czf ${PORTNAME}-${DISTVERSIONFULL}${EXTRACT_SUFX} --format=ustar --gid 0 --uid 0 --options gzip:!timestamp --no-recursion --null -T - && \
${RM} -r ${PORTNAME}-${DISTVERSIONFULL}; \
fi
diff --git a/textproc/write-good/Makefile b/textproc/write-good/Makefile
index 9384473e3150..d82ddd1c61c0 100644
--- a/textproc/write-good/Makefile
+++ b/textproc/write-good/Makefile
@@ -67,10 +67,10 @@ _npm-regenerate:
${FIND} ${WRKDIR}/.npm ${WRKSRC}/node_modules -exec ${TOUCH} -h -d 1970-01-01T00:00:00Z {} \;
(cd ${WRKDIR} && \
${FIND} .npm/_cacache -print0 | LC_ALL=C ${SORT} -z | \
- ${TAR} czf ${WRKDIR}/${_NPM_DISTFILE_cache} --format=bsdtar --uid 0 --gid 0 --options gzip:!timestamp --no-recursion --null -T -)
+ ${TAR} czf ${WRKDIR}/${_NPM_DISTFILE_cache} --format=ustar --uid 0 --gid 0 --options gzip:!timestamp --no-recursion --null -T -)
(cd ${WRKDIR} && \
${FIND} ${WRKSRC:T}/node_modules -print0 | LC_ALL=C ${SORT} -z | \
- ${TAR} czf ${WRKDIR}/${_NPM_DISTFILE_modules} --format=bsdtar --uid 0 --gid 0 --options gzip:!timestamp --no-recursion --null -T -)
+ ${TAR} czf ${WRKDIR}/${_NPM_DISTFILE_modules} --format=ustar --uid 0 --gid 0 --options gzip:!timestamp --no-recursion --null -T -)
scp ${WRKDIR}/${_NPM_DISTFILE_cache} ${WRKDIR}/${_NPM_DISTFILE_modules} 0mp@freefall.freebsd.org:public_distfiles/
cp ${WRKDIR}/${_NPM_DISTFILE_cache} ${WRKDIR}/${_NPM_DISTFILE_modules} ${DISTDIR}/
diff --git a/textproc/xlnt/Makefile b/textproc/xlnt/Makefile
index fc7bc790d92b..7146d8afcdea 100644
--- a/textproc/xlnt/Makefile
+++ b/textproc/xlnt/Makefile
@@ -34,7 +34,7 @@ pre-fetch:
(cd ${LIBSTUDXML_NAME}-${LIBSTUDXML_REV} && git reset -q --hard ${LIBSTUDXML_REV} && ${RM} -r .git) && \
${FIND} ${LIBSTUDXML_NAME}-${LIBSTUDXML_REV} -and -exec ${TOUCH} -h -d 1970-01-01T00:00:00Z {} \; && \
${FIND} ${LIBSTUDXML_NAME}-${LIBSTUDXML_REV} -print0 | LC_ALL=C ${SORT} -z | \
- ${TAR} czf ${LIBSTUDXML_NAME}-${LIBSTUDXML_REV}${EXTRACT_SUFX} --format=bsdtar --gid 0 --uid 0 --options gzip:!timestamp --no-recursion --null -T - && \
+ ${TAR} czf ${LIBSTUDXML_NAME}-${LIBSTUDXML_REV}${EXTRACT_SUFX} --format=ustar --gid 0 --uid 0 --options gzip:!timestamp --no-recursion --null -T - && \
${RM} -r ${LIBSTUDXML_NAME}-${LIBSTUDXML_REV}; \
fi
diff --git a/x11/qimageblitz/Makefile b/x11/qimageblitz/Makefile
index 5bfc83df5e87..c023eb10d4c8 100644
--- a/x11/qimageblitz/Makefile
+++ b/x11/qimageblitz/Makefile
@@ -27,7 +27,7 @@ do-fetch:
(cd ${PORTNAME}-${DISTVERSIONFULL} && ${RM} -r .svn) && \
${FIND} ${PORTNAME}-${DISTVERSIONFULL} -and -exec ${TOUCH} -h -d 1970-01-01T00:00:00Z {} \; && \
${FIND} ${PORTNAME}-${DISTVERSIONFULL} -print0 | LC_ALL=C ${SORT} -z | \
- ${TAR} czf ${PORTNAME}-${DISTVERSIONFULL}${EXTRACT_SUFX} --format=bsdtar --uid 0 --gid 0 --options gzip:!timestamp --no-recursion --null -T - && \
+ ${TAR} czf ${PORTNAME}-${DISTVERSIONFULL}${EXTRACT_SUFX} --format=ustar --uid 0 --gid 0 --options gzip:!timestamp --no-recursion --null -T - && \
${RM} -r ${PORTNAME}-${DISTVERSIONFULL}; \
fi