aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-17 00:21:12 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-17 00:21:55 +0000
commit2b2f3d622280fd36587d85ffbe78b41356f5ea50 (patch)
tree6c65196bc34ac11b16ad8dc42bdcee37cee63299
parent7d045a0c3650e3b93b24898245a31ce31e82598e (diff)
downloadports-2b2f3d622280fd36587d85ffbe78b41356f5ea50.tar.gz
ports-2b2f3d622280fd36587d85ffbe78b41356f5ea50.zip
lang/zephir: Fix build with php82
Sponsored by: Bounce Experts
-rw-r--r--Mk/Uses/php.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/Mk/Uses/php.mk b/Mk/Uses/php.mk
index 19d335abe400..4d142472d140 100644
--- a/Mk/Uses/php.mk
+++ b/Mk/Uses/php.mk
@@ -382,10 +382,11 @@ _USE_PHP_ALL= bcmath bitset bz2 calendar ctype curl dba dom \
pdo_odbc pdo_pgsql pdo_sqlite phar pgsql posix \
pspell radius random readline redis session shmop simplexml snmp \
soap sockets sodium spl sqlite3 sysvmsg sysvsem sysvshm \
- tidy tokenizer xml xmlreader xmlrpc xmlwriter xsl zip zlib
+ tidy tokenizer xml xmlreader xmlrpc xmlwriter xsl zephir_parser \
+ zip zlib
# version specific components
-_USE_PHP_VER80= ${_USE_PHP_ALL} zephir_parser
-_USE_PHP_VER81= ${_USE_PHP_ALL} zephir_parser
+_USE_PHP_VER80= ${_USE_PHP_ALL}
+_USE_PHP_VER81= ${_USE_PHP_ALL}
_USE_PHP_VER82= ${_USE_PHP_ALL}
bcmath_DEPENDS= math/php${PHP_VER}-bcmath