aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-03-26 16:38:06 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-03-26 17:33:04 +0000
commit2b74e8c0ebd7a9ec905d5273a05a107ea098dc42 (patch)
tree0b5affb8cbdf73bbea8e0d3d26163d6bf4d1dd5e
parentdef7702e93614d140559aa1392ab4ce06acd1697 (diff)
downloadports-2b74e8c0ebd7a9ec905d5273a05a107ea098dc42.tar.gz
ports-2b74e8c0ebd7a9ec905d5273a05a107ea098dc42.zip
Mk/Features/lto.mk: switch LTO_UNSAFE consumers to WITHOUT_LTO
Passing -C lto=no while Cargo.toml has lto=true desyncs cargo and rustc: = note: ld: error: [...]: Opaque pointers are only supported in -opaque-pointers mode (Producer: 'LLVM17.0.6-rust-1.77.0-stable' Reader: 'LLVM 14.0.5') Reported by: pkg-fallout (for ~2 months)
-rw-r--r--devel/texlab/Makefile2
-rw-r--r--games/jumpy/Makefile2
-rw-r--r--games/veloren-weekly/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/devel/texlab/Makefile b/devel/texlab/Makefile
index 5ae2bf759953..e567ca5b3024 100644
--- a/devel/texlab/Makefile
+++ b/devel/texlab/Makefile
@@ -17,7 +17,7 @@ GH_ACCOUNT= latex-lsp
# Fixes: error: the linked panic runtime `panic_unwind` is not compiled with
# this crate's panic strategy `abort`
-LTO_UNSAFE= yes
+WITHOUT_LTO= yes # XXX bug 277333
PLIST_FILES= bin/${PORTNAME} \
share/man/man1/${PORTNAME}.1.gz
diff --git a/games/jumpy/Makefile b/games/jumpy/Makefile
index 216a1fd1070e..71e11c294355 100644
--- a/games/jumpy/Makefile
+++ b/games/jumpy/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:audio/alsa-pl
USES= cargo
USE_GITHUB= yes
GH_ACCOUNT= fishfolk
-LTO_UNSAFE= yes # bevy_dylib fails with -C panic=abort
+WITHOUT_LTO= yes # XXX bug 277333 # bevy_dylib
PLIST_FILES= bin/${PORTNAME}
PORTDATA= *
diff --git a/games/veloren-weekly/Makefile b/games/veloren-weekly/Makefile
index 3945b66239bf..9ef9066c0372 100644
--- a/games/veloren-weekly/Makefile
+++ b/games/veloren-weekly/Makefile
@@ -42,7 +42,7 @@ CONFLICTS_INSTALL= ${PORTNAME}
CARGO_ENV+= CARGO_PROFILE_RELEASE_LTO=false
.endif
# Fixes error "Instruction does not dominate all uses!"
-LTO_UNSAFE= yes
+WITHOUT_LTO= yes # XXX bug 277333
# https://gitlab.com/veloren/veloren/issues/264
CARGO_ENV+= RUSTC_BOOTSTRAP=1