aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2023-09-26 18:33:58 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2023-09-26 19:35:09 +0000
commit2b82f0b7c5cdf3c071f104c0f1aa5c1f18945b40 (patch)
tree3df792bf20fc57f86126d0c755f776d93834de3a
parentc4a9b245b9cad213011990cc07fa377cd101e0ef (diff)
downloadports-2b82f0b7c5cdf3c071f104c0f1aa5c1f18945b40.tar.gz
ports-2b82f0b7c5cdf3c071f104c0f1aa5c1f18945b40.zip
devel/cppcheck: update 2.10.3 → 2.12.1
-rw-r--r--devel/cppcheck/Makefile2
-rw-r--r--devel/cppcheck/distinfo6
-rw-r--r--devel/cppcheck/files/patch-CMakeLists.txt6
-rw-r--r--devel/cppcheck/files/patch-test_testpath.cpp14
4 files changed, 21 insertions, 7 deletions
diff --git a/devel/cppcheck/Makefile b/devel/cppcheck/Makefile
index 5065e238bf84..a5bcfcf64dc3 100644
--- a/devel/cppcheck/Makefile
+++ b/devel/cppcheck/Makefile
@@ -1,5 +1,5 @@
PORTNAME= cppcheck
-PORTVERSION= 2.10.3
+PORTVERSION= 2.12.1
CATEGORIES= devel
MAINTAINER= amdmi3@FreeBSD.org
diff --git a/devel/cppcheck/distinfo b/devel/cppcheck/distinfo
index 2b41c893c8dd..0d6560fcceb6 100644
--- a/devel/cppcheck/distinfo
+++ b/devel/cppcheck/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1679426311
-SHA256 (danmar-cppcheck-2.10.3_GH0.tar.gz) = 8aae5e116daeaaf5d19f3efa61b91c06f161cb97412a1d1af6e1e20686e48967
-SIZE (danmar-cppcheck-2.10.3_GH0.tar.gz) = 3447010
+TIMESTAMP = 1695753260
+SHA256 (danmar-cppcheck-2.12.1_GH0.tar.gz) = 2a3d4ba1179419612183ab3d6aed6d3b18be75e98cd6f138ea8e2020905dced2
+SIZE (danmar-cppcheck-2.12.1_GH0.tar.gz) = 3579702
diff --git a/devel/cppcheck/files/patch-CMakeLists.txt b/devel/cppcheck/files/patch-CMakeLists.txt
index 71a0b515cdb8..c09aa766944f 100644
--- a/devel/cppcheck/files/patch-CMakeLists.txt
+++ b/devel/cppcheck/files/patch-CMakeLists.txt
@@ -1,9 +1,9 @@
---- CMakeLists.txt.orig 2020-05-10 09:31:19 UTC
+--- CMakeLists.txt.orig 2023-06-22 09:07:56 UTC
+++ CMakeLists.txt
@@ -1,5 +1,5 @@
cmake_minimum_required(VERSION 2.8.12)
-project(Cppcheck)
+project(cppcheck)
- set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
-
+ include(cmake/cxx11.cmake)
+ use_cxx11()
diff --git a/devel/cppcheck/files/patch-test_testpath.cpp b/devel/cppcheck/files/patch-test_testpath.cpp
new file mode 100644
index 000000000000..2b21c01bc0d4
--- /dev/null
+++ b/devel/cppcheck/files/patch-test_testpath.cpp
@@ -0,0 +1,14 @@
+This test requires /proc to be mounted
+
+--- test/testpath.cpp.orig 2023-06-22 09:07:56 UTC
++++ test/testpath.cpp
+@@ -74,7 +74,9 @@ class TestPath : public TestFixture { (private)
+ }
+
+ void getCurrentExecutablePath() const {
++#ifndef __FreeBSD__
+ ASSERT_EQUALS(false, Path::getCurrentExecutablePath("").empty());
++#endif
+ }
+
+ void isAbsolute() const {