aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-09-10 12:53:31 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-09-10 13:02:46 +0000
commit2bc6062e5d37ee9204e07fce8b86ba8a7e11dcfa (patch)
tree9f502c3144eceeeda87bc6368a57038f8616d8b4
parente414d91050f02d702645ca55a01860e7f4bdbfbd (diff)
downloadports-2bc6062e5d37ee9204e07fce8b86ba8a7e11dcfa.tar.gz
ports-2bc6062e5d37ee9204e07fce8b86ba8a7e11dcfa.zip
finance/py-ta-lib: Update to 0.4.25
- Change MASTER_SITES to CHEESESHOP - Update COMMENT - Remove PYNUMPY - Update pkg-descr - Take maintainership Changes: https://github.com/mrjbq7/ta-lib/blob/master/CHANGELOG
-rw-r--r--finance/py-ta-lib/Makefile22
-rw-r--r--finance/py-ta-lib/distinfo6
-rw-r--r--finance/py-ta-lib/pkg-descr19
3 files changed, 28 insertions, 19 deletions
diff --git a/finance/py-ta-lib/Makefile b/finance/py-ta-lib/Makefile
index 80437308c9da..650af6fa98d6 100644
--- a/finance/py-ta-lib/Makefile
+++ b/finance/py-ta-lib/Makefile
@@ -1,29 +1,25 @@
PORTNAME= ta-lib
-DISTVERSIONPREFIX= TA_Lib-
-DISTVERSION= 0.4.24
+PORTVERSION= 0.4.25
CATEGORIES= finance python
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= TA-Lib-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Python wrapper for ta-lib (tools for market analysis)
+COMMENT= Python wrapper for TA-Lib (Technical Analysis Library)
WWW= https://mrjbq7.github.io/ta-lib/
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYNUMPY}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
LIB_DEPENDS= libta_lib.so:devel/ta-lib
-RUN_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
-USES= python:3.6+
-
-MAKE_ENV= TA_INCLUDE_PATH="${LOCALBASE}/include"
-
-USE_GITHUB= yes
-GH_ACCOUNT= mrjbq7
-USE_PYTHON= distutils cython autoplist
+USES= localbase python:3.7+
+USE_PYTHON= autoplist concurrent cython distutils
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/talib/_ta_lib*.so
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
.include <bsd.port.mk>
diff --git a/finance/py-ta-lib/distinfo b/finance/py-ta-lib/distinfo
index c982206f20a2..7267ccc251a8 100644
--- a/finance/py-ta-lib/distinfo
+++ b/finance/py-ta-lib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1644165462
-SHA256 (mrjbq7-ta-lib-TA_Lib-0.4.24_GH0.tar.gz) = 63733a3fde73b0ecea3af931c90b0ff95589e9fdb3af5991058933622d6e5434
-SIZE (mrjbq7-ta-lib-TA_Lib-0.4.24_GH0.tar.gz) = 339618
+TIMESTAMP = 1662558054
+SHA256 (TA-Lib-0.4.25.tar.gz) = 6c51c09fcc138367483bcce6db81329ae6851e6ca1a8ac1e50732e443d15602b
+SIZE (TA-Lib-0.4.25.tar.gz) = 271960
diff --git a/finance/py-ta-lib/pkg-descr b/finance/py-ta-lib/pkg-descr
index c5fee2daaef8..3b8987f36de1 100644
--- a/finance/py-ta-lib/pkg-descr
+++ b/finance/py-ta-lib/pkg-descr
@@ -1,4 +1,17 @@
-py-ta-lib is a Python wrapper for TA-LIB (a marketing analysis library)
-based on Cython.
+This is a Python wrapper for TA-LIB based on Cython instead of SWIG. From the
+homepage:
-It is intended to perform marketing analysis in Python programs.
+TA-Lib is widely used by trading software developers requiring to perform
+technical analysis of financial market data.
+- Includes 150+ indicators such as ADX, MACD, RSI, Stochastic, Bollinger Bands,
+ etc.
+- Candlestick pattern recognition
+- Open-source API for C/C++, Java, Perl, Python and 100% Managed .NET
+
+The original Python bindings included with TA-Lib use SWIG which unfortunately
+are difficult to install and aren't as efficient as they could be. Therefore
+this project uses Cython and Numpy to efficiently and cleanly bind to TA-Lib --
+producing results 2-4 times faster than the SWIG interface.
+
+In addition, this project also supports the use of the Polars and Pandas
+libraries.