aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:35:05 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:19:50 +0000
commit2c1764125a4770fdd8e30d63737c94082af6f676 (patch)
treed55622c05b7d3b82e190e1ee679d75e0bf9d7c6b
parent321b35e57e2536c906ad698d2572e74f963e899a (diff)
downloadports-2c1764125a4770fdd8e30d63737c94082af6f676.tar.gz
ports-2c1764125a4770fdd8e30d63737c94082af6f676.zip
devel/py-glom: Add py-glom 22.1.0
Real applications have real data, and real data nests. Objects inside of objects inside of lists of objects. glom is a new and powerful way to handle real-world data, featuring: - Path-based access for nested data structures - Readable, meaningful error messages - Declarative data transformation, using lightweight, Pythonic specifications - Built-in data exploration and debugging features All of that and more, available as a fully-documented, pure-Python package.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-glom/Makefile23
-rw-r--r--devel/py-glom/distinfo3
-rw-r--r--devel/py-glom/pkg-descr10
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ac2857d82ef9..a32a3657438d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4656,6 +4656,7 @@
SUBDIR += py-giturlparse
SUBDIR += py-glance-store
SUBDIR += py-glob2
+ SUBDIR += py-glom
SUBDIR += py-gobject3
SUBDIR += py-google-cloud-iam
SUBDIR += py-google-crc32c
diff --git a/devel/py-glom/Makefile b/devel/py-glom/Makefile
new file mode 100644
index 000000000000..cb7352d45899
--- /dev/null
+++ b/devel/py-glom/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= glom
+PORTVERSION= 22.1.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Declarative object transformer and formatter
+WWW= https://github.com/mahmoud/glom
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}attrs>=0:devel/py-attrs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}boltons>=19.3.0:devel/py-boltons@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}face>=20.1.0:devel/py-face@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-glom/distinfo b/devel/py-glom/distinfo
new file mode 100644
index 000000000000..7a12bb22d6aa
--- /dev/null
+++ b/devel/py-glom/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1677770923
+SHA256 (glom-22.1.0.tar.gz) = 1510c6587a8f9c64a246641b70033cbc5ebde99f02ad245693678038e821aeb5
+SIZE (glom-22.1.0.tar.gz) = 189738
diff --git a/devel/py-glom/pkg-descr b/devel/py-glom/pkg-descr
new file mode 100644
index 000000000000..52f11d07dbbe
--- /dev/null
+++ b/devel/py-glom/pkg-descr
@@ -0,0 +1,10 @@
+Real applications have real data, and real data nests. Objects inside of objects
+inside of lists of objects.
+
+glom is a new and powerful way to handle real-world data, featuring:
+- Path-based access for nested data structures
+- Readable, meaningful error messages
+- Declarative data transformation, using lightweight, Pythonic specifications
+- Built-in data exploration and debugging features
+
+All of that and more, available as a fully-documented, pure-Python package.