aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-09-02 00:48:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-09-02 00:50:40 +0000
commit2c18c2a2da988ef399c05674f8bd7ab093caa6e8 (patch)
tree42322ab0da72b236509a14b3f015a07fbeded709
parent94ed6cbc3e83edb1d7bc48ce7b6251b3cf87365a (diff)
downloadports-2c18c2a2da988ef399c05674f8bd7ab093caa6e8.tar.gz
ports-2c18c2a2da988ef399c05674f8bd7ab093caa6e8.zip
net-p2p/qbittorrent: Use Qt6
Based on patch submitted by: Nuno Teixeira <eduardo@freebsd.org>
-rw-r--r--net-p2p/qbittorrent/Makefile27
-rw-r--r--net-p2p/qbittorrent/pkg-plist2
-rw-r--r--net-p2p/qbittorrent/pkg-plist-nox2
3 files changed, 11 insertions, 20 deletions
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index b473086d8610..f9e81b94dbc8 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -1,5 +1,6 @@
PORTNAME= qbittorrent
DISTVERSION= 4.5.5
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -21,24 +22,21 @@ FLAVOR?= ${FLAVORS:[1]}
nox_PKGNAMESUFFIX= -nox
nox_PLIST= ${MASTERDIR}/pkg-plist-nox
-USES= compiler:c++14-lang cpe pkgconfig qmake:no_env qt:5 ssl tar:xz
-GNU_CONFIGURE= yes
-USE_QT= core network sql xml buildtools:build linguisttools:build qmake:build
-DESTDIRNAME= INSTALL_ROOT
-CONFIGURE_ENV+= openssl_CFLAGS="-I${OPENSSLINC}" openssl_LIBS="-L${OPENSSLLIB} -lssl"
-
+USES= compiler:c++14-lang cpe pkgconfig cmake qt:6 ssl tar:xz
+USE_QT= base svg translations
USE_CXXSTD= c++17 # prevent boost-related SEGV, see bug#264278
+CMAKE_ON= QT6
+
.if ${FLAVOR} == default
USES+= desktop-file-utils gl
-USE_QT+= concurrent gui svg widgets
USE_GL= gl
.endif
.if ${FLAVOR} == nox
SUFFIX= -nox
COMMENT+= (web UI version)
-CONFIGURE_ARGS= --disable-gui
+CMAKE_OFF= GUI
USERS= qbittorrent
GROUPS= qbittorrent
USE_RC_SUBR= qbittorrent
@@ -56,9 +54,8 @@ LIBTORRENT_DESC= libtorrent version number to use
LIBTORRENT1_DESC= Version 1.x (default)
LIBTORRENT2_DESC= Version 2.x (experimental)
-DEBUG_CONFIGURE_ENABLE= debug
-DBUS_CONFIGURE_ENABLE= qt-dbus
-DBUS_USE= qt=dbus
+DEBUG_CMAKE_BOOL= debug
+DBUS_CMAKE_BOOL= DBUS
LIBTORRENT1_BUILD_DEPENDS= libtorrent-rasterbar>0:net-p2p/libtorrent-rasterbar
LIBTORRENT1_RUN_DEPENDS= libtorrent-rasterbar>0:net-p2p/libtorrent-rasterbar
@@ -68,15 +65,9 @@ LIBTORRENT2_EXTRA_PATCHES= ${FILESDIR}/extrapatch-libtorrent-rasterbar2-settings
PYTHON_DESC= Install Python to support some plugin functionality
PYTHON_USES= python:run
-
-post-patch-PYTHON-on:
- @${REINPLACE_CMD} -e 's|"python3"|"${PYTHON_CMD}"|' ${WRKSRC}/src/base/utils/foreignapps.cpp
+PYTHON_BINARY_ALIAS= python3=${PYTHON_CMD}
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/qbittorrent${SUFFIX}
- ${INSTALL_MAN} ${WRKSRC}/doc/qbittorrent${SUFFIX}.1 \
- ${STAGEDIR}${MAN1PREFIX}/man/man1/
- @${RM} -r ${STAGEDIR}${PREFIX}/share/man
.if ${FLAVOR} == nox
@${MKDIR} ${STAGEDIR}/var/db/qbittorrent/conf ${STAGEDIR}/var/db/qbittorrent/Downloads
.endif
diff --git a/net-p2p/qbittorrent/pkg-plist b/net-p2p/qbittorrent/pkg-plist
index 8948a92d77f1..bb3a6942104f 100644
--- a/net-p2p/qbittorrent/pkg-plist
+++ b/net-p2p/qbittorrent/pkg-plist
@@ -1,5 +1,4 @@
bin/qbittorrent
-man/man1/qbittorrent.1.gz
share/applications/org.qbittorrent.qBittorrent.desktop
share/icons/hicolor/128x128/apps/qbittorrent.png
share/icons/hicolor/128x128/status/qbittorrent-tray.png
@@ -27,4 +26,5 @@ share/icons/hicolor/scalable/apps/qbittorrent.svg
share/icons/hicolor/scalable/status/qbittorrent-tray-dark.svg
share/icons/hicolor/scalable/status/qbittorrent-tray-light.svg
share/icons/hicolor/scalable/status/qbittorrent-tray.svg
+share/man/man1/qbittorrent.1.gz
share/metainfo/org.qbittorrent.qBittorrent.appdata.xml
diff --git a/net-p2p/qbittorrent/pkg-plist-nox b/net-p2p/qbittorrent/pkg-plist-nox
index c97540d3a802..6371e4b212e9 100644
--- a/net-p2p/qbittorrent/pkg-plist-nox
+++ b/net-p2p/qbittorrent/pkg-plist-nox
@@ -1,5 +1,5 @@
bin/qbittorrent-nox
-man/man1/qbittorrent-nox.1.gz
+share/man/man1/qbittorrent-nox.1.gz
@owner %%USER%%
@group %%GROUP%%
@dir /var/db/qbittorrent/conf