aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2021-11-08 19:19:45 +0000
committerDima Panov <fluffy@FreeBSD.org>2021-11-08 19:19:45 +0000
commit2c19e3db5a22553b5f9c98fc49591fcb89af7a4d (patch)
tree2886729c6f0699d2a74d985f9ddaedf729898ea5
parent4d9306b10a28855d081bfb94cfa34f4390f9f1a5 (diff)
downloadports-2c19e3db5a22553b5f9c98fc49591fcb89af7a4d.tar.gz
ports-2c19e3db5a22553b5f9c98fc49591fcb89af7a4d.zip
devel/libantlr4: update to 4.9.3 release
Use external utf8cpp
-rw-r--r--devel/libantlr4/Makefile4
-rw-r--r--devel/libantlr4/distinfo6
-rw-r--r--devel/libantlr4/files/patch-runtime_CMakeLists.txt34
-rw-r--r--devel/libantlr4/pkg-plist8
4 files changed, 8 insertions, 44 deletions
diff --git a/devel/libantlr4/Makefile b/devel/libantlr4/Makefile
index 608a44550e3a..67fb833e3630 100644
--- a/devel/libantlr4/Makefile
+++ b/devel/libantlr4/Makefile
@@ -1,7 +1,7 @@
# Created by: Muhammad Moinur Rahman<5u623l20@gmail.com>
PORTNAME= antlr4
-PORTVERSION= 4.9.1
+PORTVERSION= 4.9.3
DISTVERSIONPREFIX= cpp-runtime-
DISTVERSIONSUFFIX= -source
CATEGORIES= devel
@@ -13,6 +13,8 @@ COMMENT= ANother Tool for Language Recognition (C runtime)
LICENSE= BSD3CLAUSE
+BUILD_DEPENDS= utf8cpp>0:devel/utf8cpp
+
USES= cmake compiler:c11 zip
NO_WRKSUBDIR= yes
diff --git a/devel/libantlr4/distinfo b/devel/libantlr4/distinfo
index 188b43adcafc..f3858566ff20 100644
--- a/devel/libantlr4/distinfo
+++ b/devel/libantlr4/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1629116842
-SHA256 (antlr4-cpp-runtime-4.9.1-source.zip) = 21647f9d5c55d13f2297e3f61e5dd68283e439983c27bd899f9c8a725bbea7b5
-SIZE (antlr4-cpp-runtime-4.9.1-source.zip) = 670184
+TIMESTAMP = 1636372293
+SHA256 (antlr4-cpp-runtime-4.9.3-source.zip) = 5f0af6efd81f476c3e775c486eb0a71c25d6bbc14373e88a64690e2738d68e03
+SIZE (antlr4-cpp-runtime-4.9.3-source.zip) = 488286
diff --git a/devel/libantlr4/files/patch-runtime_CMakeLists.txt b/devel/libantlr4/files/patch-runtime_CMakeLists.txt
deleted file mode 100644
index b1d59d41046c..000000000000
--- a/devel/libantlr4/files/patch-runtime_CMakeLists.txt
+++ /dev/null
@@ -1,34 +0,0 @@
---- runtime/CMakeLists.txt.orig 2020-10-10 06:11:48 UTC
-+++ runtime/CMakeLists.txt
-@@ -1,19 +1,9 @@
-
- include(${CMAKE_ROOT}/Modules/ExternalProject.cmake)
-
--set(THIRDPARTY_DIR ${CMAKE_BINARY_DIR}/runtime/thirdparty)
-+set(THIRDPARTY_DIR ${PROJECT_SOURCE_DIR}/runtime/thirdparty)
- set(UTFCPP_DIR ${THIRDPARTY_DIR}/utfcpp)
--ExternalProject_Add(
-- utfcpp
-- GIT_REPOSITORY "git://github.com/nemtrif/utfcpp"
-- GIT_TAG "v3.1.1"
-- SOURCE_DIR ${UTFCPP_DIR}
-- UPDATE_DISCONNECTED 1
-- CMAKE_ARGS -DCMAKE_INSTALL_PREFIX=${UTFCPP_DIR}/install -Dgtest_force_shared_crt=ON
-- TEST_AFTER_INSTALL 1
-- STEP_TARGETS build)
-
--
- include_directories(
- ${PROJECT_SOURCE_DIR}/runtime/src
- ${PROJECT_SOURCE_DIR}/runtime/src/atn
-@@ -23,8 +13,8 @@ include_directories(
- ${PROJECT_SOURCE_DIR}/runtime/src/tree
- ${PROJECT_SOURCE_DIR}/runtime/src/tree/pattern
- ${PROJECT_SOURCE_DIR}/runtime/src/tree/xpath
-- ${UTFCPP_DIR}/install/include/utf8cpp
-- ${UTFCPP_DIR}/install/include/utf8cpp/utf8
-+ ${UTFCPP_DIR}/source/
-+ ${UTFCPP_DIR}/source/utf8
- )
-
-
diff --git a/devel/libantlr4/pkg-plist b/devel/libantlr4/pkg-plist
index 2d0b12591f6e..546c579d536e 100644
--- a/devel/libantlr4/pkg-plist
+++ b/devel/libantlr4/pkg-plist
@@ -122,9 +122,10 @@ include/antlr4-runtime/support/Any.h
include/antlr4-runtime/support/Arrays.h
include/antlr4-runtime/support/BitSet.h
include/antlr4-runtime/support/CPPUtils.h
+include/antlr4-runtime/support/Casts.h
include/antlr4-runtime/support/Declarations.h
+include/antlr4-runtime/support/Guid.h
include/antlr4-runtime/support/StringUtils.h
-include/antlr4-runtime/support/guid.h
include/antlr4-runtime/tree/AbstractParseTreeVisitor.h
include/antlr4-runtime/tree/ErrorNode.h
include/antlr4-runtime/tree/ErrorNodeImpl.h
@@ -155,11 +156,6 @@ include/antlr4-runtime/tree/xpath/XPathTokenAnywhereElement.h
include/antlr4-runtime/tree/xpath/XPathTokenElement.h
include/antlr4-runtime/tree/xpath/XPathWildcardAnywhereElement.h
include/antlr4-runtime/tree/xpath/XPathWildcardElement.h
-include/antlr4-runtime/utf8.h
-include/antlr4-runtime/utf8/checked.h
-include/antlr4-runtime/utf8/core.h
-include/antlr4-runtime/utf8/cpp11.h
-include/antlr4-runtime/utf8/unchecked.h
lib/libantlr4-runtime.a
lib/libantlr4-runtime.so
lib/libantlr4-runtime.so.%%LIBVERSION%%