aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-06 21:45:22 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-06 21:53:05 +0000
commit2c215b822a65d0f0c24863227e3145d743943ca0 (patch)
tree793f1c7e1ef435872b43a7e9597fa054ee9f20c9
parenta79ba32c2ce95911b11dbb6e8143f74dd355444f (diff)
downloadports-2c215b822a65d0f0c24863227e3145d743943ca0.tar.gz
ports-2c215b822a65d0f0c24863227e3145d743943ca0.zip
astro/celestia: Fix build with llvm16
- Utilize USES=localbase Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--astro/celestia/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 81efc9d9adee..1dbc884f9d18 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -13,7 +13,9 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png
-USES= compiler:c++11-lang gettext gl gmake jpeg libtool lua:52 pkgconfig
+USES= compiler:c++11-lang gettext gl gmake jpeg libtool localbase:ldflags \
+ lua:52 pkgconfig
+USE_CXXSTD= c++14
USE_GL= gl
GNU_CONFIGURE= yes
EXTRA_PATCHES= ${FILESDIR}/celestia-1.6.1-lua-5.2.patch:-p1 \
@@ -22,8 +24,7 @@ EXTRA_PATCHES= ${FILESDIR}/celestia-1.6.1-lua-5.2.patch:-p1 \
${FILESDIR}/celestia-1.6.1-gcc48.patch:-p1
CXXFLAGS+= -fsigned-char # fix text rendering (see Gentoo bug 316573)
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -pthread
+LDFLAGS+= -pthread
UI_LIST= glut gtk gnome
CELESTIA_UI?= glut