aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2021-05-03 07:41:21 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2021-05-03 07:41:54 +0000
commit2c440ff75fa71bf94cb2ff41f3a9140dd6ce0581 (patch)
treeedcda06660be47dd1f5c3051fb7fe85c585006a5
parent3f972f481c2beece9d0d958e4b4e0d861f4257a8 (diff)
downloadports-2c440ff75fa71bf94cb2ff41f3a9140dd6ce0581.tar.gz
ports-2c440ff75fa71bf94cb2ff41f3a9140dd6ce0581.zip
databases/rubygem-gitlab-pg_query: Remove obsolete ports
Use databases/rubygem-pg_query instead.
-rw-r--r--MOVED1
-rw-r--r--databases/Makefile1
-rw-r--r--databases/rubygem-gitlab-pg_query/Makefile22
-rw-r--r--databases/rubygem-gitlab-pg_query/distinfo3
-rw-r--r--databases/rubygem-gitlab-pg_query/files/patch-ext_pg__query_extconf.rb56
-rw-r--r--databases/rubygem-gitlab-pg_query/pkg-descr7
6 files changed, 1 insertions, 89 deletions
diff --git a/MOVED b/MOVED
index ff8fb539d161..d22213e8a39f 100644
--- a/MOVED
+++ b/MOVED
@@ -16327,3 +16327,4 @@ devel/libbonobo||2021-05-01|Dead upstream, no consumers left in the ports tree
x11-toolkits/p5-Gtk2-Unique||2021-05-01|Dead upstream, no consumers left in the ports tree
sysutils/policykit-gnome||2021-05-01|Gnome2 component, no consumers left in the ports tree
sysutils/policykit|sysutils/polkit|2021-05-01|Gnome2 component, no consumers left in the ports tree
+databases/rubygem-gitlab-pg_query|databases/rubygem-pg_query|2021-05-03|Obsolete, please use databases/rubygem-pg_query
diff --git a/databases/Makefile b/databases/Makefile
index d551fcd2298e..8aa53036b3c6 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -925,7 +925,6 @@
SUBDIR += rubygem-flipper-active_record
SUBDIR += rubygem-flipper-active_record017
SUBDIR += rubygem-gdbm
- SUBDIR += rubygem-gitlab-pg_query
SUBDIR += rubygem-globalid
SUBDIR += rubygem-globalid-rails5
SUBDIR += rubygem-globalid-rails50
diff --git a/databases/rubygem-gitlab-pg_query/Makefile b/databases/rubygem-gitlab-pg_query/Makefile
deleted file mode 100644
index 4dcff88c74e9..000000000000
--- a/databases/rubygem-gitlab-pg_query/Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
-# Created by: Matthias Fechner <mfechner@FreeBSD.org>
-
-PORTNAME= gitlab-pg_query
-PORTVERSION= 1.3.1
-PORTREVISION= 0
-CATEGORIES= databases rubygems
-MASTER_SITES= RG
-
-MAINTAINER= mfechner@FreeBSD.org
-COMMENT= Parses SQL queries using a copy of the PostgreSQL server query parser
-
-LICENSE= BSD3CLAUSE
-LICENSE_FILE= ${WRKSRC}/LICENSE
-
-MY_DEPENDS= ${LOCALBASE}/lib/libpg_query.a:databases/libpg_query
-BUILD_DEPENDS= ${MY_DEPENDS}
-RUN_DEPENDS= ${MY_DEPENDS}
-
-USES= gem
-USE_RUBY= yes
-
-.include <bsd.port.mk>
diff --git a/databases/rubygem-gitlab-pg_query/distinfo b/databases/rubygem-gitlab-pg_query/distinfo
deleted file mode 100644
index 303e69eae455..000000000000
--- a/databases/rubygem-gitlab-pg_query/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1609489189
-SHA256 (rubygem/gitlab-pg_query-1.3.1.gem) = ef28bf4639a749db9efb8d9f5358bd1ff43e1039a2371c88b95b51e6658ecbe7
-SIZE (rubygem/gitlab-pg_query-1.3.1.gem) = 35328
diff --git a/databases/rubygem-gitlab-pg_query/files/patch-ext_pg__query_extconf.rb b/databases/rubygem-gitlab-pg_query/files/patch-ext_pg__query_extconf.rb
deleted file mode 100644
index 5189d50430f5..000000000000
--- a/databases/rubygem-gitlab-pg_query/files/patch-ext_pg__query_extconf.rb
+++ /dev/null
@@ -1,56 +0,0 @@
---- ext/pg_query/extconf.rb.orig 2021-01-01 08:22:43 UTC
-+++ ext/pg_query/extconf.rb
-@@ -4,53 +4,9 @@ require 'digest'
- require 'mkmf'
- require 'open-uri'
-
--LIB_PG_QUERY_TAG = '10-1.0.3'.freeze
--
- workdir = Dir.pwd
--libdir = File.join(workdir, 'libpg_query-' + LIB_PG_QUERY_TAG)
- gemdir = File.join(__dir__, '../..')
--libfile = libdir + '/libpg_query.a'
-
--expected_sha256 = '1332761f31c198cb9825e6ccccda0b6a0e57daeb824870e8524df77f1592d149'
--filename = "#{workdir}/libpg_query.tar.gz"
--
--unless File.exist?(filename)
-- File.open(filename, 'wb') do |target_file|
-- URI.open('https://codeload.github.com/lfittl/libpg_query/tar.gz/' + LIB_PG_QUERY_TAG, 'rb') do |read_file|
-- target_file.write(read_file.read)
-- end
-- end
--
-- checksum = Digest::SHA256.hexdigest(File.read(filename))
--
-- if checksum != expected_sha256
-- raise "SHA256 of #{filename} does not match: got #{checksum}, expected #{expected_sha256}"
-- end
--end
--
--unless Dir.exist?(libdir)
-- system("tar -xzf #{filename}") || raise('ERROR')
--end
--
--unless Dir.exist?(libfile)
-- # Build libpg_query (and parts of PostgreSQL)
-- system("cd #{libdir}; #{ENV['MAKE'] || (RUBY_PLATFORM =~ /bsd/ ? 'gmake' : 'make')} build")
--end
--
--# Copy test files (this intentionally overwrites existing files!)
--system("cp #{libdir}/testdata/* #{gemdir}/spec/files/")
--
- $objs = ['pg_query_ruby.o']
--
--$LOCAL_LIBS << '-lpg_query'
--$LIBPATH << libdir
--$CFLAGS << " -I #{libdir} -O3 -Wall -fno-strict-aliasing -fwrapv -g"
--
--SYMFILE = File.join(__dir__, 'pg_query_ruby.sym')
--if RUBY_PLATFORM =~ /darwin/
-- $DLDFLAGS << " -Wl,-exported_symbols_list #{SYMFILE}" unless defined?(::Rubinius)
--else
-- $DLDFLAGS << " -Wl,--retain-symbols-file=#{SYMFILE}"
--end
-
- create_makefile 'pg_query/pg_query'
diff --git a/databases/rubygem-gitlab-pg_query/pkg-descr b/databases/rubygem-gitlab-pg_query/pkg-descr
deleted file mode 100644
index 7a86795e7fa5..000000000000
--- a/databases/rubygem-gitlab-pg_query/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-This Ruby extension uses the actual PostgreSQL server source
-to parse SQL queries and return the internal PostgreSQL parsetree.
-
-In addition the extension allows you to normalize queries (replacing constant
-values with ?) and parse these normalized queries into a parsetree again.
-
-WWW: https://github.com/lfittl/pg_query