aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2021-12-29 18:16:02 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2021-12-29 18:16:31 +0000
commit2c513be320c898d676bd08329a1389096e2249d5 (patch)
tree453596d2c585adbf9f51745c1f009e3d6d1fcb2b
parentdc319b36e0e2b6c693d63f0995072ee57c58446a (diff)
downloadports-2c513be320c898d676bd08329a1389096e2249d5.tar.gz
ports-2c513be320c898d676bd08329a1389096e2249d5.zip
www/nginx-devel: update from 1.21.4 to 1.21.5.
Please note: it's possible to build the recent version of nginx with PCRE2 library, but several third-party modules have some build issues, so let's keep www/nginx-devel depends on PCRE1 library for now, but keep in mind it needs to switched to the modern, i.e. second, version of PCRE. <Changelog> Changes with nginx 1.21.5 *) Change: now nginx is built with the PCRE2 library by default. *) Change: now nginx always uses sendfile(SF_NODISKIO) on FreeBSD. *) Feature: support for sendfile(SF_NOCACHE) on FreeBSD. *) Feature: the $ssl_curve variable. *) Bugfix: connections might hang when using HTTP/2 without SSL with the "sendfile" and "aio" directives. Changes with njs 0.7.1 nginx modules: *) Change: the "js_include" directive deprecated since 0.4.0 was removed. *) Change: PCRE/PCRE2-specific code was moved to the modules. This ensures that njs uses the same RegExp library as nginx. Core: *) Feature: extended "fs" module. Added stat(), fstat() and friends. *) Change: default RegExp engine for CLI is switched to PCRE2. *) Bugfix: fixed decodeURI() and decodeURIComponent() with invalid byte strings. The bug was introduced in 0.4.3. *) Bugfix: fixed heap-use-after-free in await frame. The bug was introduced in 0.7.0. *) Bugfix: fixed WebCrypto sign() and verify() methods with OpenSSL 3.0. *) Bugfix: fixed exception throwing when RegExp match fails. The bug was introduced in 0.1.15. *) Bugfix: fixed catching of exception thrown in try block of async function. The bug was introduced in 0.7.0. *) Bugfix: fixed execution of async function in synchronous context. The bug was introduced in 0.7.0. *) Bugfix: fixed function redeclaration in CLI when interactive mode is on. The bug was introduced in 0.6.2. *) Bugfix: fixed typeof operator with DataView object. *) Bugfix: eliminated information leak in Buffer.from(). </Changelog>
-rw-r--r--www/nginx-devel/Makefile11
-rw-r--r--www/nginx-devel/Makefile.extmod2
-rw-r--r--www/nginx-devel/distinfo10
3 files changed, 12 insertions, 11 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index f5c5eac910cb..24eb3bed05bf 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -1,8 +1,7 @@
# Created by: Sergey A. Osokin <osa@FreeBSD.org>
PORTNAME?= nginx
-PORTVERSION= 1.21.4
-PORTREVISION= 1
+PORTVERSION= 1.21.5
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
LOCAL/osa
@@ -154,7 +153,7 @@ HTTP_PERL_VARS= DSO_BASEMODS+=http_perl_module
HTTP_RANDOM_INDEX_CONFIGURE_ON= --with-http_random_index_module
HTTP_REALIP_CONFIGURE_ON= --with-http_realip_module
HTTP_REWRITE_LIB_DEPENDS= libpcre.so:devel/pcre
-HTTP_REWRITE_CONFIGURE_ON= --with-pcre
+HTTP_REWRITE_CONFIGURE_ON= --with-pcre --without-pcre2
HTTP_REWRITE_CONFIGURE_OFF= --without-http_rewrite_module
HTTP_SECURE_LINK_CONFIGURE_ON= --with-http_secure_link_module
HTTP_SLICE_CONFIGURE_ON= --with-http_slice_module
@@ -307,7 +306,9 @@ pre-configure-SMALL_LIGHT-on:
( cd ${WRKSRC_small_light} && ./setup )
do-configure-NJS-on:
- ( cd ${WRKSRC_njs} && ${SETENV} ${CONFIGURE_ENV} ${CONFIGURE_CMD} )
+ ( cd ${WRKSRC_njs} && ${SETENV} ${CONFIGURE_ENV} ${CONFIGURE_CMD} --no-pcre2 \
+ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} njs \
+ && ${MV} build/njs ${WRKSRC_njs} )
.if !target(do-install)
do-install:
@@ -344,7 +345,7 @@ do-install-NAXSI-on:
${STAGEDIR}${ETCDIR}
do-install-NJS-on:
- ${INSTALL_PROGRAM} ${WRKSRC_njs}/build/njs ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC_njs}/njs ${STAGEDIR}${PREFIX}/sbin
.endif
.if !target(post-install)
diff --git a/www/nginx-devel/Makefile.extmod b/www/nginx-devel/Makefile.extmod
index 95995623743c..43a4b041bc0e 100644
--- a/www/nginx-devel/Makefile.extmod
+++ b/www/nginx-devel/Makefile.extmod
@@ -244,7 +244,7 @@ NAXSI_NGINX_VER= 1.3
NAXSI_GH_TUPLE= nbs-system:naxsi:${NAXSI_NGINX_VER}:naxsi
NAXSI_VARS= DSO_EXTMODS+=naxsi NAXSI_SUBDIR=/naxsi_src
-NJS_GH_TUPLE= nginx:njs:0.7.0:njs
+NJS_GH_TUPLE= nginx:njs:0.7.1:njs
NJS_VARS= DSO_EXTMODS+=njs NJS_SUBDIR=/nginx
NJS_USES= libedit
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 1514e9269f2a..cc0704cbebb6 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1638983725
-SHA256 (nginx-1.21.4.tar.gz) = d1f72f474e71bcaaf465dcc7e6f7b6a4705e4b1ed95c581af31df697551f3bfe
-SIZE (nginx-1.21.4.tar.gz) = 1070260
+TIMESTAMP = 1640793367
+SHA256 (nginx-1.21.5.tar.gz) = b20f3bf533a518a6f0f3a7967dfeed872d268d31e4cc121a0001329602ddcfbb
+SIZE (nginx-1.21.5.tar.gz) = 1072633
SHA256 (nginx_mogilefs_module-1.0.4.tar.gz) = 7ac230d30907f013dff8d435a118619ea6168aa3714dba62c6962d350c6295ae
SIZE (nginx_mogilefs_module-1.0.4.tar.gz) = 11208
SHA256 (nginx_mod_h264_streaming-2.2.7.tar.gz) = 6d974ba630cef59de1f60996c66b401264a345d25988a76037c2856cec756c19
@@ -111,8 +111,8 @@ SHA256 (SpiderLabs-ModSecurity-nginx-v1.0.2_GH0.tar.gz) = f8d3ff15520df736c5e20e
SIZE (SpiderLabs-ModSecurity-nginx-v1.0.2_GH0.tar.gz) = 33767
SHA256 (nbs-system-naxsi-1.3_GH0.tar.gz) = 439c8677372d2597b4360bbcc10bc86490de1fc75695b193ad5df154a214d628
SIZE (nbs-system-naxsi-1.3_GH0.tar.gz) = 235626
-SHA256 (nginx-njs-0.7.0_GH0.tar.gz) = 3f0fe7d77600a9c54000ce101dd51f44811964502641ae505e38c1bbf595e6f1
-SIZE (nginx-njs-0.7.0_GH0.tar.gz) = 575477
+SHA256 (nginx-njs-0.7.1_GH0.tar.gz) = f5493b444ef54f1edba85c7adcbb1132e61c36d47de8f7a8d351965cad6d5486
+SIZE (nginx-njs-0.7.1_GH0.tar.gz) = 583195
SHA256 (opentracing-contrib-nginx-opentracing-842d21f_GH0.tar.gz) = d15d5d4caa2b864fb820c9c6e373adb3eab10cfe2e5a39e98727245db4cc92c4
SIZE (opentracing-contrib-nginx-opentracing-842d21f_GH0.tar.gz) = 676206
SHA256 (konstruxi-ngx_postgres-8aa7359_GH0.tar.gz) = c69ad4495de7c7883ebc23e1e6c4cc83a4ac6a7fddd4d5c12e49d33b65f7c50b