aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2024-03-15 20:50:32 +0000
committerCharlie Li <vishwin@FreeBSD.org>2024-03-15 20:54:39 +0000
commit2c701627c182315684e2d8b0b50a8c68a5413622 (patch)
tree5e625665311f8b7449045e1d81dd9c62248ce6c0
parent133ed6be91f362717b7ae81fd6bd2124e6cbb7ec (diff)
downloadports-2c701627c182315684e2d8b0b50a8c68a5413622.tar.gz
ports-2c701627c182315684e2d8b0b50a8c68a5413622.zip
audio/libdjinterop: add 0.20.1
This is not the newest upstream version, but audio/mixxx 2.4.0 (latest upstream) specifically requires this version for the respective functionality. Similar arrangement to editors/libreoffice pegging specific versions of certain dependencies.
-rw-r--r--audio/Makefile1
-rw-r--r--audio/libdjinterop/Makefile22
-rw-r--r--audio/libdjinterop/distinfo3
-rw-r--r--audio/libdjinterop/pkg-descr6
-rw-r--r--audio/libdjinterop/pkg-plist38
5 files changed, 70 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index ac384c5d3c2a..c9ef444b9e81 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -348,6 +348,7 @@
SUBDIR += libconvolve
SUBDIR += libcoverart
SUBDIR += libdiscid
+ SUBDIR += libdjinterop
SUBDIR += libdssialsacompat
SUBDIR += libebur128
SUBDIR += libechonest
diff --git a/audio/libdjinterop/Makefile b/audio/libdjinterop/Makefile
new file mode 100644
index 000000000000..275f83322f13
--- /dev/null
+++ b/audio/libdjinterop/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= libdjinterop
+DISTVERSION= 0.20.1
+CATEGORIES= audio
+
+MAINTAINER= vishwin@FreeBSD.org
+COMMENT= C++ library for access to DJ record libraries
+WWW= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= boost-libs>0:devel/boost-libs # for test programs
+
+USES= compiler:c++17-lang cmake:testing sqlite
+
+USE_GITHUB= yes
+GH_ACCOUNT= xsco
+
+PORTSCOUT= ignore:1 # audio/mixxx dictates us
+PLIST_SUB= VERSION=${DISTVERSION}
+
+.include <bsd.port.mk>
diff --git a/audio/libdjinterop/distinfo b/audio/libdjinterop/distinfo
new file mode 100644
index 000000000000..d0b569660170
--- /dev/null
+++ b/audio/libdjinterop/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1710352228
+SHA256 (xsco-libdjinterop-0.20.1_GH0.tar.gz) = 69bdbd0e68f12858b79795a76a6023962f93f819ca36ea56a9d4680901865d13
+SIZE (xsco-libdjinterop-0.20.1_GH0.tar.gz) = 2463673
diff --git a/audio/libdjinterop/pkg-descr b/audio/libdjinterop/pkg-descr
new file mode 100644
index 000000000000..e084b99227a6
--- /dev/null
+++ b/audio/libdjinterop/pkg-descr
@@ -0,0 +1,6 @@
+libdjinterop is a C++ library that allows access to database formats
+used to store information about DJ record libraries.
+
+This library currently supports:
+
+ Engine Library, as used on "Prime"-series DJ equipment.
diff --git a/audio/libdjinterop/pkg-plist b/audio/libdjinterop/pkg-plist
new file mode 100644
index 000000000000..ea3833e4478f
--- /dev/null
+++ b/audio/libdjinterop/pkg-plist
@@ -0,0 +1,38 @@
+include/djinterop/album_art.hpp
+include/djinterop/config.hpp
+include/djinterop/crate.hpp
+include/djinterop/database.hpp
+include/djinterop/djinterop.hpp
+include/djinterop/engine/engine.hpp
+include/djinterop/engine/engine_version.hpp
+include/djinterop/engine/v2/beat_data_blob.hpp
+include/djinterop/engine/v2/change_log_table.hpp
+include/djinterop/engine/v2/engine_library.hpp
+include/djinterop/engine/v2/information_table.hpp
+include/djinterop/engine/v2/loops_blob.hpp
+include/djinterop/engine/v2/overview_waveform_data_blob.hpp
+include/djinterop/engine/v2/playlist_entity_table.hpp
+include/djinterop/engine/v2/playlist_table.hpp
+include/djinterop/engine/v2/quick_cues_blob.hpp
+include/djinterop/engine/v2/track_data_blob.hpp
+include/djinterop/engine/v2/track_table.hpp
+include/djinterop/exceptions.hpp
+include/djinterop/musical_key.hpp
+include/djinterop/optional.hpp
+include/djinterop/pad_color.hpp
+include/djinterop/performance_data.hpp
+include/djinterop/semantic_version.hpp
+include/djinterop/stream_helper.hpp
+include/djinterop/track.hpp
+include/djinterop/track_snapshot.hpp
+lib/cmake/DjInterop/DjInteropConfig.cmake
+lib/cmake/DjInterop/DjInteropConfigVersion.cmake
+lib/cmake/DjInterop/DjInteropTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/DjInterop/DjInteropTargets.cmake
+lib/cmake/DjInterop/FindPackageHandleStandardArgs.cmake
+lib/cmake/DjInterop/FindPackageMessage.cmake
+lib/cmake/DjInterop/FindSQLite3.cmake
+lib/libdjinterop.so
+lib/libdjinterop.so.0
+lib/libdjinterop.so.%%VERSION%%
+libdata/pkgconfig/djinterop.pc