aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2023-05-10 15:11:05 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2023-05-12 17:15:17 +0000
commit2cbbd136ada7dc9207759b698830d5a9d58b22df (patch)
treea92d83ef91772aec0bb6c6adadfe5890be677640
parentecf9e75299e26e21a88993f2e1a66e036febf278 (diff)
downloadports-2cbbd136ada7dc9207759b698830d5a9d58b22df.tar.gz
ports-2cbbd136ada7dc9207759b698830d5a9d58b22df.zip
lang/gcc11: Work around aarch64 extraction bug
Extraction fails with poudriere on aarch64 with the following error: => SHA256 Checksum OK for gcc-11.3.0.tar.xz. tar: Pathname can't be converted from UTF-8 to current locale. tar: Pathname can't be converted from UTF-8 to current locale. tar: Error exit delayed from previous errors. Enforcing use of bsdtar works around the issue. The issue is specific to lang/gcc11 and lang/gcc12: no other GCC port is affected. See also bug https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=246670. PR: 271052 Reported by: Vidar Karlsen <vidar@karlsen.tech> Reviewed by: gerald, mikael (cherry picked from commit 22530ba28be79b947e617dc1288896bfc3c6f6ef)
-rw-r--r--lang/gcc11/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/lang/gcc11/Makefile b/lang/gcc11/Makefile
index ab6d3d08bd34..be843694e895 100644
--- a/lang/gcc11/Makefile
+++ b/lang/gcc11/Makefile
@@ -62,6 +62,15 @@ CONFIGURE_ARGS+= --disable-multilib
.include <bsd.port.pre.mk>
+# Extraction fails with poudriere on aarch64 for GCC 11.
+# It seems that the bug is specific to lang/gcc11 and lang/gcc12 only.
+# No other GCC port is affected.
+# See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=271052
+# and https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=246670
+.if ${ARCH} == aarch64
+EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
+.endif
+
.if ${ARCH} == amd64
CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}