aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:42:37 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:20:33 +0000
commit2cc3f326bd5a2a1f027e4ee98e19889760aac051 (patch)
treef09ce3559dbcbb5cc024a9e76c34380e2c78fa97
parent1540c3bc0f4d64eab8fd53f33d9804b86a4c666a (diff)
downloadports-2cc3f326bd5a2a1f027e4ee98e19889760aac051.tar.gz
ports-2cc3f326bd5a2a1f027e4ee98e19889760aac051.zip
devel/py-canonicaljson: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-canonicaljson/Makefile8
-rw-r--r--devel/py-canonicaljson/files/setup.py3
2 files changed, 4 insertions, 7 deletions
diff --git a/devel/py-canonicaljson/Makefile b/devel/py-canonicaljson/Makefile
index 1b6e1c8e19a0..b716d1fbb4cc 100644
--- a/devel/py-canonicaljson/Makefile
+++ b/devel/py-canonicaljson/Makefile
@@ -1,5 +1,6 @@
PORTNAME= canonicaljson
PORTVERSION= 1.6.4
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,11 +12,13 @@ WWW= https://github.com/matrix-org/python-canonicaljson
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=35.0.2:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>=3.14.0:devel/py-simplejson@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}frozendict>=1.0:devel/py-frozendict@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils pytest
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
@@ -30,7 +33,4 @@ FROZENDICT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}frozendict>=1.0:devel/py-frozendi
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=4.0.0:devel/py-typing-extensions@${PY_FLAVOR}
.endif
-post-patch:
- @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
-
.include <bsd.port.post.mk>
diff --git a/devel/py-canonicaljson/files/setup.py b/devel/py-canonicaljson/files/setup.py
deleted file mode 100644
index 606849326a40..000000000000
--- a/devel/py-canonicaljson/files/setup.py
+++ /dev/null
@@ -1,3 +0,0 @@
-from setuptools import setup
-
-setup()