aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-07-11 17:30:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-07-11 17:50:21 +0000
commit2cd2a67dd6d3ec8bab963ffdd3dc14b3499a9c42 (patch)
treec0ff2f920cf0c270064d7ea5976b2c31e5769567
parent4109f93d01ca3756dc0f7cb31a72bfbe9203dfd2 (diff)
downloadports-2cd2a67dd6d3ec8bab963ffdd3dc14b3499a9c42.tar.gz
ports-2cd2a67dd6d3ec8bab963ffdd3dc14b3499a9c42.zip
audio/zita-dpl1: New port: Look-ahead digital peak level limiter
-rw-r--r--audio/Makefile1
-rw-r--r--audio/zita-dpl1/Makefile28
-rw-r--r--audio/zita-dpl1/distinfo3
-rw-r--r--audio/zita-dpl1/files/patch-Makefile11
-rw-r--r--audio/zita-dpl1/pkg-descr4
-rw-r--r--audio/zita-dpl1/pkg-plist5
6 files changed, 52 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index d3b427a3c3c0..b9ab4c6f7df8 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -872,6 +872,7 @@
SUBDIR += yoshimi
SUBDIR += zam-plugins-lv2
SUBDIR += zita-convolver
+ SUBDIR += zita-dpl1
SUBDIR += zita-njbridge
SUBDIR += zita-resampler
SUBDIR += zrythm
diff --git a/audio/zita-dpl1/Makefile b/audio/zita-dpl1/Makefile
new file mode 100644
index 000000000000..e878dbe9a0be
--- /dev/null
+++ b/audio/zita-dpl1/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= zita-dpl1
+DISTVERSION= 0.3.3
+CATEGORIES= audio
+MASTER_SITES= https://kokkinizita.linuxaudio.org/linuxaudio/downloads/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Look-ahead digital peak level limiter
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/../COPYING
+
+LIB_DEPENDS= libclthreads.so:devel/clthreads \
+ libclxclient.so:devel/clxclient \
+ libjack.so:audio/jack \
+ libpng16.so:graphics/png
+
+USES= gmake gnome localbase:ldflags pkgconfig tar:bz2 xorg
+USE_GNOME= cairo
+USE_XORG= x11 xft
+
+WRKSRC_SUBDIR= source
+
+CFLAGS+= `pkg-config --cflags xft` # workaround for incorrect and incomplete use of pkg-config by the project
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/audio/zita-dpl1/distinfo b/audio/zita-dpl1/distinfo
new file mode 100644
index 000000000000..aca8a2956c02
--- /dev/null
+++ b/audio/zita-dpl1/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1625993524
+SHA256 (zita-dpl1-0.3.3.tar.bz2) = 17a0420aa377fe1965dc7dfd958da979ed1dd275d4a5613bd15110e7f307b674
+SIZE (zita-dpl1-0.3.3.tar.bz2) = 45789
diff --git a/audio/zita-dpl1/files/patch-Makefile b/audio/zita-dpl1/files/patch-Makefile
new file mode 100644
index 000000000000..cfd7bf94396f
--- /dev/null
+++ b/audio/zita-dpl1/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2021-07-11 17:27:21 UTC
++++ Makefile
+@@ -25,7 +25,7 @@ SHARED ?= $(PREFIX)/share/zita-dpl1
+ VERSION = 0.3.3
+ CPPFLAGS += -MMD -MP -DVERSION=\"$(VERSION)\" -DSHARED=\"$(SHARED)\"
+ CXXFLAGS += -O2 -Wall -ffast-math -pthread
+-CXXFLAGS += -march=native
++CXXFLAGS += $(FREEBSD_CXXFLAGS_SIMD)
+
+
+ all: zita-dpl1
diff --git a/audio/zita-dpl1/pkg-descr b/audio/zita-dpl1/pkg-descr
new file mode 100644
index 000000000000..9c5311f44b42
--- /dev/null
+++ b/audio/zita-dpl1/pkg-descr
@@ -0,0 +1,4 @@
+Zita-dpl1 is a look-ahead digital peak level limiter using some special
+algorithms to allow fast response without excessive LF distortion.
+
+WWW: https://kokkinizita.linuxaudio.org/linuxaudio/zita-dpl1-doc/quickguide.html
diff --git a/audio/zita-dpl1/pkg-plist b/audio/zita-dpl1/pkg-plist
new file mode 100644
index 000000000000..bcbec684e07e
--- /dev/null
+++ b/audio/zita-dpl1/pkg-plist
@@ -0,0 +1,5 @@
+bin/zita-dpl1
+%%DATADIR%%/hmeter0.png
+%%DATADIR%%/hmeter1.png
+%%DATADIR%%/parsect.png
+%%DATADIR%%/redzita.png