aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2021-04-27 09:53:36 +0000
committerMathieu Arnold <mat@FreeBSD.org>2021-04-29 09:39:47 +0000
commit2d719a7528bd1ca4e1e031b18227f8669db280fe (patch)
treebebb354457566ce7de6316788044e3fdff71f8cf
parent92ca026aa01c31fb1484a2202938e637dcd8acc3 (diff)
downloadports-2d719a7528bd1ca4e1e031b18227f8669db280fe.tar.gz
ports-2d719a7528bd1ca4e1e031b18227f8669db280fe.zip
Update to 9.16.15.
MFH: 2021Q2 Security: CVE-2021-25214 Security: CVE-2021-25215 Security: CVE-2021-25216 Sponsored by: Absolight
-rw-r--r--dns/bind916/Makefile2
-rw-r--r--dns/bind916/distinfo6
-rw-r--r--dns/bind916/files/extrapatch-bind-min-override-ttl12
-rw-r--r--dns/bind916/files/patch-configure8
4 files changed, 14 insertions, 14 deletions
diff --git a/dns/bind916/Makefile b/dns/bind916/Makefile
index 8bc168d6efea..5598d3caa641 100644
--- a/dns/bind916/Makefile
+++ b/dns/bind916/Makefile
@@ -40,7 +40,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= compiler:c11 cpe libedit pkgconfig ssl tar:xz
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.16.13
+ISCVERSION= 9.16.15
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind916/distinfo b/dns/bind916/distinfo
index f8676a064949..2e1c70422787 100644
--- a/dns/bind916/distinfo
+++ b/dns/bind916/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1616162959
-SHA256 (bind-9.16.13.tar.xz) = a54cc793fa5b69b35f610f2095760f8238dff5cfd52419f7ee1c9c227da4cc08
-SIZE (bind-9.16.13.tar.xz) = 5028340
+TIMESTAMP = 1619513348
+SHA256 (bind-9.16.15.tar.xz) = 98b6f432d878a7bf8f57eb7b3c28be27278cf6b9989154bfe6c81104b38e7839
+SIZE (bind-9.16.15.tar.xz) = 5025688
diff --git a/dns/bind916/files/extrapatch-bind-min-override-ttl b/dns/bind916/files/extrapatch-bind-min-override-ttl
index 755dc8db3166..0fa5d5fd7dac 100644
--- a/dns/bind916/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind916/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2021-03-11 13:20:59 UTC
+--- bin/named/config.c.orig 2021-04-19 13:45:50 UTC
+++ bin/named/config.c
@@ -180,6 +180,7 @@ options {\n\
notify-source *;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2021-03-11 13:20:59 UTC
+--- bin/named/server.c.orig 2021-04-19 13:45:50 UTC
+++ bin/named/server.c
-@@ -4353,6 +4353,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4364,6 +4364,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2021-03-11 13:20:59 UTC
+--- lib/dns/include/dns/view.h.orig 2021-04-19 13:45:50 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,7 +34,7 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2021-03-11 13:20:59 UTC
+--- lib/dns/resolver.c.orig 2021-04-19 13:45:50 UTC
+++ lib/dns/resolver.c
@@ -6477,6 +6477,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
}
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2021-03-11 13:20:59 UTC
+--- lib/isccfg/namedconf.c.orig 2021-04-19 13:45:50 UTC
+++ lib/isccfg/namedconf.c
@@ -2047,6 +2047,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
diff --git a/dns/bind916/files/patch-configure b/dns/bind916/files/patch-configure
index e4ca7e96bb34..acd2d5d131a4 100644
--- a/dns/bind916/files/patch-configure
+++ b/dns/bind916/files/patch-configure
@@ -1,8 +1,8 @@
Fixup gssapi and db detection.
---- configure.orig 2021-03-11 13:20:59 UTC
+--- configure.orig 2021-04-19 13:45:50 UTC
+++ configure
-@@ -17761,27 +17761,9 @@ done
+@@ -17758,27 +17758,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -32,7 +32,7 @@ Fixup gssapi and db detection.
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -17824,47 +17806,7 @@ $as_echo "no" >&6; } ;;
+@@ -17821,47 +17803,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -81,7 +81,7 @@ Fixup gssapi and db detection.
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -23263,7 +23205,7 @@ $as_echo "" >&6; }
+@@ -23231,7 +23173,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).