aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2023-03-24 10:35:17 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2023-03-24 10:41:01 +0000
commit2e30b7de00f398f5e636bb3ca3586fe3172bcad5 (patch)
treee7a439c676ca9d49abb1d7735263bf68df1933e4
parentb176900dee70e78d73e6d104518d7ebb2c35120f (diff)
downloadports-2e30b7de00f398f5e636bb3ca3586fe3172bcad5.tar.gz
ports-2e30b7de00f398f5e636bb3ca3586fe3172bcad5.zip
textproc/py-python-lsp-server: Update to 1.7.1
Releases v1.7.0 and v1.7.1 with the following new features and changes: - Add a new plugin to provide autoimport functionality (disabled by default) - Add progress reporting - Make jedi_definition plugin follow definitions to pyi files - Add support for flake8 version 6 - Add support for Yapf ignore patterns - Add mccabe setting to flake8 plugin - Fixes an error with the Pydocstyle 6.2.0+ - Includes missing Pylint "information" category - Improves Jedi file completions for directories The port changes from distutils to pep517 and again removes some version limitations of dependencies. Changelog: https://github.com/python-lsp/python-lsp-server/releases/tag/v1.7.0 https://github.com/python-lsp/python-lsp-server/releases/tag/v1.7.1
-rw-r--r--textproc/py-python-lsp-server/Makefile9
-rw-r--r--textproc/py-python-lsp-server/distinfo6
-rw-r--r--textproc/py-python-lsp-server/files/patch-pyproject.toml44
3 files changed, 34 insertions, 25 deletions
diff --git a/textproc/py-python-lsp-server/Makefile b/textproc/py-python-lsp-server/Makefile
index 28e356099b6a..5f5ba3614732 100644
--- a/textproc/py-python-lsp-server/Makefile
+++ b/textproc/py-python-lsp-server/Makefile
@@ -1,6 +1,5 @@
PORTNAME= python-lsp-server
-PORTVERSION= 1.6.0
-PORTREVISION= 3
+PORTVERSION= 1.7.1
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -39,13 +38,15 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR}
pylint${PYTHON_PKGNAMESUFFIX}>0:devel/pylint@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}rope>0:devel/py-rope@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}whatthepatch>0:textproc/py-whatthepatch@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yapf>0:textproc/py-yapf@${PY_FLAVOR} \
${PYNUMPY}
-# make test: 2 failed, 136 passed, 8 skipped, 18 warnings
+# make test: 6 failed, 161 passed, 8 skipped, 21 warnings
+# devel/py-pydocstyle v6.3.0 is too new atm :(
USES= python:3.7+ pytest
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/textproc/py-python-lsp-server/distinfo b/textproc/py-python-lsp-server/distinfo
index 5f052bfc78f6..38d2655e7967 100644
--- a/textproc/py-python-lsp-server/distinfo
+++ b/textproc/py-python-lsp-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1667636520
-SHA256 (python-lsp-server-1.6.0.tar.gz) = d75cdff9027c4212e5b9e861e9a0219219c8e2c69508d9f24949951dabd0dc1b
-SIZE (python-lsp-server-1.6.0.tar.gz) = 85242
+TIMESTAMP = 1679647676
+SHA256 (python-lsp-server-1.7.1.tar.gz) = 67473bb301f35434b5fa8b21fc5ed5fac27dc8a8446ccec8bae456af52a0aef6
+SIZE (python-lsp-server-1.7.1.tar.gz) = 95731
diff --git a/textproc/py-python-lsp-server/files/patch-pyproject.toml b/textproc/py-python-lsp-server/files/patch-pyproject.toml
index d9e4209b1845..ff7f0f829b98 100644
--- a/textproc/py-python-lsp-server/files/patch-pyproject.toml
+++ b/textproc/py-python-lsp-server/files/patch-pyproject.toml
@@ -1,34 +1,42 @@
---- pyproject.toml.orig 2022-11-02 23:27:35 UTC
+--- pyproject.toml.orig 2023-01-06 23:50:19 UTC
+++ pyproject.toml
-@@ -27,23 +27,23 @@ all = [
+@@ -27,26 +27,26 @@ all = [
[project.optional-dependencies]
all = [
- "autopep8>=1.6.0,<1.7.0",
-- "flake8>=5.0.0,<5.1.0",
+- "flake8>=5.0.0,<7",
+- "mccabe>=0.7.0,<0.8.0",
+- "pycodestyle>=2.9.0,<2.11.0",
+- "pydocstyle>=6.2.0,<6.3.0",
+- "pyflakes>=2.5.0,<3.1.0",
+ "autopep8>=1.6.0",
+ "flake8>=5.0.0",
- "mccabe>=0.7.0,<0.8.0",
-- "pycodestyle>=2.9.0,<2.10.0",
++ "mccabe>=0.7.0",
+ "pycodestyle>=2.9.0",
- "pydocstyle>=2.0.0",
-- "pyflakes>=2.5.0,<2.6.0",
++ "pydocstyle>=6.2.0",
+ "pyflakes>=2.5.0",
- "pylint>=2.5.0",
- "rope>=0.10.5",
+ "pylint>=2.5.0,<3",
+ "rope>1.2.0",
"yapf",
- "whatthepatch"
+ "whatthepatch>=1.0.2,<2.0.0"
]
-autopep8 = ["autopep8>=1.6.0,<1.7.0"]
--flake8 = ["flake8>=5.0.0,<5.1.0"]
+-flake8 = ["flake8>=5.0.0,<7"]
+-mccabe = ["mccabe>=0.7.0,<0.8.0"]
+-pycodestyle = ["pycodestyle>=2.9.0,<2.11.0"]
+-pydocstyle = ["pydocstyle>=6.2.0,<6.3.0"]
+-pyflakes = ["pyflakes>=2.5.0,<3.1.0"]
+autopep8 = ["autopep8>=1.6.0"]
+flake8 = ["flake8>=5.0.0"]
- mccabe = ["mccabe>=0.7.0,<0.8.0"]
--pycodestyle = ["pycodestyle>=2.9.0,<2.10.0"]
++mccabe = ["mccabe>=0.7.0"]
+pycodestyle = ["pycodestyle>=2.9.0"]
- pydocstyle = ["pydocstyle>=2.0.0"]
--pyflakes = ["pyflakes>=2.5.0,<2.6.0"]
++pydocstyle = ["pydocstyle>=6.2.0"]
+pyflakes = ["pyflakes>=2.5.0"]
- pylint = ["pylint>=2.5.0"]
- rope = ["rope>0.10.5"]
- yapf = ["yapf", "whatthepatch>=1.0.2,<2.0.0"]
+ pylint = ["pylint>=2.5.0,<3"]
+ rope = ["rope>1.2.0"]
+-yapf = ["yapf", "whatthepatch>=1.0.2,<2.0.0"]
++yapf = ["yapf", "whatthepatch>=1.0.2"]
+ websockets = ["websockets>=10.3"]
+ test = [
+ "pylint>=2.5.0,<3",