aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-10-13 03:02:28 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-10-13 03:02:28 +0000
commit2e6d73e7ccec71b84dc9f103a614d084bbb6bcda (patch)
tree7a50e7bd34b570e6e5514974c9aefd827f9696a8
parentcf4309a33b2d02701748e57793be697f265c2b75 (diff)
downloadports-2e6d73e7ccec71b84dc9f103a614d084bbb6bcda.tar.gz
ports-2e6d73e7ccec71b84dc9f103a614d084bbb6bcda.zip
audio/zrythm: fix build on non-x86
- don't unconditionally enable SSE, it's enable conditionally for amd64 in the main meson.build anyway: cc: warning: argument unused during compilation: '-msse' [-Wunused-command-line-argument] cc: warning: argument unused during compilation: '-msse2' [-Wunused-command-line-argument] error: unknown FP unit 'sse' - disable LTO on powerpc64 since it's broken in LLVM.
-rw-r--r--audio/zrythm/Makefile7
-rw-r--r--audio/zrythm/files/patch-ext_qm-dsp_meson.build12
2 files changed, 18 insertions, 1 deletions
diff --git a/audio/zrythm/Makefile b/audio/zrythm/Makefile
index 0b4437ad1159..733bf955ddbc 100644
--- a/audio/zrythm/Makefile
+++ b/audio/zrythm/Makefile
@@ -56,11 +56,16 @@ SHEBANG_FILES= scripts/collect_translatables.sh
GLIB_SCHEMAS= org.zrythm.Zrythm.gschema.xml
-
LDFLAGS+= ${LOCALBASE}/lib/libfftw3_threads.so ${LOCALBASE}/lib/libfftw3f_threads.so # these libs are required but aren't returned by pkg-config for fftw3
BINARY_ALIAS= git=false python3=${PYTHON_CMD}
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64
+MESON_ARGS= -Db_lto=false
+.endif
+
post-patch: # https://git.zrythm.org/zrythm/zrythm/issues/299
@${REINPLACE_CMD} 's|<malloc.h>|<stdlib.h>|' ${WRKSRC}/ext/midilib/src/*.c
diff --git a/audio/zrythm/files/patch-ext_qm-dsp_meson.build b/audio/zrythm/files/patch-ext_qm-dsp_meson.build
new file mode 100644
index 000000000000..b5249bf0ca47
--- /dev/null
+++ b/audio/zrythm/files/patch-ext_qm-dsp_meson.build
@@ -0,0 +1,12 @@
+--- ext/qm-dsp/meson.build.orig 2021-10-13 01:44:29 UTC
++++ ext/qm-dsp/meson.build
+@@ -39,9 +39,6 @@ qm_dsp_lib = static_library (
+ '-Wall',
+ '-Wextra',
+ '-O3',
+- '-msse',
+- '-msse2',
+- '-mfpmath=sse',
+ '-ftree-vectorize',
+ '-DUSE_PTHREADS',
+ ],