aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2022-04-05 19:41:05 +0000
committerDimitry Andric <dim@FreeBSD.org>2022-04-26 19:10:01 +0000
commit2e829590a96d69731cc0662d048f38e0dc8d79e7 (patch)
treee61700d84cdc3b6f964b738a3a53faad63a536bb
parent7783dde8566e63fe91508b61dced7e54c721cbaa (diff)
downloadports-2e829590a96d69731cc0662d048f38e0dc8d79e7.tar.gz
ports-2e829590a96d69731cc0662d048f38e0dc8d79e7.zip
audio/mumble audio/murmur: fix build with lld 14
During an exp-run for llvm 14 (see bug 261742), it turned out that audio/mumble and audio/murmur fail to build with lld 14: c++ -fstack-protector-strong -pie -Wl,--no-add-needed -Wl,-z,relro -Wl,-z,now -shared -Wl,-soname,libcelt0.so.0 -o libcelt0.so.0.7.0 ../../debug/.obj/celt-0.7.0-build/bands.o ../../debug/.obj/celt-0.7.0-build/celt.o ../../debug/.obj/celt-0.7.0-build/cwrs.o ../../debug/.obj/celt-0.7.0-build/entcode.o ../../debug/.obj/celt-0.7.0-build/entdec.o ../../debug/.obj/celt-0.7.0-build/entenc.o ../../debug/.obj/celt-0.7.0-build/header.o ../../debug/.obj/celt-0.7.0-build/kiss_fft.o ../../debug/.obj/celt-0.7.0-build/kiss_fftr.o ../../debug/.obj/celt-0.7.0-build/laplace.o ../../debug/.obj/celt-0.7.0-build/mdct.o ../../debug/.obj/celt-0.7.0-build/modes.o ../../debug/.obj/celt-0.7.0-build/pitch.o ../../debug/.obj/celt-0.7.0-build/psy.o ../../debug/.obj/celt-0.7.0-build/quant_bands.o ../../debug/.obj/celt-0.7.0-build/rangedec.o ../../debug/.obj/celt-0.7.0-build/rangeenc.o ../../debug/.obj/celt-0.7.0-build/rate.o ../../debug/.obj/celt-0.7.0-build/vq.o -L/usr/lib/x86_64-unknown-freebsd14.0/c++11 -L/usr/lib -L/usr/local/lib c++: warning: argument unused during compilation: '-pie' [-Wunused-command-line-argument] ld: error: unknown argument '--no-add-needed' c++: error: linker command failed with exit code 1 (use -v to see invocation) This is because lld upstream removed the deprecated --no-add-needed option, which should be replaced with --no-copy-dt-needed-entries instead. (Note that BFD ld still accepts the --no-add-needed option, but is also deprecated there, so it might go away.) PR: 263071 Approved by: maintainer timeout (2 weeks) MFH: 2022Q2
-rw-r--r--audio/mumble/Makefile1
-rw-r--r--audio/murmur/Makefile1
2 files changed, 2 insertions, 0 deletions
diff --git a/audio/mumble/Makefile b/audio/mumble/Makefile
index 5670e5ccadb1..34765342962f 100644
--- a/audio/mumble/Makefile
+++ b/audio/mumble/Makefile
@@ -89,6 +89,7 @@ MAKE_JOBS_UNSAFE=yes
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/overlay_gl/overlay_gl.pro
+ @${REINPLACE_CMD} -e 's|--no-add-needed|--no-copy-dt-needed-entries|' ${WRKSRC}/qmake/compiler.pri
@${RM} ${WRKSRC}/plugins/manual/.qmake.cache
do-install:
diff --git a/audio/murmur/Makefile b/audio/murmur/Makefile
index 53bad377571b..678ad3e7a3cd 100644
--- a/audio/murmur/Makefile
+++ b/audio/murmur/Makefile
@@ -61,6 +61,7 @@ CONFIG+= no-pch
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's|--no-add-needed|--no-copy-dt-needed-entries|' ${WRKSRC}/qmake/compiler.pri
@${ECHO_CMD} 'QMAKE_LFLAGS += -fstack-protector' >> ${WRKSRC}/src/murmur/murmur.pro
pre-install: