aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-06 14:56:33 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-06 14:56:33 +0000
commit2ea0c0c9c9156270b3ccddb16f4e613ef932cbb1 (patch)
tree69f9b7c95691ecb05a4111baf949e37c55aa5989
parentbe9acef5e70a10a09a90ad2bed500e3955e865b1 (diff)
downloadports-2ea0c0c9c9156270b3ccddb16f4e613ef932cbb1.tar.gz
ports-2ea0c0c9c9156270b3ccddb16f4e613ef932cbb1.zip
devel/py-libusb1: Update to 1.9.3
- Remove outdated CONFLICTS_INSTALL: devel/py-libusb115 has been removed over 3 years ago - Update pkg-descr - Update WWW - Take maintainership Changes: https://github.com/vpelletier/python-libusb1/blob/master/README.rst#history
-rw-r--r--devel/py-libusb1/Makefile9
-rw-r--r--devel/py-libusb1/distinfo6
-rw-r--r--devel/py-libusb1/files/patch-usb1_____init____.py15
-rw-r--r--devel/py-libusb1/pkg-descr5
4 files changed, 12 insertions, 23 deletions
diff --git a/devel/py-libusb1/Makefile b/devel/py-libusb1/Makefile
index 73b7a19f4dc2..cc662187915e 100644
--- a/devel/py-libusb1/Makefile
+++ b/devel/py-libusb1/Makefile
@@ -1,19 +1,18 @@
PORTNAME= libusb1
-PORTVERSION?= 1.8
+PORTVERSION?= 1.9.3
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Pure-python wrapper for libusb-1.0
LICENSE= LGPL21+
-CONFLICTS_INSTALL?= ${PKGNAMEPREFIX}${PORTNAME}15
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-USES= python:3.6+
-USE_PYTHON= autoplist distutils
do-test:
@${PYTHON_CMD} -m unittest discover -vs ${TEST_WRKSRC}
diff --git a/devel/py-libusb1/distinfo b/devel/py-libusb1/distinfo
index 4f057132206c..625a11e6d887 100644
--- a/devel/py-libusb1/distinfo
+++ b/devel/py-libusb1/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588847526
-SHA256 (libusb1-1.8.tar.gz) = 240f65ac70ba3fab77749ec84a412e4e89624804cb80d6c9d394eef5af8878d6
-SIZE (libusb1-1.8.tar.gz) = 78282
+TIMESTAMP = 1625323581
+SHA256 (libusb1-1.9.3.tar.gz) = 60e6ce37be064f6e51d02b25da44230ecc9c0b1fdb6f14568c71457d963c1749
+SIZE (libusb1-1.9.3.tar.gz) = 81296
diff --git a/devel/py-libusb1/files/patch-usb1_____init____.py b/devel/py-libusb1/files/patch-usb1_____init____.py
index e42cf7f83290..ba2bb144a328 100644
--- a/devel/py-libusb1/files/patch-usb1_____init____.py
+++ b/devel/py-libusb1/files/patch-usb1_____init____.py
@@ -1,19 +1,8 @@
https://lists.freebsd.org/pipermail/freebsd-usb/2015-January/013586.html
---- usb1/__init__.py.orig 2016-11-23 13:07:52 UTC
+--- usb1/__init__.py.orig 2021-07-02 12:59:01 UTC
+++ usb1/__init__.py
-@@ -1830,15 +1830,20 @@ class USBDevice(object):
- """
- Get device's port number.
- """
-- return libusb1.libusb_get_port_number(self.device_p)
-+ try:
-+ return libusb1.libusb_get_port_number(self.device_p)
-+ except AttributeError:
-+ return 0
-
- def getPortNumberList(self):
- """
+@@ -1864,8 +1864,10 @@ class USBDevice(object):
Get the port number of each hub toward device.
"""
port_list = (c_uint8 * PATH_MAX_DEPTH)()
diff --git a/devel/py-libusb1/pkg-descr b/devel/py-libusb1/pkg-descr
index 2d0775142396..fd1a44342638 100644
--- a/devel/py-libusb1/pkg-descr
+++ b/devel/py-libusb1/pkg-descr
@@ -1,3 +1,4 @@
-Pure-python wrapper for libusb-1.0.
+Pure-python wrapper for libusb-1.0 supports all transfer types, both in
+synchronous and asynchronous mode
-WWW: https://pypi.org/project/libusb1/
+WWW: https://github.com/vpelletier/python-libusb1