aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2024-04-01 15:10:04 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-04-01 15:10:42 +0000
commit2eb4487adec45a064417db7a28d670411d6f3a65 (patch)
tree30e411abd1732fcccf5fd6ac23cdf415d3f27e45
parent55e6b1884c7b47cb1a935c666055e0045aa2928a (diff)
downloadports-2eb4487adec45a064417db7a28d670411d6f3a65.tar.gz
ports-2eb4487adec45a064417db7a28d670411d6f3a65.zip
lang/ghc: Fix Hadrian build with BOOT option enabled
Reported by: rene
-rw-r--r--lang/ghc/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 3d64f3d7b49b..0387e4214005 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -174,11 +174,12 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/compat/libncursesw.so.8:misc/compat12x
.if empty(PORT_OPTIONS:MBOOT)
DISTFILES+= ghc-${BOOT_GHC_VERSION}-boot-${ARCH}-freebsd${EXTRACT_SUFX}:boot
-. if !defined(IGNORE_MISSING_HADRIAN) && defined(USE_HADRIAN)
-DISTFILES+= hadrian-${GHC_VERSION}-boot.tar.gz:boot
-. endif
.endif # MBOOT
+.if !defined(IGNORE_MISSING_HADRIAN) && defined(USE_HADRIAN)
+DISTFILES+= hadrian-${GHC_VERSION}-boot.tar.gz:boot
+.endif
+
.if ${ARCH} == aarch64 || ${ARCH:Marmv*}
# ghc-8.10.x on arm requires devel/llvm10
# CONFIGURE_TARGET must to be the same as the llvm triple