aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2022-07-22 19:02:22 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2022-08-07 05:33:41 +0000
commit2ec30f23b3bb475e3dfd4022c992ab53f2076055 (patch)
tree4dc02c0e472af4a812dee63ad7ce98b73b55682f
parent3c738e904d25bd46b9c4b8e97e1d37ca59c5c322 (diff)
downloadports-2ec30f23b3bb475e3dfd4022c992ab53f2076055.tar.gz
ports-2ec30f23b3bb475e3dfd4022c992ab53f2076055.zip
sysutils/bsdstats: Set timeout to wait response from server
Currently 300.statistics hangs up if server accepts connection but doesn't respond to the request. So set timeout to wait response from server. PR: 265389 Approved by: maintainer timeout MFH: 2022Q3 (cherry picked from commit 206e447a8330a3dba38f4e4a1210f4f04eb7e783)
-rw-r--r--sysutils/bsdstats/Makefile2
-rw-r--r--sysutils/bsdstats/files/300.statistics.in2
2 files changed, 2 insertions, 2 deletions
diff --git a/sysutils/bsdstats/Makefile b/sysutils/bsdstats/Makefile
index e696ed85b68e..cd38ddc5150f 100644
--- a/sysutils/bsdstats/Makefile
+++ b/sysutils/bsdstats/Makefile
@@ -2,7 +2,7 @@
PORTNAME= bsdstats
PORTVERSION= 7.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
DISTFILES=
diff --git a/sysutils/bsdstats/files/300.statistics.in b/sysutils/bsdstats/files/300.statistics.in
index 0985059d5555..e23df42fb224 100644
--- a/sysutils/bsdstats/files/300.statistics.in
+++ b/sysutils/bsdstats/files/300.statistics.in
@@ -151,7 +151,7 @@ do_http_request() {
if [ -n "${body}" ]; then txt="${txt}${CR}${NL}Content-Length: ${#body}"; fi
txt="${txt}${CR}${NL}${CR}${NL}${body}"
- resp=$(echo "${txt}" | nlog "out" | ${NC} ${nc_host} ${nc_port} | nlog "in" 2>/dev/null)
+ resp=$(echo "${txt}" | nlog "out" | ${NC} -w ${timeout} ${nc_host} ${nc_port} | nlog "in" 2>/dev/null)
if [ $? -ne 0 ]; then
if [ ${do_log} -ne 0 ]; then
log "FAIL" "Failed to send data to the host ${nc_host}:${nc_port}, is network or host down?"