aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2022-04-17 08:17:52 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2022-04-18 11:59:07 +0000
commit2fefa005e84720bef29a3765c3d313113c930d7e (patch)
tree77ad2b9fe3d893f2d5f9ba870e47126445de788a
parent8b454642f100a1ad6f6cc262c646bacd2548b4f2 (diff)
downloadports-2fefa005e84720bef29a3765c3d313113c930d7e.tar.gz
ports-2fefa005e84720bef29a3765c3d313113c930d7e.zip
devel/py-pytest-markdown: New port
You have written a README.md. In contains some of your best words. They are in an order, and you are happy its a good order. But all those code blocks... Do they contain valid python? This plugin will find tests in your markdown files and run them.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-markdown/Makefile21
-rw-r--r--devel/py-pytest-markdown/distinfo3
-rw-r--r--devel/py-pytest-markdown/pkg-descr6
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7b06d26e73c1..01e239246657 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5092,6 +5092,7 @@
SUBDIR += py-pytest-isort
SUBDIR += py-pytest-lazy-fixture
SUBDIR += py-pytest-localserver
+ SUBDIR += py-pytest-markdown
SUBDIR += py-pytest-metadata
SUBDIR += py-pytest-mock
SUBDIR += py-pytest-mutagen
diff --git a/devel/py-pytest-markdown/Makefile b/devel/py-pytest-markdown/Makefile
new file mode 100644
index 000000000000..75c4d60c8959
--- /dev/null
+++ b/devel/py-pytest-markdown/Makefile
@@ -0,0 +1,21 @@
+
+PORTNAME= pytest-markdown
+PORTVERSION= 1.0.2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pytest_markdown-${PORTVERSION}
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= Test your markdown docs with pytest
+
+LICENSE= APACHE20
+
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=6.0.1:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}CommonMark>=0.9.1:textproc/py-CommonMark@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest-markdown/distinfo b/devel/py-pytest-markdown/distinfo
new file mode 100644
index 000000000000..a384aeb797c3
--- /dev/null
+++ b/devel/py-pytest-markdown/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1650118193
+SHA256 (pytest_markdown-1.0.2.tar.gz) = 79816bb35a56e20693bab2257e4f1795df6f8f2bc9c2a9f54da687a115c01f35
+SIZE (pytest_markdown-1.0.2.tar.gz) = 2991
diff --git a/devel/py-pytest-markdown/pkg-descr b/devel/py-pytest-markdown/pkg-descr
new file mode 100644
index 000000000000..e7b2caa2090e
--- /dev/null
+++ b/devel/py-pytest-markdown/pkg-descr
@@ -0,0 +1,6 @@
+You have written a README.md. In contains some of your best words. They are in
+an order, and you are happy its a good order. But all those code blocks... Do
+they contain valid python? This plugin will find tests in your markdown files
+and run them.
+
+WWW: https://github.com/Jc2k/pytest-markdown