aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2024-03-14 10:27:39 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2024-03-15 13:08:51 +0000
commit3108cacee82c9282e0002b5d044395b7c26dcb3e (patch)
treefadec576a66f855be4c1fc3a1f853e85baa6311a
parent730f1fd28f4f55554d0e5e7828f8e7a428b87450 (diff)
downloadports-3108cacee82c9282e0002b5d044395b7c26dcb3e.tar.gz
ports-3108cacee82c9282e0002b5d044395b7c26dcb3e.zip
net/pen: fix distfile upload
The host that supplies the source for this port rejects requests by fetch(1). This commit fix that by replacing fetch's user agent with curl/7.68.0 Also apply portfmt linter PR: 277397 Reported by: Chris Hutchinson <portmaster@bsdforge.com> (maintainer)
-rw-r--r--net/pen/Makefile44
1 files changed, 27 insertions, 17 deletions
diff --git a/net/pen/Makefile b/net/pen/Makefile
index 568bb0606c40..5a5ee96f4e32 100644
--- a/net/pen/Makefile
+++ b/net/pen/Makefile
@@ -12,32 +12,42 @@ LICENSE= GPLv2
USES= cpe ssl
CPE_VENDOR= ${PORTNAME}_project
-
-GNU_CONFIGURE= yes
-GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
USE_RC_SUBR= pen
-CONFIGURE_ARGS= --with-daemon --with-docdir=${DOCSDIR} --without-geoip \
- --with-ssl=${OPENSSLBASE}
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-
-PORTDOCS= penstats HOWTO AUTHORS README ChangeLog COPYING
-PLIST_FILES= bin/mergelogs bin/pen bin/penctl bin/penlog \
- bin/penlogd share/man/man1/mergelogs.1.gz \
- share/man/man1/pen.1.gz share/man/man1/penctl.1.gz \
- share/man/man1/penlog.1.gz share/man/man1/penlogd.1.gz
-OPTIONS_DEFINE= DEBUG DOCS KQUEUE
-OPTIONS_DEFAULT=KQUEUE
-KQUEUE_DESC= Use kqueue backend
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
+CONFIGURE_ARGS= --with-daemon \
+ --with-docdir=${DOCSDIR} \
+ --with-ssl=${OPENSSLBASE} \
+ --without-geoip
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+
+FETCH_ARGS+= --user-agent=curl/7.68.0
+
+PLIST_FILES= bin/mergelogs \
+ bin/pen \
+ bin/penctl \
+ bin/penlog \
+ bin/penlogd \
+ share/man/man1/mergelogs.1.gz \
+ share/man/man1/pen.1.gz \
+ share/man/man1/penctl.1.gz \
+ share/man/man1/penlog.1.gz \
+ share/man/man1/penlogd.1.gz
+PORTDOCS= AUTHORS COPYING ChangeLog HOWTO README penstats
+
+OPTIONS_DEFINE= DEBUG DOCS KQUEUE
+OPTIONS_DEFAULT= KQUEUE
+KQUEUE_DESC= Use kqueue backend
.if defined(WITH_FDSETSIZE)
CONFIGURE_ARGS+= --with-fd_setsize=${WITH_FDSETSIZE}
.endif
+DEBUG_CONFIGURE_ENABLE= debugging
KQUEUE_CONFIGURE_ON= --with-kqueue
KQUEUE_CONFIGURE_OFF= --with-poll
-DEBUG_CONFIGURE_ENABLE= debugging
post-patch:
@${REINPLACE_CMD} 's/-pg//' ${WRKSRC}/configure